summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_musicindex/mod_musicindex-1.4.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_musicindex/mod_musicindex-1.4.1.ebuild')
-rw-r--r--www-apache/mod_musicindex/mod_musicindex-1.4.1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/www-apache/mod_musicindex/mod_musicindex-1.4.1.ebuild b/www-apache/mod_musicindex/mod_musicindex-1.4.1.ebuild
new file mode 100644
index 000000000000..ed79e8f4f3b2
--- /dev/null
+++ b/www-apache/mod_musicindex/mod_musicindex-1.4.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit apache-module
+
+DESCRIPTION="mod_musicindex allows nice displaying of directories containing music files"
+HOMEPAGE="http://www.parisc-linux.org/~varenet/musicindex/"
+SRC_URI="http://hacks.slashdirt.org/musicindex/${P}.tar.gz
+ http://validator.w3.org/feed/images/valid-rss.png -> ${P}_valid-rss.png
+ http://jigsaw.w3.org/css-validator/images/vcss -> ${P}_vcss
+ http://www.w3.org/Icons/valid-xhtml11 -> ${P}_valid-xhtml11"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mp3 +mp4 +flac +vorbis +cache mysql archive"
+
+DEPEND="mp3? ( media-libs/libmad media-libs/libid3tag )
+ mp4? ( media-libs/libmp4v2:0 )
+ flac? ( media-libs/flac )
+ vorbis? ( media-libs/libvorbis )
+ archive? ( app-arch/libarchive )
+ mysql? ( virtual/mysql )"
+RDEPEND="${DEPEND}
+ sys-devel/libtool"
+
+APACHE2_MOD_CONF="50_${PN}"
+APACHE2_MOD_DEFINE="MUSICINDEX"
+DOCFILES="AUTHORS BUGS ChangeLog README UPGRADING"
+
+need_apache2
+
+src_configure() {
+ econf \
+ $(use_enable mp3) \
+ $(use_enable mp4) \
+ $(use_enable flac) \
+ $(use_enable vorbis) \
+ $(use_enable archive) \
+ $(use_enable cache filecache) \
+ $(use_enable mysql mysqlcache)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ apache-module_src_install
+
+ # install W3C images
+ insinto /usr/share/mod_musicindex
+ newins "${DISTDIR}/${P}_valid-rss.png" valid-rss.png
+ newins "${DISTDIR}/${P}_valid-xhtml11" valid-xhtml11
+ newins "${DISTDIR}/${P}_vcss" vcss
+}