summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-11-22 16:53:21 -0500
committerCraig Andrews <candrews@gentoo.org>2021-11-22 16:55:12 -0500
commit5793bcf7eeb4074216418683d54b9672c20d95ba (patch)
tree87a09d6d1d7f2700b77d72d30eeac3815c811b49 /www-apache/mod_qos
parentapp-admin/gnome-system-log: update EAPI 5 -> 7 (diff)
downloadgentoo-5793bcf7eeb4074216418683d54b9672c20d95ba.tar.gz
gentoo-5793bcf7eeb4074216418683d54b9672c20d95ba.tar.bz2
gentoo-5793bcf7eeb4074216418683d54b9672c20d95ba.zip
www-apache/mod_qos: 11.70 version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache/mod_qos')
-rw-r--r--www-apache/mod_qos/Manifest1
-rw-r--r--www-apache/mod_qos/mod_qos-11.70.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/www-apache/mod_qos/Manifest b/www-apache/mod_qos/Manifest
index 85d10ac890ca..4d0bcad71277 100644
--- a/www-apache/mod_qos/Manifest
+++ b/www-apache/mod_qos/Manifest
@@ -4,3 +4,4 @@ DIST mod_qos-11.66.tar.gz 1247819 BLAKE2B a835722363a816637411b434eba60bc91f04fe
DIST mod_qos-11.67.tar.gz 1282401 BLAKE2B 60d608f1e26fd2a50b1d48cad64210bb3aefc4397ce9cec302ac04fde2f8e6d1b781707509ad0ab1ce83bc8254f4b86d6de2d0f113f3000156fe81beb8df41f2 SHA512 3391d05917bdab6218774b886d7bf9f5be628525d53c91b14586f6870386f1cc333cc83340339f4ccf1918e22a2a55a5984b99643e581b63298a173e95c20e4b
DIST mod_qos-11.68.tar.gz 1282547 BLAKE2B c4067afa20e2e5e9a0d14a5f96bbcdd5ac4d1e337373dd3ca67960f888edd8340942285f455fc418d554d3a17150cc0417ccaf06be18f41549877fed4378b809 SHA512 e49d643eb1f8210feebb8067ee84154c7334a0a0d2365aa297621ce505057046d744cfbf87aaf0a023248979f3576c083b43066c89614e0fb7c564f09bbfe773
DIST mod_qos-11.69.tar.gz 1282840 BLAKE2B c0fe81b116b7d39409ec5cf87e35bb7843a0dfb4cd76a6b3ac169d96557e40a04bb06b834ba6cf2988ac3fee3e911e623bfb950cef4cea1500334addaacfe8de SHA512 e6daf7e5d267d9676c151ce2bc26347073dc89ebb49796bf843e4d9698b3dc542bcf4c7f979c9b4017f7277778f264790629e60b7ee6547e4754838e9fe4f3f4
+DIST mod_qos-11.70.tar.gz 1283241 BLAKE2B 516dc8ec0228956c374845e10ed2533291544c496a1eda693da28d551b81f83ab898384a627b87c940782925c5bc84f1140e4e241c964b451acb63fd947a274d SHA512 004898d7993cda82f261d28e4c91b1ff1665465d3ad1da005fae94471824a31f0d30ca4edf700ddb45bfde133218c55d49a396ba03b3ed0ac00b1743c4aaa5be
diff --git a/www-apache/mod_qos/mod_qos-11.70.ebuild b/www-apache/mod_qos/mod_qos-11.70.ebuild
new file mode 100644
index 000000000000..412c8e3c8eb5
--- /dev/null
+++ b/www-apache/mod_qos/mod_qos-11.70.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools apache-module
+
+DESCRIPTION="A QOS module for the apache webserver"
+HOMEPAGE="http://mod-qos.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mod-qos/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libpcre:3
+ dev-libs/openssl:0=
+ media-libs/libpng:0=
+ sys-libs/zlib:0=
+"
+DEPEND="${RDEPEND}"
+
+APXS2_S="${S}/apache2"
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="QOS"
+DOCFILES="${S}/doc/*.txt ${S}/README.TXT"
+
+need_apache2
+
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}
+src_prepare() {
+ default
+
+ pushd "${S}"/tools &>/dev/null || die
+ eautoreconf
+ popd &>/dev/null || die
+}
+
+src_configure() {
+ pushd "${S}"/tools &>/dev/null || die
+ econf
+ popd &>/dev/null || die
+}
+
+src_compile() {
+ apache-module_src_compile
+ emake -C "${S}"/tools
+}
+
+src_install() {
+ einfo "Installing Apache module ..."
+ pushd "${S}"/tools &>/dev/null || die
+ apache-module_src_install
+ popd &>/dev/null || die
+
+ einfo "Installing module utilities ..."
+ emake -C "${S}"/tools install DESTDIR="${D}"
+}