summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2021-02-08 14:43:32 +0100
committerDirkjan Ochtman <djc@gentoo.org>2021-02-08 14:44:34 +0100
commited320c5426c615d428641419128653ad05fc49ea (patch)
tree23664cb9d0def8daa6ab5e15a5d17207111c663f /www-apache/mod_wsgi
parentsys-apps/usbguard: Fix dev-libs/pegtl dependency (diff)
downloadgentoo-ed320c5426c615d428641419128653ad05fc49ea.tar.gz
gentoo-ed320c5426c615d428641419128653ad05fc49ea.tar.bz2
gentoo-ed320c5426c615d428641419128653ad05fc49ea.zip
www-apache/mod_wsgi: revbump to add python3.9 compat
Fixes: https://bugs.gentoo.org/show_bug.cgi?id=768642 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Dirkjan Ochtman <djc@gentoo.org>
Diffstat (limited to 'www-apache/mod_wsgi')
-rw-r--r--www-apache/mod_wsgi/mod_wsgi-4.7.1-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/www-apache/mod_wsgi/mod_wsgi-4.7.1-r1.ebuild b/www-apache/mod_wsgi/mod_wsgi-4.7.1-r1.ebuild
new file mode 100644
index 000000000000..609e961c96ea
--- /dev/null
+++ b/www-apache/mod_wsgi/mod_wsgi-4.7.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit apache-module eutils python-single-r1
+
+DESCRIPTION="An Apache2 module for running Python WSGI applications"
+HOMEPAGE="https://github.com/GrahamDumpleton/mod_wsgi"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+
+APACHE2_MOD_CONF="70_${PN}"
+APACHE2_MOD_DEFINE="WSGI"
+APACHE2_MOD_FILE="${S}/src/server/.libs/${PN}.so"
+
+DOCFILES="README.rst"
+
+need_apache2
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ # Calling depend.apache_pkg_setup fails because we do not have
+ # "apache2" in IUSE but the function expects this in order to call
+ # _init_apache2_late which sets the APACHE_MODULESDIR variable.
+ _init_apache2
+ _init_apache2_late
+}
+
+src_configure() {
+ # configure.ac contains bashisms
+ # (https://github.com/GrahamDumpleton/mod_wsgi/issues/567)
+ CONFIG_SHELL="/bin/bash" \
+ econf --with-apxs="${APXS}" --with-python="${PYTHON}"
+}
+
+src_compile() {
+ default
+}