summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2016-04-27 00:13:33 +1000
committerSam Jorna <wraeth@gentoo.org>2016-04-27 00:17:19 +1000
commit33da93895c529ba8e8deb8dfd52f077c401d06ee (patch)
tree3598641211ccb4260c06102c7d3ebcac4997e82e /www-apache/mod_xml2enc
parentwww-apache/mod_xml2enc: assign proxy maintainer (diff)
downloadgentoo-33da93895c529ba8e8deb8dfd52f077c401d06ee.tar.gz
gentoo-33da93895c529ba8e8deb8dfd52f077c401d06ee.tar.bz2
gentoo-33da93895c529ba8e8deb8dfd52f077c401d06ee.zip
www-apache/mod_xml2enc: bump to 1.0.4, add config
Bumps to v1.0.4 as well as adds an apache modules.d config to enable. Original config file contributed by user Matthew Smith and updated by maintainer Russell Knighton along with version bump. Gentoo-bug: 575410 Package-Manager: portage-2.2.28
Diffstat (limited to 'www-apache/mod_xml2enc')
-rw-r--r--www-apache/mod_xml2enc/Manifest2
-rw-r--r--www-apache/mod_xml2enc/files/26_mod_xml2enc.conf4
-rw-r--r--www-apache/mod_xml2enc/mod_xml2enc-1.0.4.ebuild39
3 files changed, 45 insertions, 0 deletions
diff --git a/www-apache/mod_xml2enc/Manifest b/www-apache/mod_xml2enc/Manifest
index 61b411dfa8eb..0884d011c0fc 100644
--- a/www-apache/mod_xml2enc/Manifest
+++ b/www-apache/mod_xml2enc/Manifest
@@ -1,2 +1,4 @@
+DIST mod_xml2enc-1.0.4.c 22380 SHA256 54d2d82c54f60e73eaddb69c00d2fd7be1786c449d5c7bbe045b30e56d19ba24 SHA512 b38d81ff419e9c00e302eb555715181cf2157af2d15a15b86d34f948c0c2f55de237234a24140b9fc2c1d3d46d688c4e9c4ab74af34b451677224a30b1b08582 WHIRLPOOL 6c925558f56f3f4c934ab6b50f055bac15eaf09a837500aae900d9c451ab357bc53f0d1c44759f4eb66f5c17d91a46f64cd9467c7a50d2dd8aa6d812bc2340d2
+DIST mod_xml2enc-1.0.4.h 1479 SHA256 3a4106a2de484812b6c98aa0845333be83e5f659eebe37678986b8829ee3d4a9 SHA512 01961c3f788ad4a53c2c8f4d9ddebb0333e75b8589df0ab0eb80b53ce781fa5d34b7908d082feeedc7d8a8582a8b798af26b9af107423dad99b83df5c6d5e7d3 WHIRLPOOL 539350c39c7198240cd7eabd43c3bce26d15456064b6dd68757fa70001072b1161acd388913a7941f367e56dcb00cf01bcc442d8da206ce1b2d54cbc7bcd99bf
DIST mod_xml2enc.c 22380 SHA256 54d2d82c54f60e73eaddb69c00d2fd7be1786c449d5c7bbe045b30e56d19ba24 SHA512 b38d81ff419e9c00e302eb555715181cf2157af2d15a15b86d34f948c0c2f55de237234a24140b9fc2c1d3d46d688c4e9c4ab74af34b451677224a30b1b08582 WHIRLPOOL 6c925558f56f3f4c934ab6b50f055bac15eaf09a837500aae900d9c451ab357bc53f0d1c44759f4eb66f5c17d91a46f64cd9467c7a50d2dd8aa6d812bc2340d2
DIST mod_xml2enc.h 1479 SHA256 3a4106a2de484812b6c98aa0845333be83e5f659eebe37678986b8829ee3d4a9 SHA512 01961c3f788ad4a53c2c8f4d9ddebb0333e75b8589df0ab0eb80b53ce781fa5d34b7908d082feeedc7d8a8582a8b798af26b9af107423dad99b83df5c6d5e7d3 WHIRLPOOL 539350c39c7198240cd7eabd43c3bce26d15456064b6dd68757fa70001072b1161acd388913a7941f367e56dcb00cf01bcc442d8da206ce1b2d54cbc7bcd99bf
diff --git a/www-apache/mod_xml2enc/files/26_mod_xml2enc.conf b/www-apache/mod_xml2enc/files/26_mod_xml2enc.conf
new file mode 100644
index 000000000000..1bb394df8ea6
--- /dev/null
+++ b/www-apache/mod_xml2enc/files/26_mod_xml2enc.conf
@@ -0,0 +1,4 @@
+<IfDefine XML2ENC>
+LoadFile /usr/lib/libxml2.so
+LoadModule xml2enc_module modules/mod_xml2enc.so
+</IfDefine>
diff --git a/www-apache/mod_xml2enc/mod_xml2enc-1.0.4.ebuild b/www-apache/mod_xml2enc/mod_xml2enc-1.0.4.ebuild
new file mode 100644
index 000000000000..8b5a6aa77ed5
--- /dev/null
+++ b/www-apache/mod_xml2enc/mod_xml2enc-1.0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit apache-module
+
+DESCRIPTION="An Apache2 module to provide libxml2 encoding"
+HOMEPAGE="http://apache.webthing.com/mod_xml2enc/"
+SRC_URI="http://apache.webthing.com/svn/apache/filters/${PN}.h -> ${P}.h
+ http://apache.webthing.com/svn/apache/filters/${PN}.c -> ${P}.c"
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/bzip2
+ dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="26_${PN}"
+APACHE2_MOD_DEFINE="XML2ENC"
+
+need_apache2
+
+S="${WORKDIR}"/${PN}
+
+src_unpack() {
+ mkdir "${WORKDIR}"/${PN} || die
+ cp "${DISTDIR}/${P}.h" "${WORKDIR}/${PN}/${PN}.h" || die
+ cp "${DISTDIR}/${P}.c" "${WORKDIR}/${PN}/${PN}.c" || die
+}
+
+src_compile() {
+ APXS2_ARGS="$(xml2-config --cflags) -c ${PN}.c"
+ apache-module_src_compile
+}