summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-05 19:30:17 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-05 20:33:31 -0400
commit04cfb64931a456066458f208a56dc49d6c35c086 (patch)
treee42af980ce6ae9c6011ccb9ad80bac7c6930bcde /www-apache
parentapp-arch/bzip3: drop old 1.1.3-r1 (diff)
downloadgentoo-04cfb64931a456066458f208a56dc49d6c35c086.tar.gz
gentoo-04cfb64931a456066458f208a56dc49d6c35c086.tar.bz2
gentoo-04cfb64931a456066458f208a56dc49d6c35c086.zip
www-apache/mod_auth_xradius: fix build with upcoming clang16
Revbump shouldn't mean much for gcc here, but do it anyway in case. Closes: https://bugs.gentoo.org/870841 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_auth_xradius/files/mod_auth_xradius-0.4.6-clang16.patch19
-rw-r--r--www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r2.ebuild (renamed from www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r1.ebuild)3
2 files changed, 21 insertions, 1 deletions
diff --git a/www-apache/mod_auth_xradius/files/mod_auth_xradius-0.4.6-clang16.patch b/www-apache/mod_auth_xradius/files/mod_auth_xradius-0.4.6-clang16.patch
new file mode 100644
index 000000000000..38c7b6852f29
--- /dev/null
+++ b/www-apache/mod_auth_xradius/files/mod_auth_xradius-0.4.6-clang16.patch
@@ -0,0 +1,19 @@
+Need to rename the declarations in md5.h using cpp too.
+
+https://bugs.gentoo.org/870841
+--- a/libradius/porting.h
++++ b/libradius/porting.h
+@@ -15,12 +15,12 @@
+
+ #else
+
+-#include "md5.h"
+ #define MD5_DIGEST_LENGTH 16
+ #define MD5Final xrad_MD5Final
+ #define MD5Init xrad_MD5Init
+ #define MD5Pad xrad_MD5Pad
+ #define MD5Update xrad_MD5Update
++#include "md5.h"
+
+ #endif
+
diff --git a/www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r1.ebuild b/www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r2.ebuild
index 1837678a1a09..086e87e1dee0 100644
--- a/www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r1.ebuild
+++ b/www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,7 @@ PATCHES=(
"${FILESDIR}"/${P}-fallback-support.patch
"${FILESDIR}"/${P}-apache24-api-changes.patch
"${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_prepare() {