summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-01-26 08:22:42 +0100
committerHans de Graaff <graaff@gentoo.org>2023-01-26 08:49:02 +0100
commit1931c30b90c5db79172a84cff42c08d613a7629f (patch)
treeb32f5dc7b40f4db4461ec20ee37dcb1fe80eae25 /www-apache
parentdev-ml/ocaml-inifiles: add dep rules (diff)
downloadgentoo-1931c30b90c5db79172a84cff42c08d613a7629f.tar.gz
gentoo-1931c30b90c5db79172a84cff42c08d613a7629f.tar.bz2
gentoo-1931c30b90c5db79172a84cff42c08d613a7629f.zip
www-apache/passenger: drop 6.0.11, 6.0.14
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/passenger/Manifest2
-rw-r--r--www-apache/passenger/passenger-6.0.11.ebuild126
-rw-r--r--www-apache/passenger/passenger-6.0.14.ebuild127
3 files changed, 0 insertions, 255 deletions
diff --git a/www-apache/passenger/Manifest b/www-apache/passenger/Manifest
index ec199614cb4f..c29cb065fa46 100644
--- a/www-apache/passenger/Manifest
+++ b/www-apache/passenger/Manifest
@@ -1,4 +1,2 @@
-DIST passenger-6.0.11.tar.gz 8183414 BLAKE2B 9767c3f198d7a779dfefed1d1a2ab07e3dda964a61718475470266e3b4448a45d2c5e7416a2e148afa66241f74e91e98ccbec7f2a08f5d4d1e2eff2ac7de5f63 SHA512 977d8adb261c17d5f21115703b9b18c4d3bfc17f998fb880d3a28f68392db2f9e6a2cb7612211f08bc913fd2f417cb2b689fcab2317707e17e8ddea6aeb967d2
-DIST passenger-6.0.14.tar.gz 8216590 BLAKE2B 33fa27e05ae0c5e65e3fec3cd791eee799ebc71f2b2bcfd06c6dde530c1063c87f01a0249b57443f47745b376cc596f58b66f5790b0cb2ed70df8940b6faa92d SHA512 57189e1b78ff9dda38c37d07908cae20db1c856fb4279e54706d0efd2d1d140ff7af8ed9357c4de1360364d3809e376da152f8a18050dcf657850f276d9ce70c
DIST passenger-6.0.15.tar.gz 8379463 BLAKE2B 0bf2a319072671660aae8651fb0253dd0221bce55e3bdfc832ba2f1972e7dbdeee6e9ef9b13bf9a90de20a1c1a4dbeaabf138ed71a0009b0d336e672aeb1573d SHA512 b5af050bc16624542b36433b1d23bba243892cf82b10fdee19c92174b916ea2fffff7f98a5cfcf26bc358b9f29c2c9612c29134c290531c5ce13103e52045fdc
DIST passenger-6.0.16.tar.gz 8378384 BLAKE2B ae435df097b4692f62bc83c006a2abe8103e984bae50a27d3d1faf2114c8aef5b918882b4d8999d565335046ade3c06a177d26efa0bace8d961d84376fa79da1 SHA512 6fa071c32e5ddc615e40975d1b859a9426a10ebd1d4b14adc8a759da76fca58f473bce0a7ed77e23a4ac220f74a50089bc92ebc2cb7190751c54bc5dbf845217
diff --git a/www-apache/passenger/passenger-6.0.11.ebuild b/www-apache/passenger/passenger-6.0.11.ebuild
deleted file mode 100644
index b28f752d8329..000000000000
--- a/www-apache/passenger/passenger-6.0.11.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby26 ruby27 ruby30"
-
-inherit apache-module flag-o-matic multilib ruby-ng toolchain-funcs
-
-DESCRIPTION="Passenger makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="https://www.phusionpassenger.com/"
-SRC_URI="https://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz"
-
-LICENSE="Boost-1.0 MIT BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE="apache2 debug"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-ruby_add_rdepend "
- >=dev-ruby/rack-1.0.0:*
- >=dev-ruby/rake-0.8.1"
-
-# libev is bundled but with adapations that do not seem to be accepted
-# upstream, so we must use the bundled version :-(
-CDEPEND="
- >=dev-libs/libuv-1.8.0
- net-misc/curl[ssl]
- apache2? ( www-servers/apache[apache2_modules_unixd(+)] )"
-
-RDEPEND="${RDEPEND} ${CDEPEND}"
-DEPEND="${DEPEND} ${CDEPEND}"
-
-APACHE2_MOD_CONF="30_mod_${PN}-5.0.0 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-want_apache2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
- depend.apache_pkg_setup
-}
-
-all_ruby_prepare() {
- eapply "${FILESDIR}"/${PN}-5.1.11-gentoo.patch
-
- # Change these with sed instead of a patch so that we can easily use
- # the toolchain-funcs methods.
- sed -i -e "/^CC/ s/=.*$/= '$(tc-getCC)'/" \
- -e "/^CXX\s/ s/=.*$/= '$(tc-getCXX)'/" \
- -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
-
- # Avoid fixed debugging CFLAGs.
- sed -e '/debugging_cflags/areturn ""' -i src/ruby_supportlib/phusion_passenger/platform_info/compiler.rb || die
-
- # Use sed here so that we can dynamically set the documentation directory.
- sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
- -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
- src/ruby_supportlib/phusion_passenger.rb || die
- sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" src/cxx_supportlib/ResourceLocator.h || die
-
- # Don't install a tool that won't work in our setup.
- sed -i -e '/passenger-install-apache2-module/d' src/ruby_supportlib/phusion_passenger/packaging.rb || die
- rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
-
- # Make sure we use the system-provided version where possible
- rm -rf src/cxx_supportlib/vendor-copy/libuv || die "Unable to remove vendored code."
-
- # Fix hard-coded use of AR
- sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/support/cplusplus.rb || die
-
- # Make sure apache support is not attempted with -apache2
- if ! use apache2 ; then
- sed -i -e '/fakeroot/ s/:apache2, //' build/packaging.rb || die
- fi
-}
-
-all_ruby_compile() {
- if use apache2 ; then
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- RANLIB=$(tc-getRANLIB) \
- ruby -S rake apache2 || die "rake failed"
- fi
-}
-
-each_ruby_compile() {
- append-flags -fno-strict-aliasing
-
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- RANLIB=$(tc-getRANLIB) \
- ${RUBY} -S rake native_support || die "rake failed"
-}
-
-all_ruby_install() {
- if use apache2 ; then
- APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
- apache-module_src_install
-
- # Patch in the correct libdir
- sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' "${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
- fi
-
- dodoc CHANGELOG README.md doc/*.md
-}
-
-each_ruby_install() {
- DISTDIR="${D}" \
- RUBYLIBDIR="$(ruby_rbconfig_value vendordir)" \
- RUBYARCHDIR="$(ruby_rbconfig_value archdir)" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_DOCDIR="/usr/share/doc/${P}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- EXTRA_LDFLAGS="${LDFLAGS}" \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- RANLIB=$(tc-getRANLIB) \
- ${RUBY} -S rake fakeroot || die "rake failed"
-}
diff --git a/www-apache/passenger/passenger-6.0.14.ebuild b/www-apache/passenger/passenger-6.0.14.ebuild
deleted file mode 100644
index bd5e5c4851b9..000000000000
--- a/www-apache/passenger/passenger-6.0.14.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-
-inherit apache-module flag-o-matic ruby-ng toolchain-funcs
-
-DESCRIPTION="Passenger makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="https://www.phusionpassenger.com/"
-SRC_URI="https://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz"
-
-# Passenger is licensed MIT, but vendored code licenses should also be taken into account.
-LICENSE="Boost-1.0 MIT BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="apache2 debug"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-ruby_add_rdepend "
- >=dev-ruby/rack-1.0.0:*
- >=dev-ruby/rake-0.8.1"
-
-# libev is bundled but with adapations that do not seem to be accepted
-# upstream, so we must use the bundled version :-(
-CDEPEND="
- >=dev-libs/libuv-1.8.0
- net-misc/curl[ssl]
- apache2? ( www-servers/apache[apache2_modules_unixd(+)] )"
-
-RDEPEND="${RDEPEND} ${CDEPEND}"
-DEPEND="${DEPEND} ${CDEPEND}"
-
-APACHE2_MOD_CONF="30_mod_${PN}-5.0.0 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-want_apache2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
- depend.apache_pkg_setup
-}
-
-all_ruby_prepare() {
- eapply "${FILESDIR}"/${PN}-5.1.11-gentoo.patch
-
- # Change these with sed instead of a patch so that we can easily use
- # the toolchain-funcs methods.
- sed -i -e "/^CC/ s/=.*$/= '$(tc-getCC)'/" \
- -e "/^CXX\s/ s/=.*$/= '$(tc-getCXX)'/" \
- -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
-
- # Avoid fixed debugging CFLAGs.
- sed -e '/debugging_cflags/areturn ""' -i src/ruby_supportlib/phusion_passenger/platform_info/compiler.rb || die
-
- # Use sed here so that we can dynamically set the documentation directory.
- sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
- -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
- src/ruby_supportlib/phusion_passenger.rb || die
- sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" src/cxx_supportlib/ResourceLocator.h || die
-
- # Don't install a tool that won't work in our setup.
- sed -i -e '/passenger-install-apache2-module/d' src/ruby_supportlib/phusion_passenger/packaging.rb || die
- rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
-
- # Make sure we use the system-provided version where possible
- rm -rf src/cxx_supportlib/vendor-copy/libuv || die "Unable to remove vendored code."
-
- # Fix hard-coded use of AR
- sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/support/cplusplus.rb || die
-
- # Make sure apache support is not attempted with -apache2
- if ! use apache2 ; then
- sed -i -e '/fakeroot/ s/:apache2, //' build/packaging.rb || die
- fi
-}
-
-all_ruby_compile() {
- if use apache2 ; then
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- RANLIB=$(tc-getRANLIB) \
- ruby -S rake apache2 || die "rake failed"
- fi
-}
-
-each_ruby_compile() {
- append-flags -fno-strict-aliasing
-
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- RANLIB=$(tc-getRANLIB) \
- ${RUBY} -S rake native_support || die "rake failed"
-}
-
-all_ruby_install() {
- if use apache2 ; then
- APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
- apache-module_src_install
-
- # Patch in the correct libdir
- sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' "${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
- fi
-
- dodoc CHANGELOG README.md doc/*.md
-}
-
-each_ruby_install() {
- DISTDIR="${D}" \
- RUBYLIBDIR="$(ruby_rbconfig_value vendordir)" \
- RUBYARCHDIR="$(ruby_rbconfig_value archdir)" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_DOCDIR="/usr/share/doc/${P}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- EXTRA_LDFLAGS="${LDFLAGS}" \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- RANLIB=$(tc-getRANLIB) \
- ${RUBY} -S rake fakeroot || die "rake failed"
-}