summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-26 10:26:26 +0100
committerSam James <sam@gentoo.org>2022-08-26 11:01:16 +0100
commit2bef9acebcab26b921d9a0c679b4ce2c162bab32 (patch)
tree62290ec264e5dd9279164ad6a6f1d7a766e5d534 /www-apache
parentsys-libs/ncurses: drop versions (diff)
downloadgentoo-2bef9acebcab26b921d9a0c679b4ce2c162bab32.tar.gz
gentoo-2bef9acebcab26b921d9a0c679b4ce2c162bab32.tar.bz2
gentoo-2bef9acebcab26b921d9a0c679b4ce2c162bab32.zip
www-apache/libapreq2: add 2.17
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/libapreq2/Manifest1
-rw-r--r--www-apache/libapreq2/libapreq2-2.17.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/www-apache/libapreq2/Manifest b/www-apache/libapreq2/Manifest
index 6356c1bf4098..1c2e18c9b0ae 100644
--- a/www-apache/libapreq2/Manifest
+++ b/www-apache/libapreq2/Manifest
@@ -1 +1,2 @@
DIST libapreq2-2.16.tar.gz 839264 BLAKE2B 6a79e0281bb24962775f6c2fcc906d07a2f7643f608871018a647a225329c45516f1afe12e27c432449765463b2a4e823a728051fa73938e97ddc828b94c4732 SHA512 aa9e751a3f0d6a9cb587aa1c5408e8d9a073560860d7f653776196fe3739516df16abe943c9cb0460cfb9b68a2d79ad651cfd5e4a30a2ca34d6dc3ced73f628c
+DIST libapreq2-2.17.tar.gz 849867 BLAKE2B d2fa15693c200925e4926f207f1e023cba59ac0bfe3af3a8ac12880020bb00625c7fa21478c6562f9995d5307151b865efb83b837f45213d73fc523a1a864899 SHA512 89b139b8673145d9e2d8fd77d36f878c519c1deb7f9b853cda2a15d34cbb619d1c5e784ba21553f23c2ef07803f07c75a83d96cd770f80e1b36283a4cbb88999
diff --git a/www-apache/libapreq2/libapreq2-2.17.ebuild b/www-apache/libapreq2/libapreq2-2.17.ebuild
new file mode 100644
index 000000000000..335b6354b7b6
--- /dev/null
+++ b/www-apache/libapreq2/libapreq2-2.17.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module perl-module
+
+DESCRIPTION="A library for manipulating client request data via the Apache API"
+HOMEPAGE="https://httpd.apache.org/apreq/"
+SRC_URI="mirror://apache/httpd/libapreq/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="perl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ || (
+ dev-libs/apr-util[openssl]
+ dev-libs/apr-util[nss]
+ )
+ perl? (
+ >=dev-perl/ExtUtils-XSBuilder-0.23
+ virtual/perl-version
+ >=www-apache/mod_perl-2
+ )
+ virtual/libcrypt:="
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-perl/Apache-Test )"
+BDEPEND="sys-apps/file"
+
+PATCHES=( "${FILESDIR}"/libapreq2-2.08-doc.patch )
+
+APACHE2_MOD_FILE="module/apache2/.libs/mod_apreq2.so"
+APACHE2_MOD_CONF="76_mod_apreq"
+APACHE2_MOD_DEFINE="APREQ"
+
+need_apache2
+
+pkg_setup() {
+ perl_set_version
+}
+
+src_prepare() {
+ default
+
+ sed -i -e "s/PERL \$PERL_OPTS/PERL/" acinclude.m4 aclocal.m4 configure || die
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --with-apache2-apxs=${APXS} \
+ $(use_enable perl perl-glue)
+}
+
+src_install() {
+ APACHE_MODULESDIR="/usr/$(get_libdir)/apache2/modules"
+ apache-module_src_install
+
+ emake DESTDIR="${D}" INSTALLDIRS=vendor install
+ doman docs/man/man3/*.3
+
+ perl_delete_localpod
+
+ HTML_DOCS=( docs/html/. )
+ einstalldocs
+ dodoc INSTALL MANIFEST
+
+ local f
+ while IFS="" read -d $'\0' -r f ; do
+ if file "${f}" | grep -i " text"; then
+ sed -i -e "s:${ED}:/:g" "${f}" || die
+ fi
+ done < <(find "${ED}" -type f -not -name '*.so' -print0)
+
+ find "${ED}" -name '*.la' -delete || die
+}