summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-02-16 10:32:32 -0500
committerCraig Andrews <candrews@gentoo.org>2023-02-16 10:32:58 -0500
commit3744d5764c1934443a79304c2b415ba10dc41d83 (patch)
tree0dede8a90824a01b89cac4db6d3b66720fcd8e20 /www-apache
parentdev-python/argh: Bump to 0.28.1 (diff)
downloadgentoo-3744d5764c1934443a79304c2b415ba10dc41d83.tar.gz
gentoo-3744d5764c1934443a79304c2b415ba10dc41d83.tar.bz2
gentoo-3744d5764c1934443a79304c2b415ba10dc41d83.zip
www-apache/mod_h2: add 2.0.13
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.13.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index cd86cf25464d..ff58123a3384 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_h2-2.0.12.tar.gz 790232 BLAKE2B da06e41b95e5dae0b9e114e749ef07383c565d3decf26a87d939a8377f7f687d03c7e8bac46b5c3ed85f0e0e0dfe9d4eb03548910c10268042878780981aaca7 SHA512 36c07357cfe3896237fb94e09d6a1f131cfa11de7d7e0fa86aac22197836a988daf200978b0b1541712ad990391418b394266871b86817d45597f4a83f7eddfb
+DIST mod_h2-2.0.13.tar.gz 791279 BLAKE2B fe1b13e60ea064f3c190ecb30d28fc34e594a35f71d86280e573009aa49638ee12ea2fcafbc25b2fe53a25ada4d98a586ede4c89cd296844a763c80284a3239d SHA512 69ffc4910c89be393406161fa75dce27e17e7bd7d8e1658b7eaae68eb877324f2e30d47a268d41995bb4837c6b4aea4bb8e840191e3291b1fafee3d4f1d55baa
diff --git a/www-apache/mod_h2/mod_h2-2.0.13.ebuild b/www-apache/mod_h2/mod_h2-2.0.13.ebuild
new file mode 100644
index 000000000000..5ba43634b8e0
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-2.0.13.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}