summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-05-12 10:03:43 -0400
committerCraig Andrews <candrews@gentoo.org>2023-05-12 10:04:06 -0400
commit382273494f2556a1c88e5c93a36c839431941b00 (patch)
treec0d9ef5a15dda289dd3da60deaa0d636bb186ac4 /www-apache
parentapp-text/xmlstarlet: EAPI 8 + Clang 16 fixes (diff)
downloadgentoo-382273494f2556a1c88e5c93a36c839431941b00.tar.gz
gentoo-382273494f2556a1c88e5c93a36c839431941b00.tar.bz2
gentoo-382273494f2556a1c88e5c93a36c839431941b00.zip
www-apache/mod_h2: add 2.0.15
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.15.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index b5c8d4740575..33cd29555754 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_h2-2.0.14.tar.gz 791822 BLAKE2B 1bfa052181a8955db85515320e54039ae4ae0ac6d4a59b6352bce2585eed1d7b7db7fdcffc9a3274f7f8df380ffaea4b6bb02f28b7bf93d570d753de38acc4b4 SHA512 764e52c62016315c61a5c6369ad448ca0198e8de7edde9a81c94f75194813e4c4c484ca74ee51e89445b11a74ddef939bae2b6472878e72df36279111dbbc20d
+DIST mod_h2-2.0.15.tar.gz 794493 BLAKE2B aaa5f3c4f2f2f231ab1aec2439e9a55004c1fc9079775b03cf958dee3f4ca78669e6dfd76af9f3e2ee8e753323ca5bc9292d9fd49a0dcedb2ca4c7c9217ecd2a SHA512 784486fc437e8d54899d111abdfc4baef3cfdccb8fc6faf2361c0fb2bd9d2bb8c1daf632bb95d6060db92ba5371ecac08efae256019a71b7c6ee68fc0d1bc636
diff --git a/www-apache/mod_h2/mod_h2-2.0.15.ebuild b/www-apache/mod_h2/mod_h2-2.0.15.ebuild
new file mode 100644
index 000000000000..5ba43634b8e0
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-2.0.15.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}