summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-02-19 09:42:14 -0500
committerCraig Andrews <candrews@gentoo.org>2019-02-19 09:42:14 -0500
commit6e474fa0b1a692fd2a88fe565b363c9a1b8943dc (patch)
treedd231fcaf44b804bc2827185c3841b23c9351879 /www-apache
parentwww-apps/grafana-bin: Version bump to 6.0.0_beta3 (diff)
downloadgentoo-6e474fa0b1a692fd2a88fe565b363c9a1b8943dc.tar.gz
gentoo-6e474fa0b1a692fd2a88fe565b363c9a1b8943dc.tar.bz2
gentoo-6e474fa0b1a692fd2a88fe565b363c9a1b8943dc.zip
www-apache/mod_h2: 1.12.5 version bump
Package-Manager: Portage-2.3.61, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-1.12.5.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 2af2fad609f1..15ee4fe39bd5 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1,3 +1,4 @@
DIST mod_http2-1.12.1.tar.gz 1030534 BLAKE2B cbe02be6dfd1d1563a86c020f7eb8f5922e5d171b3a5d4714539658d5a3e067774b4bbb803e67943ef9b04caef6f3d69291d9ab0f6d8334839a98f466bd3851b SHA512 72cb915bdd283742a7bc2676adf3440d5e30588df87e4dc5750886747b0026e0cd0a36f08a39c323e647c83ecef6b434b33c23c96bb7c00ad480d430c1f37f44
DIST mod_http2-1.12.2.tar.gz 1030072 BLAKE2B efb829eb98bb40489e9a52267125d79093ed2055e50ef6ae6c5fed7616df050e9ec659dd72764534ec778d75e6c462764baff88193970d2bbadf85572d5535f2 SHA512 2fab9625ba7adaa85fa4b1c55e0e1420851d1e44766f81c1e5b60b0b310b071047651c07b44b0dbeaf2d3cb2c722b9de3c52f145eb12e63c08301cf8c1f294cc
DIST mod_http2-1.12.3.tar.gz 1038823 BLAKE2B 86c0f0a6ba04e67976842aa8dae29f401eb594cb66dfb5790bee2838fd017437acfa83d0129d6d91f623304c0d5b3e0eace605adc655dc4e459725d3019a79b0 SHA512 864381a4610a58c962fc59ab885655b20a8bd8aa711688e4ee1b6c5fc3804de843a81c7c0976d5862c18d40657f8e7f5caf2650e4975d946581b32d93af6ef71
+DIST mod_http2-1.12.5.tar.gz 1039313 BLAKE2B 13871ad7af9581657e09d46e107ceb8330d673a0e5c4ce761ff6aa956a2d674694ffe985e21190e0efb960f1cdcd1dfe3b9c1aa775edb8c892a3c15b1bdaff38 SHA512 63e2e6cbb6a1b222e3bb0611170e6cbee2ff652c3b44004176af5e3ba02cf2484b8826289586d47be2b18d453a8042d52407e6d798c49d3ed37cf52796d0e4be
diff --git a/www-apache/mod_h2/mod_h2-1.12.5.ebuild b/www-apache/mod_h2/mod_h2-1.12.5.ebuild
new file mode 100644
index 000000000000..3e6d435d3f82
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-1.12.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}