summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-04-08 13:01:08 -0700
committerSam James <sam@gentoo.org>2023-04-14 01:28:12 +0100
commit709e73a4d3afb59afbda23239d9afa5dff1d9701 (patch)
tree230e859bf88a59addd6fdda8ae1cc71e0fae6589 /www-apache
parentwww-servers/h2o: Rebase live patch (diff)
downloadgentoo-709e73a4d3afb59afbda23239d9afa5dff1d9701.tar.gz
gentoo-709e73a4d3afb59afbda23239d9afa5dff1d9701.tar.bz2
gentoo-709e73a4d3afb59afbda23239d9afa5dff1d9701.zip
www-apache/mod_musicindex: Fix slibtool install
Closes: https://bugs.gentoo.org/778566 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/30523 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_musicindex/files/mod_musicindex-1.4.1-slibtool.patch28
-rw-r--r--www-apache/mod_musicindex/mod_musicindex-1.4.1-r3.ebuild17
2 files changed, 42 insertions, 3 deletions
diff --git a/www-apache/mod_musicindex/files/mod_musicindex-1.4.1-slibtool.patch b/www-apache/mod_musicindex/files/mod_musicindex-1.4.1-slibtool.patch
new file mode 100644
index 000000000000..37b829334a29
--- /dev/null
+++ b/www-apache/mod_musicindex/files/mod_musicindex-1.4.1-slibtool.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/778566
+
+commit 7455f156499c1980193f0c7a4e25b1040ba99104
+Author: orbea <orbea@riseup.net>
+Date: Sat Apr 8 12:31:47 2023 -0700
+
+ build: Don't overwrite the default install target
+
+ Autotools is capable of creating a working install target without any
+ help from apache's apxs which results in calling apache's libtool
+ implementation instead of GNU libtool or slibtool.
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 4815507..7a63571 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -69,11 +69,3 @@ noinst_HEADERS = \
+ playlist-mp4.h \
+ playlist-vorbis.h \
+ sort.h
+-
+-install: $(lib_LTLIBRARIES)
+- $(mkinstalldirs) "$(DESTDIR)$(libdir)"
+-if BUILD_FOR_APACHE2
+- $(APXS) -S LIBEXECDIR="$(DESTDIR)$(libdir)" -i -n musicindex mod_musicindex.la
+-else
+- $(APXS) -S LIBEXECDIR="$(DESTDIR)$(libdir)" -i -n musicindex .libs/mod_musicindex.so
+-endif
diff --git a/www-apache/mod_musicindex/mod_musicindex-1.4.1-r3.ebuild b/www-apache/mod_musicindex/mod_musicindex-1.4.1-r3.ebuild
index fa92548ef157..1ef181d29e3c 100644
--- a/www-apache/mod_musicindex/mod_musicindex-1.4.1-r3.ebuild
+++ b/www-apache/mod_musicindex/mod_musicindex-1.4.1-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit apache-module
+inherit apache-module autotools
DESCRIPTION="mod_musicindex allows nice displaying of directories containing music files"
HOMEPAGE="http://hacks.slashdirt.org/sw/musicindex/"
@@ -30,12 +30,21 @@ APACHE2_MOD_CONF="50_${PN}"
APACHE2_MOD_DEFINE="MUSICINDEX"
DOCS=( AUTHORS BUGS ChangeLog README UPGRADING )
+PATCHES=(
+ "${FILESDIR}"/${P}-slibtool.patch #778566
+)
+
need_apache2
pkg_setup() {
_init_apache2_late
}
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf \
--with-vorbis-libraries="${ESYSROOT}/usr/$(get_libdir)" \
@@ -62,4 +71,6 @@ src_install() {
newins "${DISTDIR}/${P}_valid-rss.png" valid-rss.png
newins "${DISTDIR}/${P}_valid-xhtml11" valid-xhtml11
newins "${DISTDIR}/${P}_vcss" vcss
+
+ find "${ED}" -type f -name "*.la" -delete || die
}