summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-08-24 09:41:05 -0400
committerCraig Andrews <candrews@gentoo.org>2023-08-24 09:42:22 -0400
commit71114b2d24e205d8e9e0a22b613fa6ea47b92d3f (patch)
tree474219ed2a9e603f2b1c618706a2defcc75d4449 /www-apache
parentdev-python/sybil: Remove old (diff)
downloadgentoo-71114b2d24e205d8e9e0a22b613fa6ea47b92d3f.tar.gz
gentoo-71114b2d24e205d8e9e0a22b613fa6ea47b92d3f.tar.bz2
gentoo-71114b2d24e205d8e9e0a22b613fa6ea47b92d3f.zip
www-apache/mod_h2: add 2.0.22
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.22.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 5289ddb4bb10..d2f00db9c72f 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_h2-2.0.21.tar.gz 671561 BLAKE2B 610e23167466b4c3a42efb08840ec1b24df20d511838764a194b45d315fed610555341e5cb17a0cfdacd8ec3cfb6deec5871a22a5ad108b10e04e05c52432fee SHA512 2c3fdd8116c2154d42b990a2dcc681c764784c59576c43d0456b041fb4d4219f295015c63a37c7583c4cd5bc45709abc5b56d8bef6df5b7ba8178da65d8e90b0
+DIST mod_h2-2.0.22.tar.gz 689224 BLAKE2B 121f463ff33112f9dcd65c3b368aa384f8f9fab70c961f5afe75db55e2c6d3587d5fdb74370383019f977d1cace7b16a05c866cca1cdf08216ef3e0b724c9b20 SHA512 2d4644208a4dcc2fd085e043d48861d076b776ff6feda306f26986fcc367a47ecbb3b103e89f7ec92aba366064d6c413bb6705871c9d225df4bd3063e6ea4e8b
diff --git a/www-apache/mod_h2/mod_h2-2.0.22.ebuild b/www-apache/mod_h2/mod_h2-2.0.22.ebuild
new file mode 100644
index 000000000000..5ba43634b8e0
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-2.0.22.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}