summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-08-28 07:04:35 +0200
committerHans de Graaff <graaff@gentoo.org>2023-08-28 11:25:28 +0200
commit7b51ea078bbe71983f60005a2924ebb78845613f (patch)
tree43272bc78f2dcde84351de0424c3255bc2411956 /www-apache
parentwww-servers/thin: drop 1.8.1-r2 (diff)
downloadgentoo-7b51ea078bbe71983f60005a2924ebb78845613f.tar.gz
gentoo-7b51ea078bbe71983f60005a2924ebb78845613f.tar.bz2
gentoo-7b51ea078bbe71983f60005a2924ebb78845613f.zip
www-apache/passenger: drop 6.0.17
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/passenger/Manifest1
-rw-r--r--www-apache/passenger/passenger-6.0.17.ebuild128
2 files changed, 0 insertions, 129 deletions
diff --git a/www-apache/passenger/Manifest b/www-apache/passenger/Manifest
index b43a89301b2b..b6d8b3a1827f 100644
--- a/www-apache/passenger/Manifest
+++ b/www-apache/passenger/Manifest
@@ -1,2 +1 @@
-DIST passenger-6.0.17.tar.gz 8422867 BLAKE2B 3ffc7dff50289efa4fdee5cb05254661f57ab5478138822d61f7821cfc6319d881827eb982b30c336bd0294c23e5a57ea81a609d4df6fbb0da0fd844f8148973 SHA512 00c972de84bf0aa6623cf805bdd9c41c8341e984f2a4e1675c9c5e981b369cf69c083bbc421f5d3a2dcecd3b47ba5402ba6d9c7c8ee51dd1b0310395c01888fa
DIST passenger-6.0.18.tar.gz 8424409 BLAKE2B 50f3639d0233892c85b97383689599c08457642fbfd1d968b67dddee896eb1377ffc40ce8049a2c3ae4a1a6d3673bdc2fef8de9125efa0386722103f9c4ed1ba SHA512 4c9e43d0907e83f82b2ae1bdc882648f5b3c1b54ffe029590a259c191f57b752dc3196332d0bb68319d50d656192e59df0ed9647f1c7fe3fdc13477a9c0b829b
diff --git a/www-apache/passenger/passenger-6.0.17.ebuild b/www-apache/passenger/passenger-6.0.17.ebuild
deleted file mode 100644
index 870c6cb638d2..000000000000
--- a/www-apache/passenger/passenger-6.0.17.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby27 ruby30 ruby31"
-
-inherit apache-module flag-o-matic ruby-ng toolchain-funcs
-
-DESCRIPTION="Passenger makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="https://www.phusionpassenger.com/"
-SRC_URI="https://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz"
-
-# Passenger is licensed MIT, but vendored code licenses should also be taken into account.
-LICENSE="Boost-1.0 MIT BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE="apache2 debug"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-ruby_add_rdepend "
- >=dev-ruby/rack-1.0.0:*
- >=dev-ruby/rake-0.8.1"
-
-# libev is bundled but with adapations that do not seem to be accepted
-# upstream, so we must use the bundled version :-(
-CDEPEND="
- >=dev-libs/libuv-1.8.0
- net-misc/curl[ssl]
- apache2? ( www-servers/apache[apache2_modules_unixd(+)] )"
-
-RDEPEND="${RDEPEND} ${CDEPEND}"
-DEPEND="${DEPEND} ${CDEPEND}"
-
-APACHE2_MOD_CONF="30_mod_${PN}-5.0.0 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-want_apache2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
- depend.apache_pkg_setup
-}
-
-all_ruby_prepare() {
- eapply "${FILESDIR}"/${PN}-5.1.11-gentoo.patch
-
- # Change these with sed instead of a patch so that we can easily use
- # the toolchain-funcs methods.
- sed -i -e "/^CC/ s/=.*$/= '$(tc-getCC)'/" \
- -e "/^CXX\s/ s/=.*$/= '$(tc-getCXX)'/" \
- -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
-
- # Avoid fixed debugging CFLAGs.
- sed -e '/debugging_cflags/areturn ""' -i src/ruby_supportlib/phusion_passenger/platform_info/compiler.rb || die
-
- # Use sed here so that we can dynamically set the documentation directory.
- sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
- -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
- src/ruby_supportlib/phusion_passenger.rb || die
- sed -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
- -i src/cxx_supportlib/ResourceLocator.h || die
-
- # Don't install a tool that won't work in our setup.
- sed -i -e '/passenger-install-apache2-module/d' src/ruby_supportlib/phusion_passenger/packaging.rb || die
- rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
-
- # Make sure we use the system-provided version where possible
- rm -rf src/cxx_supportlib/vendor-copy/libuv || die "Unable to remove vendored code."
-
- # Fix hard-coded use of AR
- sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/support/cplusplus.rb || die
-
- # Make sure apache support is not attempted with -apache2
- if ! use apache2 ; then
- sed -i -e '/fakeroot/ s/:apache2, //' build/packaging.rb || die
- fi
-}
-
-all_ruby_compile() {
- if use apache2 ; then
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- RANLIB=$(tc-getRANLIB) \
- ruby -S rake apache2 || die "rake failed"
- fi
-}
-
-each_ruby_compile() {
- append-flags -fno-strict-aliasing
-
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- RANLIB=$(tc-getRANLIB) \
- ${RUBY} -S rake native_support || die "rake failed"
-}
-
-all_ruby_install() {
- if use apache2 ; then
- APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
- apache-module_src_install
-
- # Patch in the correct libdir
- sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' "${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
- fi
-
- dodoc CHANGELOG README.md doc/*.md
-}
-
-each_ruby_install() {
- DISTDIR="${D}" \
- RUBYLIBDIR="$(ruby_rbconfig_value vendordir)" \
- RUBYARCHDIR="$(ruby_rbconfig_value archdir)" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_DOCDIR="/usr/share/doc/${P}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- EXTRA_LDFLAGS="${LDFLAGS}" \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- RANLIB=$(tc-getRANLIB) \
- ${RUBY} -S rake fakeroot || die "rake failed"
-}