summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-10-20 16:13:27 +0200
committerFabian Groffen <grobian@gentoo.org>2019-10-20 16:13:36 +0200
commit2a6019abe493cac8ff3fe7e58eb044ff4ada4934 (patch)
tree2f6b6a4393d76e3047070dc5cf6c76b327f579d2 /www-apps/baikal/baikal-0.4.6.ebuild
parentwww-apps/agendav: remove old (diff)
downloadgentoo-2a6019abe493cac8ff3fe7e58eb044ff4ada4934.tar.gz
gentoo-2a6019abe493cac8ff3fe7e58eb044ff4ada4934.tar.bz2
gentoo-2a6019abe493cac8ff3fe7e58eb044ff4ada4934.zip
www-apps/baikal: remove old
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'www-apps/baikal/baikal-0.4.6.ebuild')
-rw-r--r--www-apps/baikal/baikal-0.4.6.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/www-apps/baikal/baikal-0.4.6.ebuild b/www-apps/baikal/baikal-0.4.6.ebuild
deleted file mode 100644
index d56d16567fb4..000000000000
--- a/www-apps/baikal/baikal-0.4.6.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit webapp
-
-DESCRIPTION="Lightweight CalDAV+CardDAV server"
-HOMEPAGE="http://sabre.io/baikal/"
-SRC_URI="https://github.com/fruux/Baikal/releases/download/${PV}/${P}.zip"
-
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~arm ~ppc64"
-IUSE="+mysql sqlite"
-REQUIRED_USE="|| ( mysql sqlite )"
-
-DEPEND="app-arch/unzip"
-RDEPEND=">=dev-lang/php-5.5[ctype,filter,json,pdo,session,xml,xmlreader,xmlwriter,mysql?,sqlite?]
- mysql? ( virtual/mysql )
- sqlite? ( dev-db/sqlite )
- virtual/httpd-php"
-
-S=${WORKDIR}/${PN}
-
-src_install() {
- webapp_src_preinst
-
- dodoc *.md || die "dodoc failed"
-
- einfo "Installing web files"
- insinto "${MY_HTDOCSDIR}"
- doins -r html/* html/.htaccess Core vendor || die "doins failed"
-
- einfo "Setting up container for configuration"
- insinto /etc/${PN}
-
- einfo "Fixing symlinks"
- local link target
- find "${D}${MY_HTDOCSDIR}" -type l | while read link ; do
- target=$(readlink "${link}")
- target=${target/..\/Core/Core}
- rm "${link}" && ln -s "${target}" "${link}"
- done
- dosym /etc/${PN} "${MY_HTDOCSDIR}"/Specific
- dosym . "${MY_HTDOCSDIR}"/html
-
- webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
- webapp_src_install
-
- if has_version www-servers/apache ; then
- fowners -R apache:apache /etc/${PN}
- elif has_version www-servers/nginx ; then
- fowners -R nginx:nginx /etc/${PN}
- else
- einfo "/etc/${PN} must be owned by the webserver user for baikal"
- fi
-}