summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2022-01-08 20:04:50 +0100
committerFabian Groffen <grobian@gentoo.org>2022-01-08 20:04:50 +0100
commitfbec7d7c7443c5401724296f8cada5c22bf2934d (patch)
treee1fbb4b8d7439dc345c59bd9b36fb187929cf035 /www-apps/baikal
parentprofiles/prefix/darwin/macos: mask latest cmake on 11 and up (diff)
downloadgentoo-fbec7d7c7443c5401724296f8cada5c22bf2934d.tar.gz
gentoo-fbec7d7c7443c5401724296f8cada5c22bf2934d.tar.bz2
gentoo-fbec7d7c7443c5401724296f8cada5c22bf2934d.zip
www-apps/baikal-0.9.1: version bump
Bug: https://bugs.gentoo.org/821169 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'www-apps/baikal')
-rw-r--r--www-apps/baikal/Manifest1
-rw-r--r--www-apps/baikal/baikal-0.9.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/www-apps/baikal/Manifest b/www-apps/baikal/Manifest
index 1bdb0a8d5eca..e9c09cbea3e8 100644
--- a/www-apps/baikal/Manifest
+++ b/www-apps/baikal/Manifest
@@ -1,2 +1,3 @@
DIST baikal-0.7.2.zip 3602276 BLAKE2B 160c1b45944c897e368450da935850749e4dc5c6fdb9607dc6da926a0a05d63b4921193a31fbd64be0c9ddad336ac49f5fc49c23fca5bbb251adca8793265ba9 SHA512 df1fd10c5fb63e6aa89ae4b733eacf102b11f6322c3fa6007d0308574395389c0c6bfd62b7a0d358c54baaa96a5ccdb40bd509258a59e417617bea8d0b3d42a3
DIST baikal-0.8.0.zip 3282996 BLAKE2B 102f6ce944804faad1032edaa8cac28f37b278a61de58fd3719e60d26bf9213c2e00965dc48476a1e47ae1710178e6cc494fc9da3af63d3f073ef5abed7d7da1 SHA512 8a43e6a88aaa8eded779db940d970afe9fb37606b9547cbf97d209a7ef54128d1c5f100de917b60362bf131b21f9e82613f482453974635a8e64c798513fd5c6
+DIST baikal-0.9.1.zip 2981404 BLAKE2B 65eecd989f8b903bea35e8a4bf1be83eb322aecc13460370712ddc36420215d3facbc2161069b3c9d451ec74d8f2d336aba4c06f528eac35ebb243fb47cde00d SHA512 28a08eb701bdd5a752675bdb05a233b77310a8b024ec1452b548be231a610dd17d5871664cf689054657fd849742a9debe0ba0de92272c3ac3f2568c49d8af70
diff --git a/www-apps/baikal/baikal-0.9.1.ebuild b/www-apps/baikal/baikal-0.9.1.ebuild
new file mode 100644
index 000000000000..bcc8eac313f6
--- /dev/null
+++ b/www-apps/baikal/baikal-0.9.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit webapp
+
+DESCRIPTION="Lightweight CalDAV+CardDAV server"
+HOMEPAGE="https://sabre.io/baikal/"
+SRC_URI="https://github.com/sabre-io/Baikal/releases/download/${PV}/${P}.zip"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~ppc64"
+IUSE="+mysql sqlite"
+REQUIRED_USE="|| ( mysql sqlite )"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=dev-lang/php-6[ctype,filter,json(+),pdo,session,xml,xmlreader,xmlwriter,mysql?,sqlite?]
+ mysql? ( virtual/mysql )
+ sqlite? ( dev-db/sqlite )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc *.md
+
+ einfo "Installing web files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r html/* html/.htaccess Core vendor
+
+ einfo "Setting up container for configuration"
+ dodir /etc/${PN}
+
+ # setup config in /etc
+ # we are not allowed to use straight-forward absolute symlink :(
+ local root path htdocsdir=${MY_HTDOCSDIR%/}
+ while [[ -n ${htdocsdir} ]] ; do
+ root+="../"
+ htdocsdir=${htdocsdir%/*}
+ # trim duplicate slashes
+ while [[ ${htdocsdir} == */ ]] ; do
+ htdocsdir=${htdocsdir%/}
+ done
+ done
+ dosym ${root%/}/etc/${PN} "${MY_HTDOCSDIR}"/Specific
+ dosym ${root%/}/etc/${PN} "${MY_HTDOCSDIR}"/config
+ dosym . "${MY_HTDOCSDIR}"/html
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-v0.7-en.txt"
+ webapp_src_install
+
+ if has_version www-servers/apache ; then
+ fowners -R apache:apache /etc/${PN}
+ elif has_version www-servers/nginx ; then
+ fowners -R nginx:nginx /etc/${PN}
+ else
+ einfo "/etc/${PN} must be owned by the webserver user for baikal"
+ fi
+}