summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/blohg-tumblelog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/blohg-tumblelog')
-rw-r--r--www-apps/blohg-tumblelog/Manifest1
-rw-r--r--www-apps/blohg-tumblelog/blohg-tumblelog-0.2.ebuild33
-rw-r--r--www-apps/blohg-tumblelog/blohg-tumblelog-9999.ebuild33
-rw-r--r--www-apps/blohg-tumblelog/metadata.xml20
4 files changed, 87 insertions, 0 deletions
diff --git a/www-apps/blohg-tumblelog/Manifest b/www-apps/blohg-tumblelog/Manifest
new file mode 100644
index 000000000000..d250a3f1bf7c
--- /dev/null
+++ b/www-apps/blohg-tumblelog/Manifest
@@ -0,0 +1 @@
+DIST blohg-tumblelog-0.2.tar.gz 11046 SHA256 89d8cdc4fe7c2e058f657a8986123219a65a2b8caa404bec7423e93988976b04 SHA512 c9819c503751f4b6dc5f53b2f16206912424fe51eee4c76da5331e1ee1847066f4c758e98ec6fae98b0e0dfe33d5a37ce5f4ea2ea3abba0fd276cde242489792 WHIRLPOOL 744ab5d1d81faa44d79d9785caf1fef522fbc74f8a1c697cfccb64f5d72e25931d0be55337715111a11cedf3512be940973cca7363ff127d10d6a8789bc78a6d
diff --git a/www-apps/blohg-tumblelog/blohg-tumblelog-0.2.ebuild b/www-apps/blohg-tumblelog/blohg-tumblelog-0.2.ebuild
new file mode 100644
index 000000000000..d63bafd8c7f1
--- /dev/null
+++ b/www-apps/blohg-tumblelog/blohg-tumblelog-0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A blohg extension with reStructuredText directives to run a tumblelog"
+HOMEPAGE="https://github.com/rafaelmartins/blohg-tumblelog"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=
+ KEYWORDS=
+ EGIT_REPO_URI="git://github.com/rafaelmartins/blohg-tumblelog.git
+ https://github.com/rafaelmartins/blohg-tumblelog.git"
+ inherit git-r3
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=www-apps/blohg-0.12
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pyoembed[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/www-apps/blohg-tumblelog/blohg-tumblelog-9999.ebuild b/www-apps/blohg-tumblelog/blohg-tumblelog-9999.ebuild
new file mode 100644
index 000000000000..d63bafd8c7f1
--- /dev/null
+++ b/www-apps/blohg-tumblelog/blohg-tumblelog-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A blohg extension with reStructuredText directives to run a tumblelog"
+HOMEPAGE="https://github.com/rafaelmartins/blohg-tumblelog"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=
+ KEYWORDS=
+ EGIT_REPO_URI="git://github.com/rafaelmartins/blohg-tumblelog.git
+ https://github.com/rafaelmartins/blohg-tumblelog.git"
+ inherit git-r3
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=www-apps/blohg-0.12
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pyoembed[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/www-apps/blohg-tumblelog/metadata.xml b/www-apps/blohg-tumblelog/metadata.xml
new file mode 100644
index 000000000000..1f2cb18711c3
--- /dev/null
+++ b/www-apps/blohg-tumblelog/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <longdescription lang="en">
+ A blohg extension with reStructuredText directives to run a tumblelog.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <bugs-to>mailto:blohg@librelist.com</bugs-to>
+ <remote-id type="pypi">blohg-tumblelog</remote-id>
+ <remote-id type="github">rafaelmartins/blohg-tumblelog</remote-id>
+ </upstream>
+</pkgmetadata>