summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2019-09-29 15:55:55 -0500
committerBen Kohler <bkohler@gentoo.org>2019-09-29 15:57:29 -0500
commit23d65596bf6ed47cf5a8fd1d163ddbf3f8fb2ce9 (patch)
tree9df8085dc2103054860763945c6977f943fbcd82 /www-apps/cgit
parentRevert "net-misc/freerdp: remove old" (diff)
downloadgentoo-23d65596bf6ed47cf5a8fd1d163ddbf3f8fb2ce9.tar.gz
gentoo-23d65596bf6ed47cf5a8fd1d163ddbf3f8fb2ce9.tar.bz2
gentoo-23d65596bf6ed47cf5a8fd1d163ddbf3f8fb2ce9.zip
www-apps/cgit: fix missing group on installation
After a recent change in user.eclass, this package no longer creates the required group that's used later in src_install. I've adjusted the ebuilds to restore the original behavior as intended before this eclass change. https://gitweb.gentoo.org/repo/gentoo.git/commit/eclass/user.eclass?id=3afc0d7b8b5e90c50d66c5a845b96c33e521e6e8 Closes: https://bugs.gentoo.org/688890 Package-Manager: Portage-2.3.76, Repoman-2.3.17 RepoMan-Options: --force Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'www-apps/cgit')
-rw-r--r--www-apps/cgit/cgit-1.2.1.ebuild5
-rw-r--r--www-apps/cgit/cgit-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/www-apps/cgit/cgit-1.2.1.ebuild b/www-apps/cgit/cgit-1.2.1.ebuild
index 82174c822957..4bbbeef07a16 100644
--- a/www-apps/cgit/cgit-1.2.1.ebuild
+++ b/www-apps/cgit/cgit-1.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -38,7 +38,8 @@ DEPEND="${RDEPEND}
pkg_setup() {
webapp_pkg_setup
- enewuser "${PN}"
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
}
src_prepare() {
diff --git a/www-apps/cgit/cgit-9999.ebuild b/www-apps/cgit/cgit-9999.ebuild
index 28d3a7922770..a6df9326558d 100644
--- a/www-apps/cgit/cgit-9999.ebuild
+++ b/www-apps/cgit/cgit-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="4"
@@ -36,7 +36,8 @@ DEPEND="${RDEPEND}
pkg_setup() {
webapp_pkg_setup
- enewuser "${PN}"
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
}
src_prepare() {