summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-20 00:10:51 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-20 00:20:41 +0100
commitd9ef359535c0d376019e3b94e59160ee53d9edf9 (patch)
tree7afdae68c9dd176968b0e03d2d41a75711fdc1a7 /www-apps/curator/curator-3.0_p20110120-r2.ebuild
parentsys-kernel/hardened-sources: version bump to 4.9.11 (diff)
downloadgentoo-d9ef359535c0d376019e3b94e59160ee53d9edf9.tar.gz
gentoo-d9ef359535c0d376019e3b94e59160ee53d9edf9.tar.bz2
gentoo-d9ef359535c0d376019e3b94e59160ee53d9edf9.zip
www-apps/curator: python-single-r1, EAPI=6
Diffstat (limited to 'www-apps/curator/curator-3.0_p20110120-r2.ebuild')
-rw-r--r--www-apps/curator/curator-3.0_p20110120-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/www-apps/curator/curator-3.0_p20110120-r2.ebuild b/www-apps/curator/curator-3.0_p20110120-r2.ebuild
new file mode 100644
index 000000000000..b3282ab4f086
--- /dev/null
+++ b/www-apps/curator/curator-3.0_p20110120-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Gallery generator"
+HOMEPAGE="http://furius.ca/curator/"
+SRC_URI="mirror://gentoo/curator-3.0_pf078f1686a78.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~mips ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ dev-python/pillow[${PYTHON_USEDEP}]
+ virtual/imagemagick-tools"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S="${WORKDIR}/curator-3.0_pf078f1686a78"
+
+src_compile() {
+ python_fix_shebang hs/curator-hs
+}
+
+src_install() {
+ dobin hs/curator-hs
+ insinto /usr/share/curator
+ doins -r hs
+}