summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2020-04-15 16:17:47 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2020-04-15 16:17:47 +0000
commit2d6621ec56265f25f08420bc7e603dbaa153617e (patch)
tree71c7b06275ee5c3b1028eb035ab502c72c9edfc5 /www-apps/drupal
parentapp-portage/nattka: Remove old (diff)
downloadgentoo-2d6621ec56265f25f08420bc7e603dbaa153617e.tar.gz
gentoo-2d6621ec56265f25f08420bc7e603dbaa153617e.tar.bz2
gentoo-2d6621ec56265f25f08420bc7e603dbaa153617e.zip
www-apps/drupal: Add 8.7.13 and 8.8.5 releases.
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'www-apps/drupal')
-rw-r--r--www-apps/drupal/Manifest2
-rw-r--r--www-apps/drupal/drupal-8.7.13.ebuild68
-rw-r--r--www-apps/drupal/drupal-8.8.5.ebuild68
3 files changed, 138 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 7bb919099b98..8e497525f482 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,3 +1,5 @@
DIST drupal-7.69.tar.gz 3314294 BLAKE2B bfa1d528caf5dc1fa8a21d65244801e2d10961ec707bdb05c99cdd4fbb1e8f90692549b00befd29583371791a22fdf46af87dcc8c43204dce6ba505376bff5d4 SHA512 521eec475cbd11d9c997f660c8cd3f92e7a164650eaec67bc1d40c53e901576bc827a3805d2341ab80e9a5bb2f4524e7541d0a99970f2a51a3e45a9ac8ae7880
DIST drupal-8.7.12.tar.gz 17917274 BLAKE2B 931876fffaab011416d992910317e0b24f89ea4c01fbb09e7d256fb90652b30509051d60c61863434762eccf382ed9f25be41f84b797ffba89aff83a15ff908d SHA512 f9b140d52d11d9ec0543b8e18315b898f1d09bb4c360c544498b1b6df8d40e59c04e5e04749140c896c51f2ea1844fab8220dd556986b39af0fc846d2571e5c2
+DIST drupal-8.7.13.tar.gz 17930132 BLAKE2B 926614cfa214a4c6bceea89d730f888fadd6373d197aaed983d9a778602fd0c22c8115fea670489e1d5eb26eadaa89f30427e7d7c719f3abe3f59e98f7cb6e07 SHA512 bbf859b30204c6c62ac1d2824cda0dc23acc4af99a119684c2b55d8944d6bb6ee5989f1a092f042009e4fe1f8da7cce8fca7d823097c53279a94b2c6f75fdbbf
DIST drupal-8.8.4.tar.gz 19488274 BLAKE2B 47cd41ec3d494f5dc948d70c45072fa8040698db133141947348b201e9853c04b91460b1c064d36e45dd20d0ce99c2a1a592e4f2a0f99348cdfd08fb97b9f0e1 SHA512 e85e1262eff6274ada1d2625fbd7744b22611807e55252fcaeae722dae5dbc1c552841681f80d552e2d68f7ab2cdca8915e9a2e4c3dac9870fa92c0cb3910286
+DIST drupal-8.8.5.tar.gz 19487785 BLAKE2B f7f64482c122009a7517bc299abee2a69f37b7732f4caa6348c811324c1875d38c3a8c71e031f451b1926e9e3b209c1da6db743451c28cf1e5a8c5ea2b13eee4 SHA512 15c1b574867066601d19f1cc45f3a65301f11e034f1aed4ab2b5566e5efc7b70ca7d12482fc94bd936b4b1b6bfab0fdc1eec1470d44a6de157eeb5bf8c178124
diff --git a/www-apps/drupal/drupal-8.7.13.ebuild b/www-apps/drupal/drupal-8.7.13.ebuild
new file mode 100644
index 000000000000..50acdd30770d
--- /dev/null
+++ b/www-apps/drupal/drupal-8.7.13.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}
diff --git a/www-apps/drupal/drupal-8.8.5.ebuild b/www-apps/drupal/drupal-8.8.5.ebuild
new file mode 100644
index 000000000000..50acdd30770d
--- /dev/null
+++ b/www-apps/drupal/drupal-8.8.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}