summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-08-04 09:49:17 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2021-08-04 09:49:25 +0200
commit165804de91b7303b3481b40d49ce10b995308a6e (patch)
treef8519565d844fdc7d2b951209bc834e21edcc7ea /www-apps/element
parentnet-mail/fetchmail: bump masked 7.0.0-alpha9 (diff)
downloadgentoo-165804de91b7303b3481b40d49ce10b995308a6e.tar.gz
gentoo-165804de91b7303b3481b40d49ce10b995308a6e.tar.bz2
gentoo-165804de91b7303b3481b40d49ce10b995308a6e.zip
www-apps/element: 1.7.34 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps/element')
-rw-r--r--www-apps/element/Manifest1
-rw-r--r--www-apps/element/element-1.7.34.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/www-apps/element/Manifest b/www-apps/element/Manifest
index 1055413cda09..2bccaecd1745 100644
--- a/www-apps/element/Manifest
+++ b/www-apps/element/Manifest
@@ -1 +1,2 @@
DIST element-v1.7.33.tar.gz 15425526 BLAKE2B 0cb13c5aa94a16e532f9ff4a8558b08c01afe1d5c8c4070bc9c26684571a316b2ce1265cd763ee4fe6c54b255313d489adc41e8dfc18f619ae3c2016b593087f SHA512 8b23d2e63cd69ec51cd053826d73f72be50a9662f2adcb7d8b86b0d2b32175038e77c3d00c2e37b39147565fc9fc1cb9c61be1f7a59d1f23e3c4d6316512912d
+DIST element-v1.7.34.tar.gz 15635182 BLAKE2B b9926a7b2aba2189004c9c0885b25878479e4ca0b80053261601e7bca64703c7148403671e3a5783530cfd1d431c0b3ffc398c5bd2767d7b0a93472306c581e1 SHA512 96bc96d98677e7154790accd7fca8314aada7352d8b8c1a9cc1b18c65b78705db766e5238feda6a3601aabd1f487b115dbaaecd0f55354b752ea07730e2d2312
diff --git a/www-apps/element/element-1.7.34.ebuild b/www-apps/element/element-1.7.34.ebuild
new file mode 100644
index 000000000000..0d6f2e6d2cb4
--- /dev/null
+++ b/www-apps/element/element-1.7.34.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="A glossy Matrix collaboration client for the web"
+HOMEPAGE="https://element.io/"
+SRC_URI="https://github.com/vector-im/element-web/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+need_httpd
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/home
+ dodir "${MY_HTDOCSDIR}"/sites
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/home
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites
+ #webapp_configfile "${MY_HTDOCSDIR}"/config.json
+
+ webapp_src_install
+}