summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2021-04-19 16:29:56 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2021-04-19 09:42:16 +0100
commit199c001acc76ae53cd3330f72b2c5ad821ed37c6 (patch)
treeeba8f11512890f19f80905ca5a758d2987617444 /www-apps/gitit
parentdev-haskell/hslua-module-system: drop old (diff)
downloadgentoo-199c001acc76ae53cd3330f72b2c5ad821ed37c6.tar.gz
gentoo-199c001acc76ae53cd3330f72b2c5ad821ed37c6.tar.bz2
gentoo-199c001acc76ae53cd3330f72b2c5ad821ed37c6.zip
www-apps/gitit: allow pandoc-2.12 and 2.13
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'www-apps/gitit')
-rw-r--r--www-apps/gitit/files/gitit-0.13.0.0-pandoc-2.12.patch43
-rw-r--r--www-apps/gitit/gitit-0.13.0.0-r1.ebuild2
2 files changed, 45 insertions, 0 deletions
diff --git a/www-apps/gitit/files/gitit-0.13.0.0-pandoc-2.12.patch b/www-apps/gitit/files/gitit-0.13.0.0-pandoc-2.12.patch
new file mode 100644
index 000000000000..abe73ed17c9e
--- /dev/null
+++ b/www-apps/gitit/files/gitit-0.13.0.0-pandoc-2.12.patch
@@ -0,0 +1,43 @@
+diff --git a/src/Network/Gitit/Authentication.hs b/src/Network/Gitit/Authentication.hs
+index 4c240e7..b41d87d 100644
+--- a/src/Network/Gitit/Authentication.hs
++++ b/src/Network/Gitit/Authentication.hs
+@@ -44,8 +44,8 @@ import System.Exit
+ import System.Log.Logger (logM, Priority(..))
+ import Data.Char (isAlphaNum, isAlpha)
+ import qualified Data.Map as M
+-import Text.Pandoc.Shared (substitute)
+ import Data.Maybe (isJust, fromJust, isNothing, fromMaybe)
++import Data.List (stripPrefix)
+ import Network.URL (exportURL, add_param, importURL)
+ import Network.BSD (getHostName)
+ import qualified Text.StringTemplate as T
+@@ -54,6 +54,15 @@ import Codec.Binary.UTF8.String (encodeString)
+ import Data.ByteString.UTF8 (toString)
+ import Network.Gitit.Rpxnow as R
+
++-- Taken from Pandoc-2.11.4, no longer exported since 2.12:
++substitute :: (Eq a) => [a] -> [a] -> [a] -> [a]
++substitute _ _ [] = []
++substitute [] _ xs = xs
++substitute target replacement lst@(x:xs) =
++ case stripPrefix target lst of
++ Just lst' -> replacement ++ substitute target replacement lst'
++ Nothing -> x : substitute target replacement xs
++
+ data ValidationType = Register
+ | ResetPassword
+ deriving (Show,Read)
+diff --git a/src/Network/Gitit/Util.hs b/src/Network/Gitit/Util.hs
+index c5e9fe5..9588b3a 100644
+--- a/src/Network/Gitit/Util.hs
++++ b/src/Network/Gitit/Util.hs
+@@ -45,7 +45,7 @@ import Network.URL (encString)
+
+ -- | Read file as UTF-8 string. Encode filename as UTF-8.
+ readFileUTF8 :: FilePath -> IO Text
+-readFileUTF8 = fmap T.pack . UTF8.readFile
++readFileUTF8 = UTF8.readFile
+
+ -- | Perform a function a directory and return to working directory.
+ inDir :: FilePath -> IO a -> IO a
diff --git a/www-apps/gitit/gitit-0.13.0.0-r1.ebuild b/www-apps/gitit/gitit-0.13.0.0-r1.ebuild
index e24c23a2a38e..b2dc02d39686 100644
--- a/www-apps/gitit/gitit-0.13.0.0-r1.ebuild
+++ b/www-apps/gitit/gitit-0.13.0.0-r1.ebuild
@@ -68,6 +68,8 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.0
"
+PATCHES=( "${FILESDIR}"/${P}-pandoc-2.12.patch )
+
src_prepare() {
default