summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/ikiwiki/ikiwiki-3.20140227.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/ikiwiki/ikiwiki-3.20140227.ebuild')
-rw-r--r--www-apps/ikiwiki/ikiwiki-3.20140227.ebuild111
1 files changed, 111 insertions, 0 deletions
diff --git a/www-apps/ikiwiki/ikiwiki-3.20140227.ebuild b/www-apps/ikiwiki/ikiwiki-3.20140227.ebuild
new file mode 100644
index 000000000000..a3074d54689d
--- /dev/null
+++ b/www-apps/ikiwiki/ikiwiki-3.20140227.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="A wiki compiler"
+HOMEPAGE="http://ikiwiki.info/"
+SRC_URI="mirror://debian/pool/main/i/ikiwiki/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="extras minimal test"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}/${PN}
+
+#Authen::Passphrase
+#Search::Xapian
+#Locale::gettext
+#Crypt::SSLeay
+#Text::CSV
+#Text::Typography
+#Text::Textile
+#Text::WikiFormat
+#Net::Amazon::S3
+
+EXTRA_RDEPEND="
+ dev-python/docutils
+ dev-perl/Digest-SHA1
+ dev-perl/File-MimeInfo
+ dev-perl/RPC-XML
+ dev-perl/XML-Feed
+ dev-perl/LWPx-ParanoidAgent
+ dev-perl/Net-OpenID-Consumer
+"
+
+SUGGESTED_RDEPEND="
+ dev-perl/CGI
+ >=dev-perl/CGI-FormBuilder-3.0202
+ >=dev-perl/CGI-Session-4.14
+ dev-perl/Mail-Sendmail
+ dev-perl/Term-ReadLine-Gnu
+ dev-perl/XML-Simple
+ media-gfx/imagemagick[perl]
+"
+
+TEST_DEPEND="
+ dev-perl/File-chdir
+ dev-perl/File-ReadBackwards
+ dev-perl/File-MimeInfo
+ dev-perl/HTML-LinkExtractor
+ dev-perl/HTML-Tree
+ dev-perl/Net-OpenID-Consumer
+ dev-perl/RPC-XML
+ dev-perl/XML-Feed
+ dev-perl/XML-Twig
+ dev-vcs/cvs[server]
+ dev-vcs/cvsps"
+
+DEPEND="
+ >=dev-lang/perl-5.10
+ app-text/po4a
+ dev-perl/HTML-Parser
+ dev-perl/HTML-Scrubber
+ dev-perl/HTML-Template
+ dev-perl/URI
+ dev-perl/Text-Markdown
+ dev-perl/TimeDate
+ dev-perl/YAML-LibYAML
+"
+
+RDEPEND="${DEPEND}
+ !minimal? (
+ ${SUGGESTED_RDEPEND}
+ extras? (
+ ${EXTRA_RDEPEND}
+ )
+ )
+"
+
+DEPEND="${DEPEND}
+ test? ( ${TEST_DEPEND} )"
+
+SRC_TEST=do
+
+src_prepare() {
+ #bug 498444 /usr/lib/plan9/lib/fortunes.index
+ addpredict "/usr/lib/plan9/lib/fortunes"
+
+ sed -i 's,lib/ikiwiki,libexec/ikiwiki,' \
+ "${S}"/{IkiWiki.pm,Makefile.PL,doc/plugins/install.mdwn} || die
+# if use w3m ; then
+ sed -i 's,lib/w3m,libexec/w3m,' "${S}"/Makefile.PL || die
+# else
+# sed -i '/w3m/d' "${S}"/Makefile.PL || die
+# fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" pure_install
+ insinto /etc/ikiwiki
+ doins wikilist
+
+ #insinto /usr/share/doc/${PF}/examples
+ #doins -r doc/examples/*
+ dohtml -r -A setup html/*
+ dodoc debian/{NEWS,changelog}
+}