summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-05-06 10:12:21 +0200
committerHans de Graaff <graaff@gentoo.org>2018-05-06 10:14:23 +0200
commit48f6d02c9b70c95c994a57e46819a51e2db0c72e (patch)
treeb66a40bc709e8a6dd0a920260f3855d3f4093b63 /www-apps/jekyll-sitemap/jekyll-sitemap-0.13.0.ebuild
parentwww-apps/jekyll-sitemap: add ruby24 (diff)
downloadgentoo-48f6d02c9b70c95c994a57e46819a51e2db0c72e.tar.gz
gentoo-48f6d02c9b70c95c994a57e46819a51e2db0c72e.tar.bz2
gentoo-48f6d02c9b70c95c994a57e46819a51e2db0c72e.zip
www-apps/jekyll-sitemap: add 0.13.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'www-apps/jekyll-sitemap/jekyll-sitemap-0.13.0.ebuild')
-rw-r--r--www-apps/jekyll-sitemap/jekyll-sitemap-0.13.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/www-apps/jekyll-sitemap/jekyll-sitemap-0.13.0.ebuild b/www-apps/jekyll-sitemap/jekyll-sitemap-0.13.0.ebuild
new file mode 100644
index 000000000000..9c4ccade8b48
--- /dev/null
+++ b/www-apps/jekyll-sitemap/jekyll-sitemap-0.13.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md History.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Automatically generate a sitemap.xml for your Jekyll site"
+HOMEPAGE="https://github.com/jekyll/jekyll-sitemap"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=www-apps/jekyll-2 )"
+ruby_add_rdepend ">=dev-ruby/addressable-2.4.0"