summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-09 11:05:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-09 12:07:21 +0200
commit93d8aa91480791f62232d237a39f69d6c6625b76 (patch)
treefb674544a284e7fc4d5b9b6df5650f6032c593dd /www-apps/jekyll
parentdev-python/irc: remove unnecessary test dependency (diff)
downloadgentoo-93d8aa91480791f62232d237a39f69d6c6625b76.tar.gz
gentoo-93d8aa91480791f62232d237a39f69d6c6625b76.tar.bz2
gentoo-93d8aa91480791f62232d237a39f69d6c6625b76.zip
www-apps/jekyll: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-apps/jekyll')
-rw-r--r--www-apps/jekyll/Manifest2
-rw-r--r--www-apps/jekyll/jekyll-3.8.5.ebuild81
-rw-r--r--www-apps/jekyll/jekyll-4.1.0.ebuild90
3 files changed, 0 insertions, 173 deletions
diff --git a/www-apps/jekyll/Manifest b/www-apps/jekyll/Manifest
index 5f7915f13ed7..5b9729c8243d 100644
--- a/www-apps/jekyll/Manifest
+++ b/www-apps/jekyll/Manifest
@@ -1,3 +1 @@
-DIST jekyll-3.8.5.tar.gz 852490 BLAKE2B 3831c68c8c17b5ca14521988572849b89c8cd37f3fa4d7048adb7e25319f59a31e6174a6d25fb5ba4d33c919389f3a30cb28274cddd29ea644ec5d5aa11875e7 SHA512 2cd6bb8786fa2efc249457f72e9e1a3dc76c61a23d2ed8388fef56f1bd576897260b199edb393eb358cfe3a0b26487e40cc2fd3502c52cc9c828839b9eef624d
-DIST jekyll-4.1.0.tar.gz 1397143 BLAKE2B f7021fdc418acefa1b7e92318225ff8afff8dd84a0134906bb48ae461a94e4a71a8d0de0800ea489a3bd3eb7bfa36be4b8781e4c89729d5adc9e8ddc3b711dc3 SHA512 fdd9b28ff065a1dbe78f197c618bdd00bfeb37f66983c55ce971edcc96c3af39d926ec64b3866084dc8c21a56764ecdfb61d954123b15fe41a9de68fc951dc48
DIST jekyll-4.1.1.tar.gz 1398438 BLAKE2B ac207d58b155e069fda40b4598d441d8fb88f22e85740082829d018dc9cefe51ca636b23a6207c37711c4d26e078f6e4913946599f0200b8e8cb065a9ceff952 SHA512 98c635b54219c9666de6496e76f3a131fc715d650d868049c0fe10d76851a027e0808609c2dce1a138c95eb2fb7e58ef978237a305484071339b4a15d5acc4d5
diff --git a/www-apps/jekyll/jekyll-3.8.5.ebuild b/www-apps/jekyll/jekyll-3.8.5.ebuild
deleted file mode 100644
index 37240e5d51b3..000000000000
--- a/www-apps/jekyll/jekyll-3.8.5.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
-
-inherit ruby-fakegem
-
-RUBY_FAKEGEM_EXTRADOC="README.markdown History.markdown"
-RUBY_FAKEGEM_EXTRAINSTALL="features"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-RUBY_FAKEGEM_BINDIR="exe"
-
-DESCRIPTION="A simple, blog aware, static site generator"
-HOMEPAGE="https://jekyllrb.com https://github.com/jekyll/jekyll"
-SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-ruby_add_rdepend "
- >=dev-ruby/addressable-2.4
- >=dev-ruby/colorator-1.0i
- >=dev-ruby/em-websocket-0.5
- >=dev-ruby/i18n-0.7:0.7
- >=dev-ruby/kramdown-1.14
- >=dev-ruby/liquid-4.0:4
- >=dev-ruby/mercenary-0.3.3
- >=dev-ruby/pathutil-0.9
- >=dev-ruby/safe_yaml-1.0
- || ( dev-ruby/rouge:2 >=dev-ruby/rouge-1.7:0 )
- >=www-apps/jekyll-sass-converter-1.0
- >=www-apps/jekyll-watch-2.0
-"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/classifier-reborn-2.1.0
- dev-ruby/launchy
- >=dev-ruby/pygments_rb-0.6.0
- >=dev-ruby/rdiscount-2.0
- >=dev-ruby/redcarpet-3.2.3
- dev-ruby/rspec-mocks
- >=dev-ruby/shoulda-3
- dev-ruby/test-unit:2
- www-apps/jekyll-coffeescript
- )
-"
-
-all_ruby_prepare() {
- eapply "${FILESDIR}"/jekyll-3.6.0-test-helper.patch
-
- # Drop tests requiring bundler
- sed -i -e '/bundle_message/d' test/test_new_command.rb || die
- rm test/test_plugin_manager.rb || die
-
- # Replace git command in gemspec
- sed -i 's/git ls-files -z/find -not -type d -print0/' $RUBY_FAKEGEM_GEMSPEC || die
-
- # FIXMEs:
- # fails to find fixtures
- rm test/test_theme.rb || die
- rm test/test_theme_assets_reader.rb || die
- sed -i -e '/^ should.*theme/,/^ end$/d' \
- -e '/^ should.*theme/,/^ end$/d' test/test_site.rb || die
- # partially requires 'toml'
- rm test/test_configuration.rb || die
- # pygments tests fail because of line numbering
- sed -i -e '/^ context.*pygments/,/^ end$/d' test/test_tags.rb || die
- sed -i -e '/^ context.*pygments/,/^ end$/d' test/test_redcarpet.rb || die
-}
-
-src_test() {
- local -x JEKYLL_NO_BUNDLER_REQUIRE=true
-
- ruby-ng_src_test
-}
diff --git a/www-apps/jekyll/jekyll-4.1.0.ebuild b/www-apps/jekyll/jekyll-4.1.0.ebuild
deleted file mode 100644
index b60329211a3f..000000000000
--- a/www-apps/jekyll/jekyll-4.1.0.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26"
-
-inherit ruby-fakegem
-
-RUBY_FAKEGEM_EXTRADOC="README.markdown History.markdown"
-RUBY_FAKEGEM_EXTRAINSTALL="features"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-RUBY_FAKEGEM_BINDIR="exe"
-
-DESCRIPTION="A simple, blog aware, static site generator"
-HOMEPAGE="https://jekyllrb.com https://github.com/jekyll/jekyll"
-SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="test"
-
-ruby_add_rdepend "
- >=dev-ruby/addressable-2.4
- >=dev-ruby/colorator-1.0
- >=dev-ruby/em-websocket-0.5
- dev-ruby/i18n:1
- >=dev-ruby/kramdown-2.1:2
- dev-ruby/kramdown-parser-gfm:1
- dev-ruby/liquid:4
- >=dev-ruby/mercenary-0.4.0
- >=dev-ruby/pathutil-0.9
- =dev-ruby/rouge-3*
- >=dev-ruby/safe_yaml-1.0
- >=dev-ruby/terminal-table-1.8:0
- >=www-apps/jekyll-sass-converter-2.0
- >=www-apps/jekyll-watch-2.0
-"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/classifier-reborn-2.1.0
- dev-ruby/launchy
- >=dev-ruby/pygments_rb-0.6.0
- >=dev-ruby/rdiscount-2.0
- >=dev-ruby/redcarpet-3.2.3
- dev-ruby/rspec-mocks
- >=dev-ruby/shoulda-3
- dev-ruby/test-unit:2
- www-apps/jekyll-coffeescript
- )
-"
-
-all_ruby_prepare() {
- eapply "${FILESDIR}"/jekyll-3.6.0-test-helper.patch
-
- # Drop tests requiring bundler
- sed -i -e '/bundle_message/d' test/test_new_command.rb || die
- rm test/test_plugin_manager.rb || die
-
- # Replace git command in gemspec
- sed -e 's/git ls-files/find -not -type d -print/' \
- -e 's:_relative ": "./:' \
- -i $RUBY_FAKEGEM_GEMSPEC || die
-
- # FIXMEs:
- # fails to find fixtures because this requires bundler
- rm test/test_theme.rb || die
- rm test/test_theme_assets_reader.rb || die
- sed -i -e '/^ should.*theme/,/^ end$/d' \
- -e '/^ should.*theme/,/^ end$/d' test/test_site.rb || die
- sed -i -e '/context "with a theme"/,/^ end/ s:^:#:' test/test_layout_reader.rb || die
- sed -i -e '/normalize paths of rendered items/askip "test-theme"' test/test_liquid_renderer.rb || die
- # partially requires 'toml'
- rm test/test_configuration.rb || die
- # pygments tests fail because of line numbering
- sed -i -e '/^ context.*pygments/,/^ end$/d' test/test_tags.rb || die
- #sed -i -e '/^ context.*pygments/,/^ end$/d' test/test_redcarpet.rb || die
-
- # Tries to use bundler and install packages.
- rm -f test/test_new_command.rb || die
-}
-
-src_test() {
- local -x JEKYLL_NO_BUNDLER_REQUIRE=true
-
- ruby-ng_src_test
-}