summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-03-11 18:11:40 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-03-11 18:12:45 +0100
commitcb5ce2b431b892d312d67a117f6460c324f62440 (patch)
treea1e2085bbd4c5d2d75a481e86d88f73773cd3e62 /www-apps/klaus/klaus-1.5.2.ebuild
parentdev-python/python-ctags: add Python 3.8 support, add slot operator (diff)
downloadgentoo-cb5ce2b431b892d312d67a117f6460c324f62440.tar.gz
gentoo-cb5ce2b431b892d312d67a117f6460c324f62440.tar.bz2
gentoo-cb5ce2b431b892d312d67a117f6460c324f62440.zip
www-apps/klaus: bump to 1.5.2, add Python 3.8 support
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'www-apps/klaus/klaus-1.5.2.ebuild')
-rw-r--r--www-apps/klaus/klaus-1.5.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/www-apps/klaus/klaus-1.5.2.ebuild b/www-apps/klaus/klaus-1.5.2.ebuild
new file mode 100644
index 000000000000..351c5e29721b
--- /dev/null
+++ b/www-apps/klaus/klaus-1.5.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple, easy-to-set-up Git web viewer"
+HOMEPAGE="https://github.com/jonashaag/klaus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ctags"
+
+RDEPEND="
+ >=dev-python/dulwich-0.19.3[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/httpauth[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ctags? ( dev-python/python-ctags[${PYTHON_USEDEP}] )
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# The tests can only be run from a git repository
+# so they are not included in the source distributions
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}