summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-08 18:52:12 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-08 19:11:01 +0100
commit7efce20edc636e00f960eeeab798208ee3cccfcc (patch)
tree10405b5479d3b407e3bcecd16ac93264a3165a2d /www-apps/mod_survey
parentwww-client/google-chrome: depend on >=dev-libs/nss-3.26 (diff)
downloadgentoo-7efce20edc636e00f960eeeab798208ee3cccfcc.tar.gz
gentoo-7efce20edc636e00f960eeeab798208ee3cccfcc.tar.bz2
gentoo-7efce20edc636e00f960eeeab798208ee3cccfcc.zip
www-apps/mod_survey: Remove linguas_* USE flags.
Don't bother with setting a default language, which can never work reliably when it is based on the order of entries in LINGUAS. Stay with the upstream default (English) instead, which can be changed in the config file. Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'www-apps/mod_survey')
-rw-r--r--www-apps/mod_survey/mod_survey-3.2.5.ebuild33
1 files changed, 4 insertions, 29 deletions
diff --git a/www-apps/mod_survey/mod_survey-3.2.5.ebuild b/www-apps/mod_survey/mod_survey-3.2.5.ebuild
index 130996dca760..4fef9c59543a 100644
--- a/www-apps/mod_survey/mod_survey-3.2.5.ebuild
+++ b/www-apps/mod_survey/mod_survey-3.2.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
inherit depend.apache webapp
@@ -17,11 +17,6 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc mysql nls postgres"
-LANGS="en de fr it sv"
-for i in ${LANGS}; do
- IUSE="${IUSE} linguas_${i}"
-done
-
DEPEND=">=dev-lang/perl-5.6.1"
RDEPEND="${DEPEND}
>=www-apache/mod_perl-1.99
@@ -36,28 +31,9 @@ pkg_setup() {
has_apache
if use nls; then
- for i in ${LINGUAS}; do
- if has linguas_${i} ${IUSE}; then
- if use linguas_${i}; then
- locallang="${i}"
- ewarn "${i} from the LINGUAS variable has been set as the"
- ewarn "default language. This can be overriden on a"
- ewarn "per-survey basis, or changed in"
- ewarn "${APACHE_MODULES_CONFDIR}/98_${PN}.conf"
- ewarn
- break
- fi
- else
- einfo "LINGUAS=${i} is not supported by ${P}"
- shift
- fi
- done
- fi
-
- if [[ -z ${locallang} ]]; then
- [[ -n "${LINGUAS}" ]] && ewarn "None of ${LINGUAS} supported."
- use nls && ewarn "Will use English as default language."
- locallang="en"
+ ewarn "English will be set as the default language."
+ ewarn "This can be overriden on a per-survey basis, or changed in"
+ ewarn "${APACHE_MODULES_CONFDIR}/98_${PN}.conf"
fi
}
@@ -66,7 +42,6 @@ src_unpack() {
cd "${S}"
sed -i \
- -e "s|\$lang = \"en\"|\$lang = \"${locallang}\"|" \
-e "s|/usr/local/mod_survey/|${D}/usr/lib/mod_survey/|g" \
installer.pl