summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Andrejak <thomas.andrejak@gmail.com>2019-11-07 02:40:36 +0100
committerGöktürk Yüksek <gokturk@gentoo.org>2019-12-24 16:54:51 -0500
commitb96ac1a5c074bdd68204cde4b02fc3abb8efe7c5 (patch)
tree427c8791c38d43caa8b34fb3587080d4b1569ad9 /www-apps/prewikka/prewikka-5.1.1.ebuild
parentdev-python/lark-parser: Add new package (diff)
downloadgentoo-b96ac1a5c074bdd68204cde4b02fc3abb8efe7c5.tar.gz
gentoo-b96ac1a5c074bdd68204cde4b02fc3abb8efe7c5.tar.bz2
gentoo-b96ac1a5c074bdd68204cde4b02fc3abb8efe7c5.zip
www-apps/prewikka: Bump version 5.1
Closes: https://github.com/gentoo/gentoo/pull/13578 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'www-apps/prewikka/prewikka-5.1.1.ebuild')
-rw-r--r--www-apps/prewikka/prewikka-5.1.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/www-apps/prewikka/prewikka-5.1.1.ebuild b/www-apps/prewikka/prewikka-5.1.1.ebuild
new file mode 100644
index 000000000000..1ab92c9ebfde
--- /dev/null
+++ b/www-apps/prewikka/prewikka-5.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="ssl"
+
+inherit distutils-r1
+
+DESCRIPTION="Graphical front-end analysis console for the Prelude Framework"
+HOMEPAGE="https://www.prelude-siem.org"
+SRC_URI="https://www.prelude-siem.org/pkg/src/5.1.0/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/libprelude-5.1.0[python,${PYTHON_USEDEP}]
+ <dev-libs/libprelude-6[python,${PYTHON_USEDEP}]
+ >=dev-libs/libpreludedb-5.1.0[python,${PYTHON_USEDEP}]
+ <dev-libs/libpreludedb-6[python,${PYTHON_USEDEP}]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/lark-parser[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/voluptuous[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ media-fonts/font-xfree86-type1"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="dev-python/lesscpy[${PYTHON_USEDEP}]
+ sys-devel/gettext"
+
+pkg_postinst() {
+ optfeature "Asynchronous DNS" dev-python/twisted[${PYTHON_USEDEP}]
+}