summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/sitebar/sitebar-3.3.9-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/sitebar/sitebar-3.3.9-r2.ebuild')
-rw-r--r--www-apps/sitebar/sitebar-3.3.9-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/www-apps/sitebar/sitebar-3.3.9-r2.ebuild b/www-apps/sitebar/sitebar-3.3.9-r2.ebuild
new file mode 100644
index 000000000000..42bf24c1a843
--- /dev/null
+++ b/www-apps/sitebar/sitebar-3.3.9-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base webapp
+
+MY_P="SiteBar-${PV}"
+
+DESCRIPTION="The Bookmark Server for Personal and Team Use"
+HOMEPAGE="http://sitebar.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2
+ plugins? (
+ mirror://sourceforge/${PN}/SiteBarPluginIMAP_3.3.7_1.1.zip
+ mirror://sourceforge/${PN}/SiteBarPluginLDAP_3.3.7_1.1.zip
+ mirror://sourceforge/${PN}/SiteBarPluginMailGate_3.3.7_1.0.4.zip
+ mirror://sourceforge/${PN}/SiteBarPluginMessenger_3.3.7_1.2.zip
+ mirror://sourceforge/${PN}/SiteBarPluginXBELSync_3.3.7_1.1.zip
+ )"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+IUSE="plugins"
+
+DEPEND="virtual/httpd-php"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/inc_writer.inc.php.diff" ) # PHP 5.3 patch
+DOCS=( readme.txt doc/history.txt doc/install.txt doc/troubleshooting.txt )
+
+src_install() {
+ webapp_src_preinst
+ base_src_install_docs
+ cp -R . "${D}/${MY_HTDOCSDIR}"
+ use plugins && cp -R "${WORKDIR}/plugins/." "${D}/${MY_HTDOCSDIR}/plugins/."
+ rm -rf "${D}/${MY_HTDOCSDIR}/doc" "${D}/${MY_HTDOCSDIR}/readme.txt"
+
+ webapp_serverowned "${MY_HTDOCSDIR}/inc"
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+
+ webapp_src_install
+}