summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 21:27:53 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:37:12 +0100
commitfa5ded6d130c632cf601594066d33a11297ec384 (patch)
tree2f4911a67f690fe1f7f5bbc6566c85013baf17dd /www-apps/venus
parentwww-apps/netbox: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-fa5ded6d130c632cf601594066d33a11297ec384.tar.gz
gentoo-fa5ded6d130c632cf601594066d33a11297ec384.tar.bz2
gentoo-fa5ded6d130c632cf601594066d33a11297ec384.zip
www-apps/venus: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-apps/venus')
-rw-r--r--www-apps/venus/venus-20100911-r3.ebuild (renamed from www-apps/venus/venus-20100911-r1.ebuild)18
-rw-r--r--www-apps/venus/venus-20100911-r4.ebuild (renamed from www-apps/venus/venus-20100911-r2.ebuild)18
2 files changed, 20 insertions, 16 deletions
diff --git a/www-apps/venus/venus-20100911-r1.ebuild b/www-apps/venus/venus-20100911-r3.ebuild
index 44d5059cd316..228801836103 100644
--- a/www-apps/venus/venus-20100911-r1.ebuild
+++ b/www-apps/venus/venus-20100911-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,13 +19,15 @@ RESTRICT="!test? ( test )"
SLOT="0"
RDEPEND="
- dev-python/bsddb3[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/utidylib[${PYTHON_USEDEP}]
- django? ( dev-python/django[${PYTHON_USEDEP}] )
- genshi? ( dev-python/genshi[${PYTHON_USEDEP}] )
- redland? ( dev-python/rdflib[redland,${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep '
+ dev-python/bsddb3[${PYTHON_MULTI_USEDEP}]
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/httplib2[${PYTHON_MULTI_USEDEP}]
+ dev-python/utidylib[${PYTHON_MULTI_USEDEP}]
+ django? ( dev-python/django[${PYTHON_MULTI_USEDEP}] )
+ genshi? ( dev-python/genshi[${PYTHON_MULTI_USEDEP}] )
+ redland? ( dev-python/rdflib[redland,${PYTHON_MULTI_USEDEP}] )
+ ')
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
diff --git a/www-apps/venus/venus-20100911-r2.ebuild b/www-apps/venus/venus-20100911-r4.ebuild
index dd264089df00..cd6f9036e379 100644
--- a/www-apps/venus/venus-20100911-r2.ebuild
+++ b/www-apps/venus/venus-20100911-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,13 +19,15 @@ RESTRICT="!test? ( test )"
SLOT="0"
RDEPEND="
- dev-python/bsddb3[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/utidylib[${PYTHON_USEDEP}]
- django? ( dev-python/django[${PYTHON_USEDEP}] )
- genshi? ( dev-python/genshi[${PYTHON_USEDEP}] )
- redland? ( dev-python/rdflib[redland,${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep '
+ dev-python/bsddb3[${PYTHON_MULTI_USEDEP}]
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/httplib2[${PYTHON_MULTI_USEDEP}]
+ dev-python/utidylib[${PYTHON_MULTI_USEDEP}]
+ django? ( dev-python/django[${PYTHON_MULTI_USEDEP}] )
+ genshi? ( dev-python/genshi[${PYTHON_MULTI_USEDEP}] )
+ redland? ( dev-python/rdflib[redland,${PYTHON_MULTI_USEDEP}] )
+ ')
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"