summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-09-23 18:43:34 -0400
committerAaron Bauman <bman@gentoo.org>2020-09-23 18:43:50 -0400
commitfe053de4d4682e6a4524bcd0d54fbb23da6ca9f3 (patch)
treeedc4aff904432aedef0a116d43d1efcfb04b92f2 /www-apps/webdavcgi
parentx11-plugins/wmxres: 1.4 bump (diff)
downloadgentoo-fe053de4d4682e6a4524bcd0d54fbb23da6ca9f3.tar.gz
gentoo-fe053de4d4682e6a4524bcd0d54fbb23da6ca9f3.tar.bz2
gentoo-fe053de4d4682e6a4524bcd0d54fbb23da6ca9f3.zip
www-apps/webdavcgi: drop old EAPIs
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'www-apps/webdavcgi')
-rw-r--r--www-apps/webdavcgi/Manifest2
-rw-r--r--www-apps/webdavcgi/webdavcgi-0.8.3.ebuild107
-rw-r--r--www-apps/webdavcgi/webdavcgi-0.8.4.ebuild163
3 files changed, 0 insertions, 272 deletions
diff --git a/www-apps/webdavcgi/Manifest b/www-apps/webdavcgi/Manifest
index 91abe670cbe0..107cebddc770 100644
--- a/www-apps/webdavcgi/Manifest
+++ b/www-apps/webdavcgi/Manifest
@@ -1,3 +1 @@
-DIST webdavcgi-0.8.3.tar.bz2 1190975 BLAKE2B 7935474a850afde362faf244d3b6047e86f8c509e1b54e452c2cecd15a08bbbb5c91c862fc70142e8958d9d6cd687f85bd482d6472ba12b22c9027b9cdb7e106 SHA512 f50e6bb1e78a88ab6bc6452c04f2e5d0cec86f6641d1813556ae3b06c33e2c9250e623926bf1a71ea10f6ca3912e708cb54cd0956b344329de1499887e48e784
-DIST webdavcgi-0.8.4.tar.bz2 1195935 BLAKE2B 7f914d8f9f04354c6887303482ae72e8b4b24751e58aae225b1bc8182dd22e9644e1386b9d5823a610c49ebf0a5676838cfd7e0a1fcc20cce7e34c08d49966af SHA512 17d9dcfe68012820bf809bc3bd54a881fc9e66a9ddfd87d9381ec0cb08abe3f81638afba4d28ab3079ed56cf1e263b4a764b8348691f17a06743bb1ddf3a2a4e
DIST webdavcgi-1.1.1.tar.bz2 11623234 BLAKE2B a5a2b67f2666ce4180e5ed145045b8552e6e988967d99bad518d72a67a417ce600619b11af9171aa291bb4b98ec0b0c8c3ce56511d65c4e8b8c92932e8da418f SHA512 660b3e54d72c5b96c1fb329d8e0838b1dbf68e1671af3880f7e096bfdfe559909cf3e1e3069fe4877e0ffbd67d24dc4a38c3db8baaae6d62db05bde31cea789f
diff --git a/www-apps/webdavcgi/webdavcgi-0.8.3.ebuild b/www-apps/webdavcgi/webdavcgi-0.8.3.ebuild
deleted file mode 100644
index b2e189821039..000000000000
--- a/www-apps/webdavcgi/webdavcgi-0.8.3.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs webapp
-
-DESCRIPTION="A Perl CGI for accessing and sharing files, or calendar/addressbooks via WebDAV"
-HOMEPAGE="http://webdavcgi.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-WEBAPP_MANUAL_SLOT="yes"
-KEYWORDS="~amd64"
-IUSE="mysql postgres rcs samba +sqlite +suid"
-
-DEPEND=""
-RDEPEND="dev-perl/Archive-Zip
- dev-perl/File-Copy-Link
- dev-perl/PerlIO-gzip
- dev-perl/Quota
- dev-perl/TimeDate
- dev-perl/URI
- dev-perl/UUID-Tiny
- dev-perl/XML-Simple
- media-gfx/graphicsmagick[perl]
- mysql? ( dev-perl/DBD-mysql )
- virtual/perl-Module-Load
- postgres? ( dev-perl/DBD-Pg )
- rcs? ( dev-perl/Rcs )
- samba? ( dev-perl/Filesys-SmbClient )
- sqlite? ( dev-perl/DBD-SQLite )
- dev-perl/CGI
- virtual/perl-File-Spec"
-
-need_httpd_cgi
-
-REQUIRED_USE="|| ( mysql postgres sqlite )"
-
-CGIBINDIR="cgi-bin"
-
-src_prepare() {
- epatch "${FILESDIR}/${PV}-logout-var-expansion.patch"
-}
-
-src_compile() {
- if use suid; then
- # There are several webdavwrappers, TODO: make it configureable
- export WEBDAVWRAPPER="webdavwrapper"
-
- $(tc-getCC) ${LDFLAGS} ${CFLAGS} \
- -o "${CGIBINDIR}/${WEBDAVWRAPPER}" \
- helper/webdavwrapper.c || die "compile ${WEBDAVWRAPPER} failed"
- fi
-}
-
-src_install() {
- webapp_src_preinst
-
- local htdocsDir='htdocs'
- local confDir='etc'
-
- local installDirs="$confDir lib locale"
-
- insinto "${MY_HTDOCSDIR}"
- doins -r "${htdocsDir}"/*
-
- exeinto "${MY_CGIBINDIR}"
- newexe "${CGIBINDIR}/logout-dist" logout
-
- doexe "${CGIBINDIR}/webdav.pl"
- use suid && doexe "${CGIBINDIR}/${WEBDAVWRAPPER}"
-
- local currentDir
- for currentDir in ${installDirs}; do
- dodir "${MY_HOSTROOTDIR}/${currentDir}"
- insinto "${MY_HOSTROOTDIR}/${currentDir}"
- doins -r "${currentDir}"/*
- done
-
- webapp_configfile "${MY_HOSTROOTDIR}/${confDir}"/{webdav.conf-dist,mime.types}
-
- use mysql && webapp_sqlscript mysql sql/mysql.sql
- use postgres && webapp_sqlscript postgres sql/postgresql.sql
-
- dodoc CHANGELOG TODO
- dohtml -r doc/*
-
- webapp_hook_script "${FILESDIR}/reconfig"
-
- webapp_src_install
-
- # In order to change the user and group ID at runtime, the webdavwrapper
- # needs to be run as root (set-user-ID and set-group-ID bit)
- if use suid; then
- einfo "Setting SUID and SGID bit for ${WEBDAVWRAPPER}"
- fowners root:root "${MY_CGIBINDIR}/${WEBDAVWRAPPER}"
- fperms 6755 "${MY_CGIBINDIR}/${WEBDAVWRAPPER}"
- webapp_postinst_txt en "${FILESDIR}/postinstall-${WEBDAVWRAPPER}-en.txt"
- webapp_hook_script "${FILESDIR}/reconfig-suid"
- else
- ewarn "You have the 'suid' USE flag disabled"
- ewarn "WebDAV CGI won't be able to switch user ids"
- webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
- fi
-}
diff --git a/www-apps/webdavcgi/webdavcgi-0.8.4.ebuild b/www-apps/webdavcgi/webdavcgi-0.8.4.ebuild
deleted file mode 100644
index 45fbb4226ce9..000000000000
--- a/www-apps/webdavcgi/webdavcgi-0.8.4.ebuild
+++ /dev/null
@@ -1,163 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs versionator
-
-DESCRIPTION="A Perl CGI for accessing and sharing files, or calendar/addressbooks via WebDAV"
-HOMEPAGE="http://webdavcgi.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-
-# Provide slotting on minor versions. WebDAV CGI is a web application which
-# can be shared by multiple instances and thus major updates shouldn't be
-# enforced to all users/instances at the same time.
-SLOT="$(get_version_component_range 1-2)"
-
-KEYWORDS="~amd64"
-IUSE="afs kerberos mysql postgres rcs samba +sqlite +suid"
-
-DEPEND=""
-RDEPEND="!www-apps/webdavcgi:0
- afs? ( net-fs/openafs )
- dev-lang/perl
- dev-perl/Archive-Zip
- dev-perl/File-Copy-Link
- dev-perl/PerlIO-gzip
- dev-perl/Quota
- dev-perl/TimeDate
- dev-perl/URI
- dev-perl/UUID-Tiny
- dev-perl/XML-Simple
- kerberos? ( virtual/krb5 )
- media-gfx/graphicsmagick[perl]
- mysql? ( dev-perl/DBD-mysql )
- virtual/perl-Module-Load
- postgres? ( dev-perl/DBD-Pg )
- rcs? ( dev-perl/Rcs )
- samba? ( dev-perl/Filesys-SmbClient )
- sqlite? ( dev-perl/DBD-SQLite )
- dev-perl/CGI
- virtual/perl-File-Spec
- || ( virtual/httpd-cgi virtual/httpd-fastcgi )"
-
-REQUIRED_USE="|| ( mysql postgres sqlite )"
-
-CGIBINDIR="cgi-bin"
-
-src_compile() {
- if use suid; then
- WEBDAVWRAPPERS="webdavwrapper" # Standard UID/GID wrapper
-
- use afs && WEBDAVWRAPPERS+=" webdavwrapper-afs"
- use kerberos && WEBDAVWRAPPERS+=" webdavwrapper-krb"
-
- export WEBDAVWRAPPERS
-
- local wrapper
- for wrapper in ${WEBDAVWRAPPERS}; do
- $(tc-getCC) ${LDFLAGS} ${CFLAGS} \
- -o "${CGIBINDIR}/${wrapper}" \
- "helper/${wrapper}.c" || die "compile ${wrapper} failed"
- done
- fi
-}
-
-src_install() {
- exeinto "/usr/libexec/${PN}-${SLOT}/${CGIBINDIR}"
- newexe "${CGIBINDIR}/logout-dist" "logout"
- doexe "${CGIBINDIR}/webdav.pl"
-
- use afs && doexe "${CGIBINDIR}/afswrapper"
- use samba && doexe "${CGIBINDIR}/smbwrapper"
-
- if use suid; then
- # In order to change the user and group ID at runtime, the webdavwrapper
- # needs to be run as root (set-user-ID and set-group-ID bit)
- exeopts -o root -g root -m 6755
-
- local wrapper
- for wrapper in ${WEBDAVWRAPPERS}; do
- einfo "Installing UID/GID wrapper ${wrapper}"
- doexe "${CGIBINDIR}/${wrapper}"
- done
-
- # reset install opts
- exeopts
- else
- ewarn "You have the 'suid' USE flag disabled"
- ewarn "WebDAV CGI won't be able to switch user ids"
- fi
-
- local confDir='etc'
- local webdavConfDir="/etc/${PN}-${SLOT}/default"
-
- export WEBDAVCONFIG="${webdavConfDir}/webdav.conf"
-
- insinto "${webdavConfDir}"
- doins "${confDir}/mime.types"
- newins "${FILESDIR}/webdav-${SLOT}.conf" "webdav.conf"
-
- local installBaseDir="/usr/share/${PN}-${SLOT}"
- local currentDir
- for currentDir in htdocs lib locale; do
- insinto "${installBaseDir}/${currentDir}"
- doins -r "${currentDir}"/*
- done
-
- if use mysql || use postgres; then
- local sqlDir='sql'
- insinto "${installBaseDir}/${sqlDir}"
- use mysql && "${sqlDir}/mysql.sql"
- use postgres && "${sqlDir}/postgresql.sql"
- fi
-
- if use sqlite; then
- # Directory where the SQLite database resides
- local sqliteRootDir="/var/lib/${PN}/${SLOT}"
- keepdir "${sqliteRootDir}"
-
- # Default database directory where all users are able to create and
- # share the databases, this can be changed within the config file and
- # restricted to user/group only access if required.
- export SQLITEDIR="${sqliteRootDir}/default"
- keepdir "${SQLITEDIR}"
- fperms 1777 "${SQLITEDIR}"
- fi
-
- # Default thumbnail directory, writable by all users
- export THUMBNAILDIR="/var/cache/${PN}/${SLOT}/default/thumbnails"
- keepdir "${THUMBNAILDIR}"
- fperms 1777 "${THUMBNAILDIR}"
-
- export APACHEEXAMPLECONFIG="apache-webdavcgi-${SLOT}-example.conf"
- dodoc CHANGELOG TODO
- dodoc "${FILESDIR}/${APACHEEXAMPLECONFIG}"
- dohtml -r doc/*
-}
-
-pkg_postinst() {
- ewarn "In order to allow different users to create and share files,"
- ewarn "some directories were installed with world write access by default."
- ewarn "To set restrictive permissions, add all WebDAV CGI users to a"
- ewarn "common group, and allow access to the following directories by this"
- ewarn "group only."
- ewarn "Thumbnail directory: ${THUMBNAILDIR}"
- use sqlite && ewarn "SQLite directory: ${SQLITEDIR}"
-
- ewarn
- ewarn "Until bug #456180 is fixed, you probably have to re-emerge"
- ewarn "media-gfx/graphicsmagick"
-
- elog
- elog "The WebDAV CGI config is located at ${WEBDAVCONFIG}."
- elog
- elog "An example Apache HTTP server configuration snippet is available in"
- elog "/usr/share/doc/${PF} in the file ${APACHEEXAMPLECONFIG}"
-
- einfo
- einfo "Detailed installation and configuration instructions can be found at"
- einfo "http://webdavcgi.sourceforge.net/"
-}