summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2018-09-12 14:43:57 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2018-09-12 14:43:57 +0300
commite5263327fcdb52efec55c10924b1b056b31706d4 (patch)
tree285bbad054b70f09a1376997d64dc66d0a6c405c /www-apps/wordpress/wordpress-4.9.8.ebuild
parentkde-plasma/oxygen: Fix incorrect symlinks (diff)
downloadgentoo-e5263327fcdb52efec55c10924b1b056b31706d4.tar.gz
gentoo-e5263327fcdb52efec55c10924b1b056b31706d4.tar.bz2
gentoo-e5263327fcdb52efec55c10924b1b056b31706d4.zip
www-apps/wordpress: Version bump
Package-Manager: Portage-2.3.47, Repoman-2.3.10
Diffstat (limited to 'www-apps/wordpress/wordpress-4.9.8.ebuild')
-rw-r--r--www-apps/wordpress/wordpress-4.9.8.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/www-apps/wordpress/wordpress-4.9.8.ebuild b/www-apps/wordpress/wordpress-4.9.8.ebuild
new file mode 100644
index 000000000000..19231ee76d17
--- /dev/null
+++ b/www-apps/wordpress/wordpress-4.9.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+DESCRIPTION="Wordpress PHP and MySQL based content management system (CMS)"
+HOMEPAGE="https://wordpress.org/"
+SRC_URI="https://wordpress.org/${P/_rc/-RC}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="virtual/httpd-php
+ || ( dev-lang/php[mysql] dev-lang/php[mysqli] )"
+
+S=${WORKDIR}/${PN}
+
+need_httpd_cgi
+
+IUSE="+akismet examples +themes vhosts"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc readme.html
+ rm readme.html license.txt || die
+
+ if ! use akismet ; then
+ rm -R wp-content/plugins/akismet/ || die
+ fi
+ if ! use examples ; then
+ rm wp-content/plugins/hello.php || die
+ fi
+ if ! use themes ; then
+ rm -R wp-content/themes/*/ || die
+ fi
+
+ [[ -f wp-config.php ]] || cp wp-config-sample.php wp-config.php
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/index.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/menu.php
+ webapp_serverowned "${MY_HTDOCSDIR}"
+
+ webapp_configfile "${MY_HTDOCSDIR}"/wp-config.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}