summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-03-25 07:24:41 +0000
committerSam James <sam@gentoo.org>2022-03-25 19:25:37 +0000
commit16285c7de71d0281f3e7d26c7c545eff322a21fe (patch)
tree086479a491ec8a447592fea10c31d90222498805 /www-apps
parentwww-apps/gitea: security bump to 1.16.5 (diff)
downloadgentoo-16285c7de71d0281f3e7d26c7c545eff322a21fe.tar.gz
gentoo-16285c7de71d0281f3e7d26c7c545eff322a21fe.tar.bz2
gentoo-16285c7de71d0281f3e7d26c7c545eff322a21fe.zip
www-apps/gitea: drop vulnerable
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24741 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/gitea-1.16.4.ebuild107
2 files changed, 0 insertions, 108 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 878c1f5000f2..5073ac723c94 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1,2 +1 @@
-DIST gitea-1.16.4.tar.gz 49747172 BLAKE2B cab622fd0014b7f9737674973d978055bc02b390c3bb522b3f462ac136eb2a51b335ae7223ed62cd0481bebb5bdbac442fa6c5d36f6b0a8f91f76e43cb44f2f7 SHA512 880a73cf161564e7dddb432a6ae3274896fd8825718f7bb84ec86aa1b36644789914d0fb390e7b5d7d8d0b47078ded3319e20149c677aeefadf8c79735383de0
DIST gitea-1.16.5.tar.gz 53178954 BLAKE2B 67c378a46eab8e374b1a5b91d86e558c6ae06e24a23cb0d670f112573e0606c3ee7f700047f703a73b19f39b216597e3a05c3602e01ecfb09f146515545d3687 SHA512 3c367155a97809d587879b023979ad198106040c362e6d5e6df26cad384c614aaac1c47d84bcac0177a5b5546c4a76e95cfff9cf76b411226c0b1aa618d4d4b3
diff --git a/www-apps/gitea/gitea-1.16.4.ebuild b/www-apps/gitea/gitea-1.16.4.ebuild
deleted file mode 100644
index eaeda1a3f382..000000000000
--- a/www-apps/gitea/gitea-1.16.4.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 2016-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit fcaps go-module tmpfiles systemd
-
-DESCRIPTION="A painless self-hosted Git service"
-HOMEPAGE="https://gitea.io https://github.com/go-gitea/gitea"
-SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64 ~arm ~arm64"
-S="${WORKDIR}"
-
-LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
-SLOT="0"
-IUSE="+acct pam sqlite"
-
-DEPEND="
- acct? (
- acct-group/git
- acct-user/git[gitea] )
- pam? ( sys-libs/pam )"
-RDEPEND="${DEPEND}
- dev-vcs/git"
-
-DOCS=(
- custom/conf/app.example.ini CONTRIBUTING.md README.md
-)
-FILECAPS=(
- -m 711 cap_net_bind_service+ep usr/bin/gitea
-)
-
-RESTRICT="test"
-
-src_prepare() {
- default
-
- local sedcmds=(
- -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
- -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"
- -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
- -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
- -e "s#^MODE = console#MODE = file#"
- -e "s#^LEVEL = Trace#LEVEL = Info#"
- -e "s#^LOG_SQL = true#LOG_SQL = false#"
- -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
- )
-
- sed -i "${sedcmds[@]}" custom/conf/app.example.ini || die
- if use sqlite ; then
- sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.example.ini || die
- fi
-}
-
-src_compile() {
- local gitea_tags=(
- bindata
- $(usev pam)
- $(usex sqlite 'sqlite sqlite_unlock_notify' '')
- )
- local gitea_settings=(
- "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
- "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
- "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
- )
- local makeenv=(
- DRONE_TAG="${PV}"
- LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
- TAGS="${gitea_tags[*]}"
- )
-
- env "${makeenv[@]}" emake backend
-}
-
-src_install() {
- dobin gitea
-
- einstalldocs
-
- newconfd "${FILESDIR}/gitea.confd-r1" gitea
- newinitd "${FILESDIR}/gitea.initd-r3" gitea
- newtmpfiles - gitea.conf <<-EOF
- d /run/gitea 0755 git git
- EOF
- systemd_newunit "${FILESDIR}"/gitea.service-r3 gitea.service
-
- insinto /etc/gitea
- newins custom/conf/app.example.ini app.ini
- if use acct; then
- fowners root:git /etc/gitea/{,app.ini}
- fperms g+w,o-rwx /etc/gitea/{,app.ini}
-
- diropts -m0750 -o git -g git
- keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
- keepdir /var/log/gitea
- fi
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
- tmpfiles_process gitea.conf
-
- ewarn "The default JWT signing algorithm changed in 1.15.0 from HS256 (symmetric) to"
- ewarn "RS256 (asymmetric). Gitea OAuth2 tokens (and potentially client secrets) will"
- ewarn "need to be regenerated unless you change your JWT_SIGNING_ALGORITHM back to HS256."
- ewarn "For other breaking changes, see <https://github.com/go-gitea/gitea/releases/tag/v1.15.0>."
-}