summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Cramer <m1027@posteo.net>2021-02-03 21:16:20 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-02-11 09:23:40 +0200
commit281d76cf0404bf8eddfd7bb706d642657f20f11a (patch)
treec92310ac6eb945190e46d22a43c9a08ec27903b3 /www-apps
parentsys-power/thermald: drop old version (diff)
downloadgentoo-281d76cf0404bf8eddfd7bb706d642657f20f11a.tar.gz
gentoo-281d76cf0404bf8eddfd7bb706d642657f20f11a.tar.bz2
gentoo-281d76cf0404bf8eddfd7bb706d642657f20f11a.zip
www-apps/radicale: bump to 2.1.12-r3
Signed-off-by: Marc Cramer <m1027@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/19259 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/radicale/Manifest1
-rw-r--r--www-apps/radicale/radicale-2.1.12-r3.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/www-apps/radicale/Manifest b/www-apps/radicale/Manifest
index 912cc59fe185..4238d899fb39 100644
--- a/www-apps/radicale/Manifest
+++ b/www-apps/radicale/Manifest
@@ -1 +1,2 @@
DIST Radicale-2.1.11.tar.gz 76490 BLAKE2B 35578b693a32d4a77f8ff1c93cbb8fb63fd8dabf9fde79cd928d4afa6e059fe836840ca6a33621c13e9421a69bfb25cbb59688ba83bed62003ef3b56b54804b1 SHA512 e85f12664d3db6b911dd534eaddd15c498ca4f641cc15523644300aca8b1ef3f6fd4d9645857235502f03a7903111905537b04f9a6fdbde1a60fbb720d377733
+DIST Radicale-2.1.12.tar.gz 109781 BLAKE2B 743eaeffab43f2efcfc798f84d00fee40a09609beeb555e3afe3c9f4c54d8e0ce3a7eba4c1e14d6702775ab7d156b085408ee968b0d53437982cf2ea7cb4653c SHA512 a708fb1269f7ba8c9e351e101f613a8adb18c12b1239b832ed9e0287476f30aa7ded30f9bc259da9c4b5f3aefe90bbf9980d0d08d98dd07b79cd19930b0e204c
diff --git a/www-apps/radicale/radicale-2.1.12-r3.ebuild b/www-apps/radicale/radicale-2.1.12-r3.ebuild
new file mode 100644
index 000000000000..85a6b5f135be
--- /dev/null
+++ b/www-apps/radicale/radicale-2.1.12-r3.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1 eutils systemd
+
+MY_PN="Radicale"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A simple CalDAV calendar server"
+HOMEPAGE="https://radicale.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+bcrypt"
+
+RDEPEND="
+ acct-user/radicale
+ acct-group/radicale
+ sys-apps/util-linux
+ >=dev-python/vobject-0.9.6[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.7.3[${PYTHON_USEDEP}]
+ bcrypt? ( dev-python/passlib[bcrypt,${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+RDIR=/var/lib/${PN}
+
+#pkg_pretend() {
+# if [[ -f ${RDIR}/.props && ${MERGE_TYPE} != buildonly ]]; then
+# eerror "It looks like you have a version 1 database in ${RDIR}."
+# eerror "You must convert this database to version 2 format before upgrading."
+# eerror "You may want to back up the old database before migrating."
+# eerror
+# eerror "If you have kept the Gentoo-default database configuration, this will work:"
+# eerror "1. Stop any running instance of Radicale."
+# eerror "2. Run \`radicale --export-storage ~/radicale-exported\`."
+# eerror "3. Run \`chown -R radicale: ~/radicale-exported\`"
+# eerror "4. Run \`mv \"${RDIR}\" \"${RDIR}.old\"\`."
+# eerror "5. Install Radicale version 2."
+# eerror "6. Run \`mv ~/radicale-exported \"${RDIR}/collections\"\`."
+# eerror
+# eerror "For more details, or if you are have a more complex configuration,"
+# eerror "please see the migration guide: https://radicale.org/1to2/"
+# eerror "If you do a custom migration, please ensure the database is cleaned out of"
+# eerror "${RDIR}, including the hidden .props file."
+# die
+# fi
+#}
+
+#pkg_setup() {
+# enewgroup ${PN}
+# enewuser ${PN} -1 -1 ${RDIR} ${PN}
+#}
+
+python_install_all() {
+ rm README* || die
+
+ # init file
+ newinitd "${FILESDIR}"/radicale-r2.init.d radicale
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ # directories
+ keepdir ${RDIR}
+ fowners ${PN}:${PN} ${RDIR}
+ fperms 0750 ${RDIR}
+
+ # config file
+ insinto /etc/${PN}
+ doins config logging
+
+ # fcgi and wsgi files
+ exeinto /usr/share/${PN}
+ doexe radicale.fcgi radicale.wsgi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ local _erdir="${EROOT}${RDIR}"
+
+ einfo "A sample WSGI script has been put into ${EROOT}/usr/share/${PN}."
+ einfo "You will also find there an example FastCGI script."
+ if [[ $(stat --format="%U:%G:%a" "${_erdir}") != "${PN}:${PN}:750" ]]
+ then
+ ewarn "Unsafe file permissions detected on ${_erdir}. This probably comes"
+ ewarn "from an earlier version of this ebuild."
+ ewarn "To fix run:"
+ ewarn " \`chown -R ${PN}:${PN} ${_erdir}\`"
+ ewarn " \`chmod 0750 ${_erdir}\`"
+ ewarn " \`chmod -R o= ${_erdir}\`"
+ fi
+}