summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-04-05 10:05:57 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2016-04-05 10:11:58 +0200
commit2d97cd320e4a9aa04b8b20809eb82c84a36087c7 (patch)
tree0f420b7ba32e5c7d429d45c9423f41cdafb5ead3 /www-apps
parentdev-java/xml-im-exporter: Clean up old. (diff)
downloadgentoo-2d97cd320e4a9aa04b8b20809eb82c84a36087c7.tar.gz
gentoo-2d97cd320e4a9aa04b8b20809eb82c84a36087c7.tar.bz2
gentoo-2d97cd320e4a9aa04b8b20809eb82c84a36087c7.zip
www-apps/piwigo: initial commit, imported from my overlay
Package-Manager: portage-2.2.28
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/piwigo/Manifest1
-rw-r--r--www-apps/piwigo/metadata.xml18
-rw-r--r--www-apps/piwigo/piwigo-2.8.0.ebuild44
3 files changed, 63 insertions, 0 deletions
diff --git a/www-apps/piwigo/Manifest b/www-apps/piwigo/Manifest
new file mode 100644
index 000000000000..ad3f2b61a36d
--- /dev/null
+++ b/www-apps/piwigo/Manifest
@@ -0,0 +1 @@
+DIST piwigo-2.8.0.zip 7524556 SHA256 1712c81a5b40faaaff956f08b7a8618119d41336869f9e03e78060fa8d21726b SHA512 13529959235d416e6eaf54394d79d6fae58a2ba3cfc79b11765f600d95fd297be5dff98d84bb0436f9cef8d4811c2de9cf3d8f891e0a11e73534e62d0f511f59 WHIRLPOOL e9e5ff7d970a0b6e0e6027a005e865ff020437bd7645acf452cc9168af1fb3707d403204e7e961b6e084510303a428e68a3557c22ece205daaa3028ac66b7f6a
diff --git a/www-apps/piwigo/metadata.xml b/www-apps/piwigo/metadata.xml
new file mode 100644
index 000000000000..586c819bb3f1
--- /dev/null
+++ b/www-apps/piwigo/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <longdescription>
+Piwigo is a photo gallery software for the web that comes with powerful features to publish and manage your collection of pictures.
+
+Started in 2002, the project is now supported by an active community of users and developers.
+It supports numerous galleries of all sizes all over the world, from an individual ten-photos party to the images stock of an agency. This scalability is supported by smart browsing capabilities based on categories, tags and chronological search. Various extensions make Piwigo even more scalable and customizable to suit your own needs and desires.
+
+Piwigo is both web and photo standard compliant. And, icing on the cake, it is free and opensource.
+
+PhpWebGallery became Piwigo on February 15th, 2009.
+ </longdescription>
+</pkgmetadata>
diff --git a/www-apps/piwigo/piwigo-2.8.0.ebuild b/www-apps/piwigo/piwigo-2.8.0.ebuild
new file mode 100644
index 000000000000..4c01a9de70d3
--- /dev/null
+++ b/www-apps/piwigo/piwigo-2.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit webapp
+
+DESCRIPTION="a photo gallery software for the web"
+HOMEPAGE="http://piwigo.org/"
+SRC_URI="http://piwigo.org/download/dlcounter.php?code=${PV} -> ${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+exif +gd imagemagick"
+
+DEPEND=""
+RDEPEND="imagemagick? ( || ( media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick] ) )
+ dev-lang/php[ctype,exif?,gd?,filter,iconv,json,mysqli]
+ >=virtual/mysql-5.0
+ virtual/httpd-php"
+
+REQUIRED_USE="|| ( gd imagemagick )"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Local configuration, and parts that can be updated
+ webapp_serverowned "${MY_HTDOCSDIR}"/_data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/galleries
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/language
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/local
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/plugins
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/template-extension
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/themes
+ webapp_serverowned "${MY_HTDOCSDIR}"/upload
+
+ webapp_src_install
+}