summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-12-23 20:48:58 +0000
committerSam James <sam@gentoo.org>2021-12-25 23:20:03 +0000
commit40a824bb90d1beb52b0e1bf3d4699fedc78d331a (patch)
tree278492999eca612e81d16e3058dc8428840c023c /www-apps
parentnet-analyzer/net-snmp: sync live (diff)
downloadgentoo-40a824bb90d1beb52b0e1bf3d4699fedc78d331a.tar.gz
gentoo-40a824bb90d1beb52b0e1bf3d4699fedc78d331a.tar.bz2
gentoo-40a824bb90d1beb52b0e1bf3d4699fedc78d331a.zip
www-apps/gitea: bump to 1.15.8
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/gitea-1.15.8.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 2895b7fa49ff..0632a8e636fa 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1,3 +1,4 @@
DIST gitea-1.15.5.tar.gz 48677702 BLAKE2B fe46e16041861a477cd91e66e741d35cd43264f8e8c6bfeac5a858fd4aeac9e5e92e308608d6fe74a86a69f21a7c036c8e3409aacb8e5841cbf60ae67009574a SHA512 85522113f389d0a26d4f4b78c05a5454095da5f9f9a030c7392143588f985dc7711368d40194bdc6ea286f3ec15b1f9db428f1401f29aa4c46800d0431696a85
DIST gitea-1.15.6.tar.gz 48675768 BLAKE2B e7952cc981925ec36ab6576456266e3582ea88098a2ad83da161c875b3621be586ddbe63fe0d0ce7c62a0fa1e46663f20ce24ce998f3318645667bd92236ade1 SHA512 9492a3628c5b300a1322893ffdfffa42e904d1b94917c058ad339e0d9ca21155c834b11d55808cbc89e08533de5340fbf858b87487ad307713c4dc12f5e810c8
DIST gitea-1.15.7.tar.gz 48716399 BLAKE2B 4238dad8ce64f205bc18fb35a395b18f6da9f34e5bc0dd9d9bb33d5b8413895fb11f85e8514aca62485ce70f0af5091cb8dfeaccecd146fe5e37ca250227847d SHA512 9488776bb39d15a7390e6734e05c6ee9e092a52055575bc784660d6815125f29498d16a7807dac71ecbabc3f08c407c2da1514c36cce72855a17a9ed7b52fbb9
+DIST gitea-1.15.8.tar.gz 48705540 BLAKE2B fe51af1ac573958e615e600925a3e2a8f1bdfe44333304571198de58fa989e8f8c9ebc4f4714d7700c24f28cba60170a2e34c4416ed28ec201577af92d557a82 SHA512 026f8006fa5f51f6bd753228290f1f3714cd5b23c35e2041b309fc4d0d66be9f84fdaf4c7bd5759248fa26e3d3b9fe628fd5ee4c96e13ff6c99fa7facef4ab06
diff --git a/www-apps/gitea/gitea-1.15.8.ebuild b/www-apps/gitea/gitea-1.15.8.ebuild
new file mode 100644
index 000000000000..2bacf5e333f4
--- /dev/null
+++ b/www-apps/gitea/gitea-1.15.8.ebuild
@@ -0,0 +1,115 @@
+# Copyright 2016-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps go-module tmpfiles systemd
+MY_PV="${PV/_rc/-rc}"
+
+DESCRIPTION="A painless self-hosted Git service"
+HOMEPAGE="https://gitea.io https://github.com/go-gitea/gitea"
+
+if [[ ${PV} != 9999* ]] ; then
+ SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${MY_PV}/gitea-src-${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64"
+ S="${WORKDIR}"
+else
+ EGIT_REPO_URI="https://github.com/go-gitea/gitea"
+ inherit git-r3
+ S="${WORKDIR}/${P}"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="+acct pam sqlite"
+
+DEPEND="
+ acct? (
+ acct-group/git
+ acct-user/git[gitea] )
+ pam? ( sys-libs/pam )"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+DOCS=(
+ custom/conf/app.example.ini CONTRIBUTING.md README.md
+)
+FILECAPS=(
+ -m 711 cap_net_bind_service+ep usr/bin/gitea
+)
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ local sedcmds=(
+ -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
+ -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"
+ -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
+ -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
+ -e "s#^MODE = console#MODE = file#"
+ -e "s#^LEVEL = Trace#LEVEL = Info#"
+ -e "s#^LOG_SQL = true#LOG_SQL = false#"
+ -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
+ )
+
+ sed -i "${sedcmds[@]}" custom/conf/app.example.ini || die
+ if use sqlite ; then
+ sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.example.ini || die
+ fi
+}
+
+src_compile() {
+ local gitea_tags=(
+ bindata
+ $(usev pam)
+ $(usex sqlite 'sqlite sqlite_unlock_notify' '')
+ )
+ local gitea_settings=(
+ "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
+ "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
+ "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
+ )
+ local makeenv=(
+ TAGS="${gitea_tags[*]}"
+ LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
+ )
+ [[ ${PV} != 9999* ]] && makeenv+=("DRONE_TAG=${MY_PV}")
+
+ env "${makeenv[@]}" emake backend
+}
+
+src_install() {
+ dobin gitea
+
+ einstalldocs
+
+ newconfd "${FILESDIR}/gitea.confd-r1" gitea
+ newinitd "${FILESDIR}/gitea.initd-r3" gitea
+ newtmpfiles - gitea.conf <<-EOF
+ d /run/gitea 0755 git git
+ EOF
+ systemd_newunit "${FILESDIR}"/gitea.service-r3 gitea.service
+
+ insinto /etc/gitea
+ newins custom/conf/app.example.ini app.ini
+ if use acct ; then
+ fowners root:git /etc/gitea/{,app.ini}
+ fperms g+w,o-rwx /etc/gitea/{,app.ini}
+
+ diropts -m0750 -o git -g git
+ keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
+ keepdir /var/log/gitea
+ fi
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ tmpfiles_process gitea.conf
+
+ ewarn "The default JWT signing algorithm changed in 1.15.0 from HS256 (symmetric) to"
+ ewarn "RS256 (asymmetric). Gitea OAuth2 tokens (and potentially client secrets) will"
+ ewarn "need to be regenerated unless you change your JWT_SIGNING_ALGORITHM back to HS256."
+ ewarn "For other breaking changes, see <https://github.com/go-gitea/gitea/releases/tag/v1.15.0>."
+}