summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-07-07 14:24:50 +0000
committerJoonas Niilola <juippis@gentoo.org>2022-07-15 11:38:11 +0300
commit40c15a13dfc0e1524d1bb5cab4e7e14c87dbf933 (patch)
tree2724a55297e7df5db0246a68a0bc7dd891046613 /www-apps
parentapp-admin/logstash-bin: drop old (diff)
downloadgentoo-40c15a13dfc0e1524d1bb5cab4e7e14c87dbf933.tar.gz
gentoo-40c15a13dfc0e1524d1bb5cab4e7e14c87dbf933.tar.bz2
gentoo-40c15a13dfc0e1524d1bb5cab4e7e14c87dbf933.zip
www-apps/kibana-bin: bump to 7.17.5
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/kibana-bin/Manifest1
-rw-r--r--www-apps/kibana-bin/kibana-bin-7.17.5.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/www-apps/kibana-bin/Manifest b/www-apps/kibana-bin/Manifest
index 22daa2eb5e21..80fb690fbc9f 100644
--- a/www-apps/kibana-bin/Manifest
+++ b/www-apps/kibana-bin/Manifest
@@ -1 +1,2 @@
DIST kibana-7.17.3-linux-x86_64.tar.gz 263671680 BLAKE2B fe044050ffbc7f83428cb75f27bcab0afbabbe6ee69603067ceeffb13c673973f7413b8ea13ee6534bc1e96898b2955da0f16c41f254e7e8a56ea58d74032903 SHA512 ad675a4f7ae05dba56517435057d7698c967f71c5b4bca722583bc0075dde15b54757fb99cfa7ed64c488a1cc62b00a617cbd645b052829062be1cb30fc023cc
+DIST kibana-7.17.5-linux-x86_64.tar.gz 263788794 BLAKE2B 7399fbfd5ce6c47421ec3f713dd5b12de5b32dd143ee980169c3fb2f4b7d00e6d9cc5a892e40b2efe28bb9148644d8dc921f753a33f941aee3ca90cb1f7eb7f4 SHA512 a1a00934b9ddd318b66129f682d8d678c51ff3c79b1953f72a72bd00d28600ef465e201e5ed434c31764a09cebcf5e76ae21d99915b5955158d573e6adffc2d7
diff --git a/www-apps/kibana-bin/kibana-bin-7.17.5.ebuild b/www-apps/kibana-bin/kibana-bin-7.17.5.ebuild
new file mode 100644
index 000000000000..6082bc86be56
--- /dev/null
+++ b/www-apps/kibana-bin/kibana-bin-7.17.5.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+MY_PN="${PN%-bin}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Analytics and search dashboard for Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/kibana"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}-linux-x86_64.tar.gz"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 Artistic-2 BSD BSD-2 CC-BY-3.0 CC-BY-4.0 Elastic-2.0 icu ISC MIT MPL-2.0 OFL-1.1 openssl public-domain Unlicense WTFPL-2 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ acct-group/kibana
+ acct-user/kibana
+ dev-libs/expat
+ dev-libs/nspr
+ dev-libs/nss
+ >=net-libs/nodejs-16.13.0
+"
+
+# Do not complain about CFLAGS etc since we don't use them
+QA_FLAGS_IGNORED='.*'
+QA_PRESTRIPPED="
+ opt/kibana/x-pack/plugins/reporting/chromium/headless_shell-linux_x64/headless_shell
+ opt/kibana/x-pack/plugins/reporting/chromium/headless_shell-linux_x64/swiftshader/libEGL.so
+ opt/kibana/x-pack/plugins/reporting/chromium/headless_shell-linux_x64/swiftshader/libGLESv2.so
+ opt/kibana/node_modules/re2/build/Release/re2.node
+"
+
+S="${WORKDIR}/${MY_P}-linux-x86_64"
+
+src_prepare() {
+ default
+
+ # remove unused directory
+ rm -r data || die
+
+ # remove bundled nodejs
+ rm -r node || die
+ sed -i 's@\(^NODE="\).*@\1/usr/bin/node"@g' \
+ bin/kibana || die
+
+ # move plugins to /var/lib/kibana
+ rm -r plugins || die
+
+ # handle node.js version with RDEPEND
+ sed -i /node_version_validator/d \
+ src/setup_node_env/no_transpilation_dist.js || die
+}
+
+src_install() {
+ insinto /etc/${MY_PN}
+ doins -r config/.
+ rm -r config || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${MY_PN}.logrotate ${MY_PN}
+
+ newconfd "${FILESDIR}"/${MY_PN}.confd ${MY_PN}
+ newinitd "${FILESDIR}"/${MY_PN}.initd-r1 ${MY_PN}
+ systemd_dounit "${FILESDIR}"/${MY_PN}.service
+
+ insinto /opt/${MY_PN}
+ doins -r .
+
+ fperms -R +x /opt/${MY_PN}/bin
+
+ diropts -m 0750 -o ${MY_PN} -g ${MY_PN}
+ keepdir /var/lib/${MY_PN}/plugins
+ keepdir /var/log/${MY_PN}
+
+ dosym ../../var/lib/kibana/plugins /opt/kibana/plugins
+}
+
+pkg_postinst() {
+ elog "This version of Kibana is compatible with Elasticsearch $(ver_cut 1-2) and"
+ elog "Node.js 16. Some plugins may fail with other versions of Node.js (Bug #656008)."
+ elog
+ elog "To set a customized Elasticsearch instance:"
+ elog " OpenRC: set ES_INSTANCE in /etc/conf.d/${MY_PN}"
+ elog " systemd: set elasticsearch.url in /etc/${MY_PN}/kibana.yml"
+ elog
+ elog "Elasticsearch can run local or remote."
+}