summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-07-22 01:00:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-07-22 02:01:55 +0200
commit56c273948eaa8df3671c4473fc567461d825fb5f (patch)
treed28a7ff7662c6780b43dced7382922cb4404706d /www-apps
parentmedia-plugins/mythplugins: 0.28.1 version bump (diff)
downloadgentoo-56c273948eaa8df3671c4473fc567461d825fb5f.tar.gz
gentoo-56c273948eaa8df3671c4473fc567461d825fb5f.tar.bz2
gentoo-56c273948eaa8df3671c4473fc567461d825fb5f.zip
www-apps/mythweb: 0.28.1 version bump
Drop BACKPORTS and related epatch hack Sort RDEPEND Reported-by: Andreas Steinmetz <ast@domdv.de> Gentoo-bug: 609000 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mythweb/Manifest1
-rw-r--r--www-apps/mythweb/mythweb-0.28.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/www-apps/mythweb/Manifest b/www-apps/mythweb/Manifest
index 4d9330271055..4d40219da90c 100644
--- a/www-apps/mythweb/Manifest
+++ b/www-apps/mythweb/Manifest
@@ -1,2 +1,3 @@
DIST mythweb-0.27.5.tar.gz 1686597 SHA256 5dc3fd9e60f59dea4264fb064b40d73f2534c99d0399da6223a42d2f563e9d13 SHA512 effa5f9cab6b40423a819f0307aecd1faa397da7d859503162b6229e5da2d4cd0d95d793326768335518cd397fa58ba71ad98c14247feda10e7930f7e023f1af WHIRLPOOL 8721398611db0572f475f5642c397a5d3f0fbe352f0f3ea23dc21cc0ea94e0e6876a713cf0f99331c6fc1f585a62525dc64510737a85667c0e2a14b6f1c6bb10
+DIST mythweb-0.28.1.tar.gz 1705490 SHA256 bbd82992230d3571eba55a26a91cc3f2dcddfa631d1822ce58e1bf99f2537244 SHA512 0ce9e2c7138d35ef59859a8a8980b01d90d9b616e55653fb28dd5a473199446508e525171687383ce83051b434f5e7618f509a9e75cd84296446ee450733e963 WHIRLPOOL b36f3226a9984d4c7ea383e1344ddb630b06972fd3170cdcbd0521f9bad3b7acf24f94c7e7099812f8fe5eeea17ab115a36a38ea0b07617998011c7f7c545e00
DIST mythweb-0.28.tar.gz 1705475 SHA256 92253f4eb11331da64cff50926fbced3477d244c201675c177be4f5838cd4ed7 SHA512 58887f6d3823f137b252cf546ada134ebafa3e0142240ba9474868300add7ab00ee39f8cd0d56e91be0571837bea7110e8b3cca38a8a1a47b055d76dccf2a3fe WHIRLPOOL f130933ea6a5c20fa67668eb830cb094be9449ce4f21ff45041055cd91fda11be3752482ce04d066e90cfba9af97c741d4c67368900e4887bd7e726a22fe4540
diff --git a/www-apps/mythweb/mythweb-0.28.1.ebuild b/www-apps/mythweb/mythweb-0.28.1.ebuild
new file mode 100644
index 000000000000..5243d2658ba7
--- /dev/null
+++ b/www-apps/mythweb/mythweb-0.28.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils webapp
+
+# Release version
+MY_PV="${PV%_p*}"
+MY_P="mythweb-${MY_PV}"
+
+DESCRIPTION="PHP scripts intended to manage MythTV from a web browser"
+HOMEPAGE="https://www.mythtv.org"
+SRC_URI="https://github.com/MythTV/mythweb/archive/v${MY_PV}.tar.gz -> mythweb-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/php:*[json,mysql,session,posix]
+ dev-perl/DBD-mysql
+ dev-perl/DBI
+ dev-perl/HTTP-Date
+ dev-perl/Net-UPnP
+ virtual/httpd-php:*
+"
+DEPEND="${RDEPEND}"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # Install docs
+ cd "${S}"
+ dodoc README INSTALL
+
+ # Install htdocs files
+ insinto "${MY_HTDOCSDIR}"
+ doins mythweb.php
+ doins -r classes
+ doins -r configuration
+ doins -r data
+ doins -r includes
+ doins -r js
+ doins -r modules
+ doins -r skins
+ doins -r tests
+ exeinto "${MY_HTDOCSDIR}"
+ doexe mythweb.pl
+
+ # Install our server config files
+ webapp_server_configfile apache mythweb.conf.apache mythweb.conf
+ webapp_server_configfile lighttpd mythweb.conf.lighttpd mythweb.conf
+ webapp_server_configfile nginx "${FILESDIR}"/mythweb.conf.nginx \
+ mythweb.include
+
+ # Data needs to be writable and modifiable by the web server
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+
+ # Message to display after install
+ webapp_postinst_txt en "${FILESDIR}"/0.25-postinstall-en.txt
+
+ # Script to set the correct defaults on install
+ webapp_hook_script "${FILESDIR}"/reconfig
+
+ webapp_src_install
+}