summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-03-12 09:15:11 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-03-12 23:59:04 +0100
commit593aca98e2ea268c973390673281f1c853c97e53 (patch)
treef9a8dea0fef29f54abcd4c1cbdf2236e7bd69181 /www-apps
parentnet-analyzer/prometheus-snmp_exporter: fix typo in initd (diff)
downloadgentoo-593aca98e2ea268c973390673281f1c853c97e53.tar.gz
gentoo-593aca98e2ea268c973390673281f1c853c97e53.tar.bz2
gentoo-593aca98e2ea268c973390673281f1c853c97e53.zip
www-apps/kibana-bin: bump to 5.6.8/6.2.2.
Closes: https://bugs.gentoo.org/647830 Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7430
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/kibana-bin/Manifest2
-rw-r--r--www-apps/kibana-bin/kibana-bin-5.6.8.ebuild62
-rw-r--r--www-apps/kibana-bin/kibana-bin-6.2.2.ebuild62
3 files changed, 126 insertions, 0 deletions
diff --git a/www-apps/kibana-bin/Manifest b/www-apps/kibana-bin/Manifest
index 0885f5675fcc..3e3900c071eb 100644
--- a/www-apps/kibana-bin/Manifest
+++ b/www-apps/kibana-bin/Manifest
@@ -1,3 +1,5 @@
DIST kibana-5.6.6-linux-x86_64.tar.gz 52322049 BLAKE2B 7c1b36b2231fe6b48977459475aa40badd255391b57dfe32294096514a08335267b7276c17744010dd66ad1497ba80358cc45e0862811c28c0229e0eacfa82e8 SHA512 75803ff81cb73a48e2071f6249ec90b863246ce04b668919f811e43b27614ccb571f220e4667fc0b505ed45f531d8487aed615752752889d498a2f77e06b2f28
+DIST kibana-5.6.8-linux-x86_64.tar.gz 51974963 BLAKE2B d90b3e56e9d19c3846b7fae294d8bf27b89ffe462d8554e465bb5235741915ee65c1c6e58b94453ffbb80eaac17ede190300d614b25cf033d84231d87a46c6e9 SHA512 a819fc1166994364e94a47fa6f55f06e0672a6c5fc9bc8d594ad5ba48092033faafcc8fc70aae3c4b04300f96a9221683711bc2e2b5d343fd85d7dc22b173513
DIST kibana-6.0.1-linux-x86_64.tar.gz 62720465 BLAKE2B 81c3cb130067483cc6138c5274555c01102e365d873bf753a534cbcd96487516af41fbb91878cea4f80ffc02c5d18c82d322b0530cf1d3a55adffeefe60d9574 SHA512 3761f8abff5d949631f365c228af2f205597e1f05137d0140917b35128d2dcb79e32db355873864c1f01bce06121af71f1bfcb1679ae25903e1121bc76f68ecc
DIST kibana-6.1.2-linux-x86_64.tar.gz 65093343 BLAKE2B 08254af4fcc261a49f5f6e4e1c734acca799708394d95d3203d6355d1e9dc3fa6bfa3eb85b1cb40e5d52a4558b6ea202d54e87ff6274823767f8332a7b01b9c7 SHA512 eefe3ae73e08c0cd14c5c7d7f962dc78cdfff1096895a1ab539f172b84dfa0d8c197d99573ac7dea6c60adb89b5e3fd5be10dddd749c060c540b30c34426c8a1
+DIST kibana-6.2.2-linux-x86_64.tar.gz 83415765 BLAKE2B 86f7511c82b6954a8769673b856eb46f2b633490535a013d4e30138e8abee470776493de43284f2e68b2cac6b74ba2b76245fd35803b8b5834f79ea5f488dd6b SHA512 8d26eb8293028aa0c35942a7b5025401f9b717d5c548d6cdbcf2761c0d8cc1189fdbf12c6f39468d4c809a3975f5f3c817e0f02424b296ce36183e118b0c72c6
diff --git a/www-apps/kibana-bin/kibana-bin-5.6.8.ebuild b/www-apps/kibana-bin/kibana-bin-5.6.8.ebuild
new file mode 100644
index 000000000000..8471d3d0b369
--- /dev/null
+++ b/www-apps/kibana-bin/kibana-bin-5.6.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user eapi7-ver
+
+MY_PN="${PN%-bin}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Analytics and search dashboard for Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/kibana"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}-linux-x86_64.tar.gz"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 Artistic-2 BSD BSD-2 CC-BY-3.0 CC-BY-4.0 icu ISC MIT MPL-2.0 OFL-1.1 openssl public-domain Unlicense WTFPL-2 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="net-libs/nodejs"
+
+S="${WORKDIR}/${MY_P}-linux-x86_64"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /opt/${MY_PN} ${MY_PN}
+}
+
+src_prepare() {
+ default
+
+ # remove bundled nodejs
+ rm -rv node || die
+}
+
+src_install() {
+ keepdir /var/log/${MY_PN}
+
+ insinto /etc/${MY_PN}
+ doins -r config/.
+ rm -rv config || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${MY_PN}.logrotate ${MY_PN}
+
+ newconfd "${FILESDIR}"/${MY_PN}.confd ${MY_PN}
+ newinitd "${FILESDIR}"/${MY_PN}.initd ${MY_PN}
+
+ insinto /opt/${MY_PN}
+ doins -r .
+
+ chmod +x "${ED%/}"/opt/${MY_PN}/bin/* || die
+}
+
+pkg_postinst() {
+ elog "This version of Kibana is compatible with Elasticsearch $(ver_cut 1-2)"
+ elog
+ elog "Be sure to point ES_INSTANCE to your Elasticsearch instance"
+ elog "in /etc/conf.d/${MY_PN}."
+ elog
+ elog "Elasticsearch can run local or remote."
+}
diff --git a/www-apps/kibana-bin/kibana-bin-6.2.2.ebuild b/www-apps/kibana-bin/kibana-bin-6.2.2.ebuild
new file mode 100644
index 000000000000..8471d3d0b369
--- /dev/null
+++ b/www-apps/kibana-bin/kibana-bin-6.2.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user eapi7-ver
+
+MY_PN="${PN%-bin}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Analytics and search dashboard for Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/kibana"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}-linux-x86_64.tar.gz"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 Artistic-2 BSD BSD-2 CC-BY-3.0 CC-BY-4.0 icu ISC MIT MPL-2.0 OFL-1.1 openssl public-domain Unlicense WTFPL-2 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="net-libs/nodejs"
+
+S="${WORKDIR}/${MY_P}-linux-x86_64"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /opt/${MY_PN} ${MY_PN}
+}
+
+src_prepare() {
+ default
+
+ # remove bundled nodejs
+ rm -rv node || die
+}
+
+src_install() {
+ keepdir /var/log/${MY_PN}
+
+ insinto /etc/${MY_PN}
+ doins -r config/.
+ rm -rv config || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${MY_PN}.logrotate ${MY_PN}
+
+ newconfd "${FILESDIR}"/${MY_PN}.confd ${MY_PN}
+ newinitd "${FILESDIR}"/${MY_PN}.initd ${MY_PN}
+
+ insinto /opt/${MY_PN}
+ doins -r .
+
+ chmod +x "${ED%/}"/opt/${MY_PN}/bin/* || die
+}
+
+pkg_postinst() {
+ elog "This version of Kibana is compatible with Elasticsearch $(ver_cut 1-2)"
+ elog
+ elog "Be sure to point ES_INSTANCE to your Elasticsearch instance"
+ elog "in /etc/conf.d/${MY_PN}."
+ elog
+ elog "Elasticsearch can run local or remote."
+}