summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-03-31 17:44:04 +0200
committerSebastian Pipping <sping@gentoo.org>2018-03-31 17:44:31 +0200
commit59c6a0d96e252098bfca93a1d698f0e3f34c4de2 (patch)
treebe524b83f5a27d4f1b90ea60665713b6d0239001 /www-apps
parentx11-libs/neXtaw-0.15.1-r2: alpha stable (diff)
downloadgentoo-59c6a0d96e252098bfca93a1d698f0e3f34c4de2.tar.gz
gentoo-59c6a0d96e252098bfca93a1d698f0e3f34c4de2.tar.bz2
gentoo-59c6a0d96e252098bfca93a1d698f0e3f34c4de2.zip
www-apps/nikola: 7.8.14
Package-Manager: Portage-2.3.26, Repoman-2.3.7
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/nikola/Manifest1
-rw-r--r--www-apps/nikola/nikola-7.8.14.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/www-apps/nikola/Manifest b/www-apps/nikola/Manifest
index 8c2778370587..9912124b137b 100644
--- a/www-apps/nikola/Manifest
+++ b/www-apps/nikola/Manifest
@@ -1,4 +1,5 @@
DIST Nikola-7.8.11.tar.gz 4104413 BLAKE2B 22da280a7f7416ad88680a573aa103dc38a8e7ed5476f0ce35c7d179131aaf6bc41edfd1f591967bcc6e747a279b5e0b9e2e0c6e959d45e93328dcb14d95658e SHA512 9273f56a6cbb08db9a4b5c562cd4e80e8bbb777c299406bc3d816a63d8b21d1b2a3e4aa3fa376858459a650ded54b0526ac54b4f186757cd2dec7ccf656e145e
DIST Nikola-7.8.12.tar.gz 4106202 BLAKE2B 95ef2d074145b40be90f8daf7de92dc4091e24b0db8e5f949daeff6e6bd03d2437198a4a1e33728c204c907cd94fc1ad6f6d0a1945119eaaa738cbc172dfaadb SHA512 8be18b4a9b61da7de1c0b3d75cd0d2bebc9c45191b30b8f918b2a6c8af333d1a6545f7336a033c3aef25a6920d905ff10f7d8238aba586b1dcbc6b92e03e376d
DIST Nikola-7.8.13.tar.gz 4131250 BLAKE2B 6fdb12e59d7e977bc1ab9e2dd458de4a8a61104e1237926d5362ce1420fd3533617d268a4b496a4248932255459a2e3fa43488be62fedc86ab7c62a3c3cefeb3 SHA512 95118f9e2a7d884ab3e7f517749de6cde22439579cf6e05245111ab972f2def0c7ab824978cf750d2bedf788b2a994ec743e9574b70d17424e04c570ef796bef
+DIST Nikola-7.8.14.tar.gz 4130538 BLAKE2B dc8cd3a484bf203291ff8ca2b25233814e68bf916081f692a73c87af953cd57ea732dfdedfb8508187fb27566204f9442eb87847c98018fa0e5ef4ab4eb5295f SHA512 1a930e0cebbc9d54437ce438622eb2a6ad01988aaa9706f58cc0add17e483c3510d3a8ba120b8aa3b475c0e030cca471173f2520fd36e9528144cdee40fb1a9c
DIST Nikola-7.8.8.tar.gz 3870991 BLAKE2B df6b3784acb339faccbcf1d269a2a9e315861be25e3880fab1c18754df1121b7081e9d1ad08d5a08d6b6913eacfdf184d9a19e5e1218a038913a6c7d2f78dcde SHA512 6222cfaea048a547d8a224828815b8334d2f39abf872d63b9a970ca017cee37e5efeaccc5327b8c21bea9fdfe7beafae7ac9af9f57d459a10fa991879bf74687
diff --git a/www-apps/nikola/nikola-7.8.14.ebuild b/www-apps/nikola/nikola-7.8.14.ebuild
new file mode 100644
index 000000000000..c0a87b751c1e
--- /dev/null
+++ b/www-apps/nikola/nikola-7.8.14.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_PN="Nikola"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A static website and blog generator"
+HOMEPAGE="https://getnikola.com/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT Apache-2.0 CC0-1.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="assets charts ghpages hyphenation ipython jinja watchdog webmedia websocket"
+RESTRICT="test" # needs coveralls
+
+DEPEND=">=dev-python/docutils-0.12[${PYTHON_USEDEP}]" # needs rst2man to build manpage
+RDEPEND="${DEPEND}
+ >=dev-python/blinker-1.3[${PYTHON_USEDEP}]
+ >=dev-python/doit-0.29.0[${PYTHON_USEDEP}]
+ >=dev-python/logbook-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.3.5[${PYTHON_USEDEP}]
+ >=dev-python/mako-1.0[${PYTHON_USEDEP}]
+ >=dev-python/markdown-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/natsort-3.5.2[${PYTHON_USEDEP}]
+ >=dev-python/piexif-1.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
+ >=dev-python/PyRSS2Gen-1.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.4[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-20.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/unidecode-0.04.16[${PYTHON_USEDEP}]
+ >=dev-python/yapsy-1.11.223[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ assets? ( >=dev-python/webassets-0.10.1[${PYTHON_USEDEP}] )
+ charts? ( >=dev-python/pygal-2.0.1[${PYTHON_USEDEP}] )
+ ghpages? ( >=dev-python/ghp-import-0.4.1[${PYTHON_USEDEP}] )
+ hyphenation? ( >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}] )
+ ipython? ( >=dev-python/ipython-2.0.0[notebook,${PYTHON_USEDEP}] )
+ jinja? ( >=dev-python/jinja-2.7.2[${PYTHON_USEDEP}] )
+ watchdog? ( ~dev-python/watchdog-0.8.3[${PYTHON_USEDEP}] )
+ webmedia? ( >=dev-python/micawber-0.3.0[${PYTHON_USEDEP}] )
+ websocket? ( ~dev-python/ws4py-0.3.4[${PYTHON_USEDEP}] )"
+# typography? ( >=dev-python/typogrify-2.0.4[${PYTHON_USEDEP}] ) # needs smartypants
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils-r1_src_install
+
+ # hackish way to remove docs that ended up in the wrong place
+ rm -rv "${D}/usr/share/doc/${PN}" || die
+
+ dodoc AUTHORS.txt CHANGES.txt README.rst docs/*.txt
+ gunzip "docs/man/${PN}.1.gz" || die
+ doman "docs/man/${PN}.1"
+}