summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-04-11 16:11:47 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-04-11 16:12:50 +0300
commit5ac1b19bd9b11e0b712a856f0e45bb2eda94ea6f (patch)
tree9fa0f1d259922db85e86d3cff06e83300c02a289 /www-apps
parentwww-apps/hugo: add 0.96.0, enable tests (diff)
downloadgentoo-5ac1b19bd9b11e0b712a856f0e45bb2eda94ea6f.tar.gz
gentoo-5ac1b19bd9b11e0b712a856f0e45bb2eda94ea6f.tar.bz2
gentoo-5ac1b19bd9b11e0b712a856f0e45bb2eda94ea6f.zip
www-apps/hugo: add "test-full" USE flag for optional heavy test deps
- the optfeature method was suggested by me, but find this better in the end since this can be automated. Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/hugo/hugo-0.96.0.ebuild12
-rw-r--r--www-apps/hugo/metadata.xml1
2 files changed, 4 insertions, 9 deletions
diff --git a/www-apps/hugo/hugo-0.96.0.ebuild b/www-apps/hugo/hugo-0.96.0.ebuild
index 03c50c742f9a..50ae5b3634cf 100644
--- a/www-apps/hugo/hugo-0.96.0.ebuild
+++ b/www-apps/hugo/hugo-0.96.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit go-module bash-completion-r1 optfeature
+inherit go-module bash-completion-r1
DESCRIPTION="Fast static HTML and CSS website generator"
HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
@@ -18,13 +18,14 @@ SRC_URI="
LICENSE="Apache-2.0 BSD BSD-2 MIT Unlicense"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc +sass test"
+IUSE="doc +sass test test-full"
BDEPEND="
>=dev-lang/go-1.18
test? (
dev-python/docutils
dev-ruby/asciidoctor
+ test-full? ( app-text/pandoc )
)
"
RDEPEND="
@@ -40,13 +41,6 @@ PATCHES=(
"${FILESDIR}/${PN}-0.96.0-skip-some-tests.patch"
)
-pkg_setup() {
- if use test; then
- optfeature_header "Install additional packages for optional tests:"
- optfeature "pandoc converter tests" "app-text/pandoc"
- fi
-}
-
src_configure() {
export CGO_ENABLED=1
export CGO_CFLAGS="${CFLAGS}"
diff --git a/www-apps/hugo/metadata.xml b/www-apps/hugo/metadata.xml
index d3bce6b51931..c1a8bfb7f195 100644
--- a/www-apps/hugo/metadata.xml
+++ b/www-apps/hugo/metadata.xml
@@ -11,6 +11,7 @@
</maintainer>
<use>
<flag name="sass">Enable SASS/SCSS support</flag>
+ <flag name="test-full">Pull optional heavier test-dependency packages</flag>
</use>
<upstream>
<remote-id type="github">gohugoio/hugo</remote-id>