summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTill Schäfer <till2.schaefer@uni-dortmund.de>2022-01-17 10:38:50 +0100
committerIonen Wolkens <ionen@gentoo.org>2022-02-06 14:33:46 -0500
commit5b546f2ea92035bfc43b61aa42d9f463b29ac865 (patch)
tree9484b4393e4f306db0c7d2769a34a77e2aba9ff3 /www-apps
parentdev-util/conan: cleanup unused python compat (diff)
downloadgentoo-5b546f2ea92035bfc43b61aa42d9f463b29ac865.tar.gz
gentoo-5b546f2ea92035bfc43b61aa42d9f463b29ac865.tar.bz2
gentoo-5b546f2ea92035bfc43b61aa42d9f463b29ac865.zip
www-apps/davical: version bump to 1.1.10
+ update to EAPI 8 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Till Schäfer <till2.schaefer@uni-dortmund.de> Closes: https://github.com/gentoo/gentoo/pull/23836 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/davical/Manifest1
-rw-r--r--www-apps/davical/davical-1.1.10.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/www-apps/davical/Manifest b/www-apps/davical/Manifest
index 7bb5a282f73d..fd9d7aa033e9 100644
--- a/www-apps/davical/Manifest
+++ b/www-apps/davical/Manifest
@@ -1 +1,2 @@
+DIST davical-1.1.10.tar.xz 1367356 BLAKE2B e93be0e4ce2768e13635247d006792a40865bcbe95698fa5bc7a7a20503acae0c1adbc1a2573f84043e4606342a468c5a606dab4c025edc9e68dae9a5d9aa10e SHA512 d307fc600c50bd294497ff9ab8fdc7a2d966e5360acb8babe3549a754204bbc73a44b89a1c4347f9527cf4f99e0091afc9bf92bbdd46e6843b5830489ad911aa
DIST davical-1.1.9.3.tar.xz 1359608 BLAKE2B d936fa5809413eac92e996262074972a04e1ac2d50d06c921e0f70468dde2b67175c6463d73ead09d5b2bce4ab1c2a02ccb45b64ee43066f6a9609c5ccdd01ee SHA512 cad28a991900d4cd9b1f86aeda7861482eef8707a02a371af53bd9cd17f9b5417ae81ccf1129d01fa5786f7bc9edc7478eb5a7274147039ce3ef603874c093a6
diff --git a/www-apps/davical/davical-1.1.10.ebuild b/www-apps/davical/davical-1.1.10.ebuild
new file mode 100644
index 000000000000..55191dde88dd
--- /dev/null
+++ b/www-apps/davical/davical-1.1.10.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature webapp
+
+DESCRIPTION="A CalDAV and CardDAV Server"
+HOMEPAGE="https://www.davical.org/"
+SRC_URI="https://www.davical.org/downloads/${PN}_${PV}.orig.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-2 GPL-2+ GPL-3+ LGPL-2.1+ LGPL-3+"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-devel/gettext"
+
+RDEPEND="app-admin/pwgen
+ dev-lang/php[calendar,curl,iconv,imap,nls,pdo,postgres,xml]
+ dev-perl/DBD-Pg
+ dev-perl/DBI
+ dev-perl/YAML
+ >=dev-php/awl-0.62
+ virtual/httpd-php"
+
+need_httpd
+
+S="${WORKDIR}"
+
+src_compile() {
+ emake built-locale
+}
+
+src_install() {
+ webapp_src_preinst
+
+ einstalldocs
+
+ einfo "Installing web files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r htdocs/. htdocs/.htaccess
+
+ einfo "Installing main files and i18n"
+ insinto "${MY_HOSTROOTDIR}/${PN}"
+ doins -r inc locale
+ rm "${ED}/${MY_HOSTROOTDIR}/${PN}/inc/always.php.in" || die
+
+ einfo "Installing sql files"
+ insinto "${MY_SQLSCRIPTSDIR}"
+ doins -r dba/.
+
+ insinto /etc/${PN}
+ doins -r config/. "${FILESDIR}/vhost-example"
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ webapp_postupgrade_txt en "${FILESDIR}/postupgrade-en.txt"
+ webapp_src_install
+
+ fperms +x "${MY_SQLSCRIPTSDIR}/create-database.sh"
+ fperms +x "${MY_SQLSCRIPTSDIR}/update-davical-database"
+}
+
+pkg_postinst() {
+ elog "If you are upgrading from a previous version of davical, don't forget to"
+ elog "upgrade the database structure with"
+ elog " cd /usr/share/webapps/davical/${PVR}/sqlscripts/"
+ elog " ./update-davical-database -dbuser xxxxxxx -appuser xxxxxx"
+
+ webapp_pkg_postinst
+
+ elog ""
+ optfeature "LDAP authentication" dev-lang/php[ldap]
+}