summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-04-11 15:45:30 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-04-11 15:45:30 -0500
commit6404d330f0eafac7435785e36aa4af8144353aee (patch)
tree95627023f1af37695cda7b2f7c461feb42a4a7b1 /www-apps
parentx11-libs/libxcb, x11-proto/xcb-proto: add support for python 3.5 (diff)
downloadgentoo-6404d330f0eafac7435785e36aa4af8144353aee.tar.gz
gentoo-6404d330f0eafac7435785e36aa4af8144353aee.tar.bz2
gentoo-6404d330f0eafac7435785e36aa4af8144353aee.zip
www-apps/icingaweb2-module-graphite: first packaging
Package-Manager: portage-2.2.26
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-9999.ebuild29
-rw-r--r--www-apps/icingaweb2-module-graphite/metadata.xml10
2 files changed, 39 insertions, 0 deletions
diff --git a/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-9999.ebuild b/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-9999.ebuild
new file mode 100644
index 000000000000..f30e54227f4d
--- /dev/null
+++ b/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Icinga Web 2 plugin for pnp4nagios"
+HOMEPAGE="http://www.icinga.org/"
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-graphite.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ MY_PN="icingaweb2-module-pnp"
+ SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ >=www-apps/icingaweb2-2.0.0"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/pnp/${PN}"
+ doins -r "${S}"/*
+}
diff --git a/www-apps/icingaweb2-module-graphite/metadata.xml b/www-apps/icingaweb2-module-graphite/metadata.xml
new file mode 100644
index 000000000000..1301fb3341bc
--- /dev/null
+++ b/www-apps/icingaweb2-module-graphite/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>