summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2020-04-17 11:14:17 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-05-13 10:59:43 +0300
commit810b5622c5184146421cac2614dc356677e93b2d (patch)
tree74d30ad0a3c8a0033e20ec79a03e740e966b194c /www-apps
parentapp-editors/sandy: Add IUSE=savedconfig (diff)
downloadgentoo-810b5622c5184146421cac2614dc356677e93b2d.tar.gz
gentoo-810b5622c5184146421cac2614dc356677e93b2d.tar.bz2
gentoo-810b5622c5184146421cac2614dc356677e93b2d.zip
www-apps/gitea: build now requires npm
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitea/gitea-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/www-apps/gitea/gitea-9999.ebuild b/www-apps/gitea/gitea-9999.ebuild
index 9e8bcf9c6054..ce44b1f5ef76 100644
--- a/www-apps/gitea/gitea-9999.ebuild
+++ b/www-apps/gitea/gitea-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,7 @@ DESCRIPTION="A painless self-hosted Git service"
HOMEPAGE="https://gitea.io"
if [[ ${PV} != 9999* ]] ; then
- SRC_URI="https://github.com/go-gitea/gitea/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64"
else
EGIT_REPO_URI="https://github.com/go-gitea/gitea"
@@ -30,7 +30,8 @@ LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
SLOT="0"
IUSE="+acct pam sqlite"
-BDEPEND="dev-lang/go"
+BDEPEND="dev-lang/go
+ >=net-libs/nodejs-10[npm]"
DEPEND="pam? ( sys-libs/pam )"
RDEPEND="${DEPEND}
acct? (
@@ -42,6 +43,8 @@ RDEPEND="${DEPEND}
DOCS=( custom/conf/app.ini.sample CONTRIBUTING.md README.md )
S="${WORKDIR}/${P}/src/${EGO_PN}"
+PATCHES=( "${FILESDIR}/gitea-logflags.patch" )
+
gitea_make() {
local gitea_tags=(
bindata
@@ -60,7 +63,7 @@ gitea_make() {
)
[[ ${PV} != 9999* ]] && makeenv+=("DRONE_TAG=${PV}")
- env "${makeenv[@]}" emake "$@"
+ env "${makeenv[@]}" emake -j1 "$@"
}
src_prepare() {
@@ -85,7 +88,8 @@ src_prepare() {
sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.ini.sample || die
fi
- gitea_make generate
+ # Remove already build assets (like frontend part)
+ gitea_make clean-all
}
src_compile() {