summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2016-11-07 00:06:24 +0100
committerRafael Martins <rafaelmartins@gentoo.org>2016-11-07 00:06:24 +0100
commit930998b2fdfce771b37de4e86ba799f09e9eaceb (patch)
tree95ded01d691eac6ce489777f2677eaa83a310806 /www-apps
parentapp-portage/g-octave: apply patches using PATCHES variable (diff)
downloadgentoo-930998b2fdfce771b37de4e86ba799f09e9eaceb.tar.gz
gentoo-930998b2fdfce771b37de4e86ba799f09e9eaceb.tar.bz2
gentoo-930998b2fdfce771b37de4e86ba799f09e9eaceb.zip
www-apps/blohg: update libgit2 dependency
Package-Manager: portage-2.2.28
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/blohg/blohg-0.13-r2.ebuild (renamed from www-apps/blohg/blohg-0.13-r1.ebuild)6
-rw-r--r--www-apps/blohg/files/use-recent-libgit2.patch17
2 files changed, 21 insertions, 2 deletions
diff --git a/www-apps/blohg/blohg-0.13-r1.ebuild b/www-apps/blohg/blohg-0.13-r2.ebuild
index 40f58f708525..f4245e6dafd2 100644
--- a/www-apps/blohg/blohg-0.13-r1.ebuild
+++ b/www-apps/blohg/blohg-0.13-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
@@ -42,7 +42,7 @@ RDEPEND="
dev-python/pyyaml
dev-python/setuptools
dev-python/pygments
- git? ( =dev-python/pygit2-0.20* )
+ git? ( >=dev-python/pygit2-0.21.3 )
mercurial? ( >=dev-vcs/mercurial-1.6 )"
DEPEND="${RDEPEND}
@@ -52,6 +52,8 @@ DEPEND="${RDEPEND}
python_prepare_all() {
if ! use git; then
rm -rf blohg/vcs_backends/git || die 'rm failed'
+ else
+ local PATCHES=( "${FILESDIR}/use-recent-libgit2.patch" )
fi
if ! use mercurial; then
diff --git a/www-apps/blohg/files/use-recent-libgit2.patch b/www-apps/blohg/files/use-recent-libgit2.patch
new file mode 100644
index 000000000000..decd01b78fb5
--- /dev/null
+++ b/www-apps/blohg/files/use-recent-libgit2.patch
@@ -0,0 +1,17 @@
+diff --git a/blohg/vcs_backends/git/filectx.py b/blohg/vcs_backends/git/filectx.py
+index 84f7aa3..5e20762 100644
+--- a/blohg/vcs_backends/git/filectx.py
++++ b/blohg/vcs_backends/git/filectx.py
+@@ -73,7 +73,11 @@ def _last_changeset(self):
+ GIT_SORT_TIME):
+ diff = self._repo.diff(head, commit)
+ for patch in diff:
+- if patch.new_file_path == self._path:
++ try:
++ new_file_path = patch.delta.new_file.path
++ except AttributeError:
++ new_file_path = patch.new_file_path
++ if new_file_path == self._path:
+ return head
+ head = commit
+