summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-02-13 13:01:40 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-02-13 13:01:40 +0000
commitab44f9d8955887d4504d7bc8d437929135368ed8 (patch)
tree467d012182bbec2832a206ceab1cf0441927011d /www-apps
parentapp-misc/radeontop: update live ebuild (diff)
downloadgentoo-ab44f9d8955887d4504d7bc8d437929135368ed8.tar.gz
gentoo-ab44f9d8955887d4504d7bc8d437929135368ed8.tar.bz2
gentoo-ab44f9d8955887d4504d7bc8d437929135368ed8.zip
www-apps/tt-rss: PHP 8 is not supported yet
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/tt-rss/tt-rss-20200922.ebuild23
-rw-r--r--www-apps/tt-rss/tt-rss-99999999.ebuild23
2 files changed, 36 insertions, 10 deletions
diff --git a/www-apps/tt-rss/tt-rss-20200922.ebuild b/www-apps/tt-rss/tt-rss-20200922.ebuild
index 1c58510d1d96..09db5c1f1489 100644
--- a/www-apps/tt-rss/tt-rss-20200922.ebuild
+++ b/www-apps/tt-rss/tt-rss-20200922.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,21 @@ LICENSE="GPL-3"
KEYWORDS="~amd64 ~arm ~mips ~x86"
IUSE="+acl daemon gd +mysqli postgres"
REQUIRED_USE="|| ( mysqli postgres )"
-PHP_USE="gd?,mysqli?,postgres?,curl,fileinfo,intl,json,pdo,unicode,xml"
+
+PHP_SLOTS="7.4 7.3 7.2"
+PHP_USE="gd?,mysqli?,postgres?,curl,fileinfo,intl,json(+),pdo,unicode,xml"
+
+php_rdepend() {
+ local slot
+ echo "|| ("
+ for slot in ${PHP_SLOTS}; do
+ echo "(
+ virtual/httpd-php:${slot}
+ dev-lang/php:${slot}[$1]
+ )"
+ done
+ echo ")"
+}
DEPEND="
daemon? ( acl? ( sys-apps/acl ) )
@@ -23,12 +37,11 @@ RDEPEND="
daemon? (
acct-user/ttrssd
acct-group/ttrssd
- dev-lang/php:*[${PHP_USE},cli,pcntl]
+ $(php_rdepend "${PHP_USE},cli,pcntl")
)
!daemon? (
- dev-lang/php:*[${PHP_USE}]
+ $(php_rdepend "${PHP_USE}")
)
- virtual/httpd-php:*
"
DEPEND="
diff --git a/www-apps/tt-rss/tt-rss-99999999.ebuild b/www-apps/tt-rss/tt-rss-99999999.ebuild
index 9a62a5c6ac7a..c543f510ec92 100644
--- a/www-apps/tt-rss/tt-rss-99999999.ebuild
+++ b/www-apps/tt-rss/tt-rss-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,21 @@ LICENSE="GPL-3"
SLOT="${PV}" # Single live slot.
IUSE="+acl daemon gd +mysqli postgres"
REQUIRED_USE="|| ( mysqli postgres )"
-PHP_USE="gd?,mysqli?,postgres?,curl,fileinfo,intl,json,pdo,unicode,xml"
+
+PHP_SLOTS="7.4 7.3 7.2"
+PHP_USE="gd?,mysqli?,postgres?,curl,fileinfo,intl,json(+),pdo,unicode,xml"
+
+php_rdepend() {
+ local slot
+ echo "|| ("
+ for slot in ${PHP_SLOTS}; do
+ echo "(
+ virtual/httpd-php:${slot}
+ dev-lang/php:${slot}[$1]
+ )"
+ done
+ echo ")"
+}
DEPEND="
daemon? ( acl? ( sys-apps/acl ) )
@@ -23,12 +37,11 @@ RDEPEND="
daemon? (
acct-user/ttrssd
acct-group/ttrssd
- dev-lang/php:*[${PHP_USE},cli,pcntl]
+ $(php_rdepend "${PHP_USE},cli,pcntl")
)
!daemon? (
- dev-lang/php:*[${PHP_USE}]
+ $(php_rdepend "${PHP_USE}")
)
- virtual/httpd-php:*
"
DEPEND="