summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-11-03 19:03:56 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2022-11-03 23:23:54 +0100
commitb349d5d8e51cde8feaa50bebcd1a8a954fb89538 (patch)
treea191bd15d6604ede66d2ff691d52775bc1ed4efc /www-apps
parentdev-java/log4j-over-slf4j: add github upstream metadata (diff)
downloadgentoo-b349d5d8e51cde8feaa50bebcd1a8a954fb89538.tar.gz
gentoo-b349d5d8e51cde8feaa50bebcd1a8a954fb89538.tar.bz2
gentoo-b349d5d8e51cde8feaa50bebcd1a8a954fb89538.zip
www-apps/nextcloud: add 23.0.11, 24.0.7, 25.0.1
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/nextcloud/Manifest3
-rw-r--r--www-apps/nextcloud/nextcloud-23.0.11.ebuild43
-rw-r--r--www-apps/nextcloud/nextcloud-24.0.7.ebuild43
-rw-r--r--www-apps/nextcloud/nextcloud-25.0.1.ebuild43
4 files changed, 132 insertions, 0 deletions
diff --git a/www-apps/nextcloud/Manifest b/www-apps/nextcloud/Manifest
index ed7b18254cb3..876a678b52e5 100644
--- a/www-apps/nextcloud/Manifest
+++ b/www-apps/nextcloud/Manifest
@@ -1,3 +1,6 @@
DIST nextcloud-23.0.10.tar.bz2 141026523 BLAKE2B 52e2962c1bd8075a64b10e792b18f7e18688c4a1227ef71cfbc85fe743a924ead8a78c3ed95396c37c3c85fa9a848eb3017d0c818294bbad35d679cc0844b0a5 SHA512 be4cfcd728db5c492da68c5aad29caab926673ad623ef3050c8f193d58164aaea04679f63e01eaf59652f0f6d8237c64fb38e66a08fd35e0e43b10f2b67b4d64
+DIST nextcloud-23.0.11.tar.bz2 141705816 BLAKE2B fa1232ab9263e6964ceb1cd45941187db1af331cb1e4f0f149e5638f6813a7b19b838f64eec234dc2e8c7182b4aeb2d8abb61051d0ddb314ec04198f80c44a3d SHA512 094abe8eabe6746cea616db95739513c3832f8e823931abfd7dc83b8e8ecf49c4444fe478727e79b17bca5b16990cd0c95211476180e0382f45e07e5b51b6f49
DIST nextcloud-24.0.6.tar.bz2 123902888 BLAKE2B 145d3b3c9527ac950f12a88cd02085c566d3d8e224d7ec099bcb9e519c3d2854954b23ea27ee62ff2ae3032d3788bb494b38ef1fc26bc9cf3991e0fd864120d0 SHA512 15c45f8ae4ee9e03c35f8aef6549b9fe92984dac4345406bbc95eec9099912f10a9ad8a7b73c001cc96294d2d136259acc4003d6610c47254ca5cac9d701343d
+DIST nextcloud-24.0.7.tar.bz2 124233139 BLAKE2B 991668bf897984da0f0034f954d0077779159acc6b27447603decc79bb79d6457f98cf8324e18f2ab3dda76cbbde63bc43d3ee2f1ff918d227c8256d8f3e8789 SHA512 77c1999b52ab87779908619ec8845887c9da32f90d9eb1e639d07c3899519235a18d973a35a8bfbfe9f896c7b7705cc91d571558700550857f741f98a85a52ef
DIST nextcloud-25.0.0.tar.bz2 144109342 BLAKE2B a339f5bf01255cccdbb9941d360e091a34149e6d3a365497344911c8f156cd7b272ed657fe48720054c448c3e52fafec37dbe0cd69be42f424479d35dd90e547 SHA512 6f7a7a4e7b613df7b246bf9a582a15598d40a96023bdde1d8e3fff1b5888588d9c957f58ea813470696edc7c1ad5e8d1721d5eaa3d9c91549ca8acc411a8211e
+DIST nextcloud-25.0.1.tar.bz2 146695370 BLAKE2B 01d9482301fa50e2b938cbe164310d0e3db3a791944e78ef2d7016ecd3e214907d53b589abc51c550263e636c114ee37dd027ebf3d164493c53775a10f102a61 SHA512 7fd401ffe01e5b1d568e4f66cdc5972d5e3c0b82f147a04330da9fe5ab1f2ddf152943e28f152fb635e8bca8d83a95a5a269a1f34fa189cef4a3c9dbe4e8c89b
diff --git a/www-apps/nextcloud/nextcloud-23.0.11.ebuild b/www-apps/nextcloud/nextcloud-23.0.11.ebuild
new file mode 100644
index 000000000000..ae0486c3b736
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-23.0.11.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="<dev-lang/php-8.1[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}
diff --git a/www-apps/nextcloud/nextcloud-24.0.7.ebuild b/www-apps/nextcloud/nextcloud-24.0.7.ebuild
new file mode 100644
index 000000000000..e35dd132e50a
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-24.0.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="<dev-lang/php-8.2[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}
diff --git a/www-apps/nextcloud/nextcloud-25.0.1.ebuild b/www-apps/nextcloud/nextcloud-25.0.1.ebuild
new file mode 100644
index 000000000000..e35dd132e50a
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-25.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="<dev-lang/php-8.2[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}