summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-07-07 10:49:29 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-07-07 10:56:40 -0500
commitb4958d98994d79cc401b8af371d78f1239c32f3e (patch)
treef071dc997fd1600743d2cce257d38e827faf1833 /www-apps
parentsys-fs/lvm2: fix segfault on musl (diff)
downloadgentoo-b4958d98994d79cc401b8af371d78f1239c32f3e.tar.gz
gentoo-b4958d98994d79cc401b8af371d78f1239c32f3e.tar.bz2
gentoo-b4958d98994d79cc401b8af371d78f1239c32f3e.zip
www-apps/icingaweb2: 2.11.1 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.11.1.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 8232c190adc2..41e9abbaac7b 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -2,3 +2,4 @@ DIST icingaweb2-2.10.1.tar.gz 11490414 BLAKE2B 897d5dcb4774db42651b53937f2bf8081
DIST icingaweb2-2.10.2.tar.gz 11489780 BLAKE2B 4135e798afba7e7ea457ac00add5cd4ff14d9572ce6ffa50c8dc29ba43435e9305b9c2f52187bc50fc25f3def730c01c682a9ef80afdc79676a5d0c27dd87297 SHA512 e0e7f4f24c5609ccc0b1b0773fc018632bdd8d879311968e7b72cca1a856f227af3e6ff3e916b8bcdfc8c24c60d32008c6fee53ebac8d3a08328ded88baa3c00
DIST icingaweb2-2.10.3.tar.gz 11490948 BLAKE2B ab7c3d0772224162f8eb106618c10398737f163850ef82f2d1ca75c6fc07b2640b2bed813a7007866886ddf7b5a20cf631ea95164b0e3c3d051d70f62f3a660d SHA512 f881f91ffaf46a8e5be67414c8d38982132085dfba56a7c1033b2d2e1689de2f37a00e83d3890410f03dc5f12101d051dc8d75617d952c30d487f98e5cc78067
DIST icingaweb2-2.11.0.tar.gz 11411511 BLAKE2B f7b550a73bd0ff9770700a3a8cab1b02c88a57ed4bbb2e120df379bf897fb21d838a968f9d4d83e6a38d32578655d2670734f66e3c0dc8215fe5295d46ebc191 SHA512 e76e01262cb5b4ac43504349262660d85306205e0599bb0c8afd6a1d9f3240d659dd5cfdc35a6b9e2498ad16864a6024d0dac46faed4473da70be461a1db9f8e
+DIST icingaweb2-2.11.1.tar.gz 11410186 BLAKE2B 6211dac560ab7acd4b37b056ab32fa73d21521f5bb02509b63d703e986761e617c1304ff71c22fc1b0d820cabf4e1264d13847142daee7da5cc5644fb4164a67 SHA512 3df41958de29e6099acfbf002b9cf68da535cfd5400397e03d3ea59083ee68b8084c1cea85ae31cb6134cef2a2b39c18b53cabcbdf436e7ddc14f0ddbcd61997
diff --git a/www-apps/icingaweb2/icingaweb2-2.11.1.ebuild b/www-apps/icingaweb2/icingaweb2-2.11.1.ebuild
new file mode 100644
index 000000000000..078757090855
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.11.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit depend.apache multilib
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
+REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2-server? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )
+ || (
+ dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.4[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:8.0[apache2?,cli,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:8.1[apache2?,cli,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ dev-libs/icinga-php-library
+ dev-libs/icinga-php-thirdparty
+ acct-group/icingacmd
+ acct-group/icingaweb2"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+ fowners root:icingaweb2 "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}