summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-01-28 07:59:26 +0000
committerSam James <sam@gentoo.org>2022-01-28 08:36:24 +0000
commitb99cef1a2a037cfa00af093831ad30d3fae38e6c (patch)
tree8e2317c1d7f97d3a25b6b0aa83e1423ed84c917c /www-apps
parentapp-misc/elasticsearch: drop old (diff)
downloadgentoo-b99cef1a2a037cfa00af093831ad30d3fae38e6c.tar.gz
gentoo-b99cef1a2a037cfa00af093831ad30d3fae38e6c.tar.bz2
gentoo-b99cef1a2a037cfa00af093831ad30d3fae38e6c.zip
www-apps/kibana-bin: bump to 6.8.23/7.16.3
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/kibana-bin/Manifest3
-rw-r--r--www-apps/kibana-bin/kibana-bin-6.8.23.ebuild89
-rw-r--r--www-apps/kibana-bin/kibana-bin-7.16.3.ebuild91
3 files changed, 183 insertions, 0 deletions
diff --git a/www-apps/kibana-bin/Manifest b/www-apps/kibana-bin/Manifest
index 78c460cdc98b..dc1f346c8514 100644
--- a/www-apps/kibana-bin/Manifest
+++ b/www-apps/kibana-bin/Manifest
@@ -1,3 +1,6 @@
DIST kibana-6.8.22-linux-x86_64.tar.gz 186925815 BLAKE2B c3a5ed661991f7646f9f59a709bb4c3d940b13e7d32beb9f4862b5c1d6ad63b6af0730713463e54e427cb7f488acc3446f4eec28b23cc7ef07f9b7da385161ee SHA512 4a7b74ba93255bbef9255e30f373addb6bb231c364cf367281120c564d00923ab87356e936d4a49165bab8dc50d34ee38728099f40bea26fe76d464a05c7968c
+DIST kibana-6.8.23-linux-x86_64.tar.gz 186911401 BLAKE2B 4d0894b88c855bc64ed648489d8c7293965a6edee0ebb841f22c5779592a282dc6af800f39bcd4fd710242aa63365165616bd7a2cf17e8ca0a6560c7bc604256 SHA512 15226207e3606637fe5004bf7b994fa8d09a0b2860881f7539a70872e5480c6614a6181fbb1ec0effa24380bd7721a8bdd87dea152e628c6577684c1b13ee0a2
DIST kibana-7.16.2-linux-x86_64.tar.gz 280893546 BLAKE2B c2057e45823e373c7ac842e0f4d7782aad398cc662aca801eb6cd2a792a5826b5e212c836f14d07bf451fd2d6b8f87bec481b03c2fb9afa8c26ce5054e6d54d9 SHA512 4c82f338b7e818db6e9e03c522d354286bc654e4dbe97529a3308ae27e510c5b4fcfa120371428867c49ed76dee06bf1386c47c8ceb7118bbddf09eed6e131ba
+DIST kibana-7.16.3-linux-x86_64.tar.gz 281044755 BLAKE2B f308f60615f66a7139ae4e39172900c571c6000879aa2c47f6ba906098e12cb1e0f244af2289b870c6d35bf10ce59d6bd9395678243bd77365aea0b650cc27f5 SHA512 a08198dac16d62a0167a37ed58d73004535eec0fe21e0be8bb4926a2bfb1a69e8d8a679e1a7537dcad72d7a5f25c35c8a233da7dd130df01d2fa47b848d18ca3
DIST kibana-oss-6.8.22-linux-x86_64.tar.gz 67436490 BLAKE2B 1de996ea4ab2a7e0b77bf5b5c4c16bb235c9dd35814144f5cec77b662b2b81f05e8c47db7dd5b65c9d58c46ce56232710f3e5f892ad91c6ca0bda9ba37dd1bc4 SHA512 30a19e8ff87f590aefa607db3f55d53acc41077768e0239933c2cbaedd1abffa05c6df96b575f22b3b1151ef6f1a5ed860fc0e53f87ecaa1239c5564e7a7c4bf
+DIST kibana-oss-6.8.23-linux-x86_64.tar.gz 67419004 BLAKE2B e7d7be6947cdb3d19efae9ca4113d22a70d3354632c57df266f0dff0b367caa01e3e0ee797ed6330f59cf4d4de63c7985c3504b0914445fb18ab696cbbaf98c1 SHA512 f6ffd8e8f957e08a6783b3decbab0f85654eb1386d7135e76c25799c76524957aa250f8bae43b220c0f14616071a63f5132ca73145d5a44ac8a52d106403a530
diff --git a/www-apps/kibana-bin/kibana-bin-6.8.23.ebuild b/www-apps/kibana-bin/kibana-bin-6.8.23.ebuild
new file mode 100644
index 000000000000..0c16c09d3126
--- /dev/null
+++ b/www-apps/kibana-bin/kibana-bin-6.8.23.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+MY_PN="${PN%-bin}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Analytics and search dashboard for Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/kibana"
+SRC_URI="x-pack? ( https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}-linux-x86_64.tar.gz )
+ !x-pack? ( https://artifacts.elastic.co/downloads/${MY_PN}/${MY_PN}-oss-${PV}-linux-x86_64.tar.gz )"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 Artistic-2 BSD BSD-2 CC-BY-3.0 CC-BY-4.0 icu ISC MIT MPL-2.0 OFL-1.1 openssl public-domain Unlicense WTFPL-2 ZLIB x-pack? ( Elastic )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="x-pack"
+
+RDEPEND="
+ acct-group/kibana
+ acct-user/kibana
+ >=net-libs/nodejs-10.15.2
+ <net-libs/nodejs-14
+ x-pack? (
+ dev-libs/expat
+ dev-libs/nss
+ )"
+
+S="${WORKDIR}/${MY_P}-linux-x86_64"
+
+src_prepare() {
+ default
+
+ # remove empty unused directory
+ rmdir data || die
+
+ # remove bundled nodejs
+ rm -r node || die
+
+ # move optimize/plugins to /var/lib/kibana
+ rm -r optimize plugins || die
+
+ # handle node.js version with RDEPEND
+ sed -i /node_version_validator/d src/setup_node_env/index.js || die
+}
+
+src_install() {
+ insinto /etc/${MY_PN}
+ doins -r config/.
+ rm -r config || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${MY_PN}.logrotate ${MY_PN}
+
+ newconfd "${FILESDIR}"/${MY_PN}.confd ${MY_PN}
+ newinitd "${FILESDIR}"/${MY_PN}.initd ${MY_PN}
+ systemd_dounit "${FILESDIR}"/${MY_PN}.service
+
+ insinto /opt/${MY_PN}
+ doins -r .
+
+ fperms -R +x /opt/${MY_PN}/bin
+
+ diropts -m 0750 -o ${MY_PN} -g ${MY_PN}
+ keepdir /var/lib/${MY_PN}/optimize
+ keepdir /var/lib/${MY_PN}/plugins
+ keepdir /var/log/${MY_PN}
+
+ dosym ../../var/lib/kibana/optimize /opt/kibana/optimize # Bug 667214
+ dosym ../../var/lib/kibana/plugins /opt/kibana/plugins
+}
+
+pkg_postinst() {
+ ewarn "Kibana optimize/plugins directories were moved to /var/lib/kibana."
+ ewarn "In case of startup failures (FATAL Error: Cannot find module...),"
+ ewarn "please remove the optimize directory content:"
+ ewarn "rm -r /var/lib/kibana/optimize/*"
+ elog "This version of Kibana is compatible with Elasticsearch $(ver_cut 1-2) and"
+ elog "Node.js 10. Some plugins may fail with other versions of Node.js (Bug #656008)."
+ elog
+ elog "To set a customized Elasticsearch instance:"
+ elog " OpenRC: set ES_INSTANCE in /etc/conf.d/${MY_PN}"
+ elog " systemd: set elasticsearch.url in /etc/${MY_PN}/kibana.yml"
+ elog
+ elog "Elasticsearch can run local or remote."
+}
diff --git a/www-apps/kibana-bin/kibana-bin-7.16.3.ebuild b/www-apps/kibana-bin/kibana-bin-7.16.3.ebuild
new file mode 100644
index 000000000000..d13809c0d99b
--- /dev/null
+++ b/www-apps/kibana-bin/kibana-bin-7.16.3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+MY_PN="${PN%-bin}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Analytics and search dashboard for Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/kibana"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}-linux-x86_64.tar.gz"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 Artistic-2 BSD BSD-2 CC-BY-3.0 CC-BY-4.0 Elastic-2.0 icu ISC MIT MPL-2.0 OFL-1.1 openssl public-domain Unlicense WTFPL-2 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ acct-group/kibana
+ acct-user/kibana
+ dev-libs/expat
+ dev-libs/nss
+ >=net-libs/nodejs-16.13.0
+"
+
+# Do not complain about CFLAGS etc since we don't use them
+QA_FLAGS_IGNORED='.*'
+QA_PRESTRIPPED="
+ opt/kibana/x-pack/plugins/reporting/chromium/headless_shell-linux_x64/headless_shell
+ opt/kibana/x-pack/plugins/reporting/chromium/headless_shell-linux_x64/swiftshader/libEGL.so
+ opt/kibana/x-pack/plugins/reporting/chromium/headless_shell-linux_x64/swiftshader/libGLESv2.so
+ opt/kibana/node_modules/re2/build/Release/re2.node
+"
+
+S="${WORKDIR}/${MY_P}-linux-x86_64"
+
+src_prepare() {
+ default
+
+ # remove unused directory
+ rm -r data || die
+
+ # remove bundled nodejs
+ rm -r node || die
+ sed -i 's@\(^NODE="\).*@\1/usr/bin/node"@g' \
+ bin/kibana || die
+
+ # move plugins to /var/lib/kibana
+ rm -r plugins || die
+
+ # handle node.js version with RDEPEND
+ sed -i /node_version_validator/d \
+ src/setup_node_env/no_transpilation_dist.js || die
+}
+
+src_install() {
+ insinto /etc/${MY_PN}
+ doins -r config/.
+ rm -r config || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${MY_PN}.logrotate ${MY_PN}
+
+ newconfd "${FILESDIR}"/${MY_PN}.confd ${MY_PN}
+ newinitd "${FILESDIR}"/${MY_PN}.initd-r1 ${MY_PN}
+ systemd_dounit "${FILESDIR}"/${MY_PN}.service
+
+ insinto /opt/${MY_PN}
+ doins -r .
+
+ fperms -R +x /opt/${MY_PN}/bin
+
+ diropts -m 0750 -o ${MY_PN} -g ${MY_PN}
+ keepdir /var/lib/${MY_PN}/plugins
+ keepdir /var/log/${MY_PN}
+
+ dosym ../../var/lib/kibana/plugins /opt/kibana/plugins
+}
+
+pkg_postinst() {
+ elog "This version of Kibana is compatible with Elasticsearch $(ver_cut 1-2) and"
+ elog "Node.js 16. Some plugins may fail with other versions of Node.js (Bug #656008)."
+ elog
+ elog "To set a customized Elasticsearch instance:"
+ elog " OpenRC: set ES_INSTANCE in /etc/conf.d/${MY_PN}"
+ elog " systemd: set elasticsearch.url in /etc/${MY_PN}/kibana.yml"
+ elog
+ elog "Elasticsearch can run local or remote."
+}