summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2021-01-26 12:07:10 -0500
committerAaron Bauman <bman@gentoo.org>2021-01-26 12:07:10 -0500
commitc34372ca9cd26e1ed6126ad8351cfb6fbe6fec21 (patch)
treebc5f38775e50970c5bea3b0b4bb99a17534fa088 /www-apps
parentdev-ros/ament_cmake_version: bump to 1.0.4 (diff)
downloadgentoo-c34372ca9cd26e1ed6126ad8351cfb6fbe6fec21.tar.gz
gentoo-c34372ca9cd26e1ed6126ad8351cfb6fbe6fec21.tar.bz2
gentoo-c34372ca9cd26e1ed6126ad8351cfb6fbe6fec21.zip
www-apps/jekyll: drop patch and bump watch dep
* Drop patch/workaround for missing listener gem. Thanks to graaff for identifying and fixing the issue in jekyll-watch Gemspec file * Bump www-apps/jekyll-watch to 2.2.1-r1 * Drop patch jekyll-missingdep.patch Suggested-by: Hans de Graaff <graaff@gentoo.org> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/jekyll/files/jekyll-missingdep.patch14
-rw-r--r--www-apps/jekyll/jekyll-4.2.0-r1.ebuild93
2 files changed, 93 insertions, 14 deletions
diff --git a/www-apps/jekyll/files/jekyll-missingdep.patch b/www-apps/jekyll/files/jekyll-missingdep.patch
deleted file mode 100644
index fcaf8f10e86f..000000000000
--- a/www-apps/jekyll/files/jekyll-missingdep.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/jekyll.gemspec 2021-01-26 04:08:18.198289608 +0200
-+++ b/jekyll.gemspec 2021-01-26 04:09:08.545548043 +0200
-@@ -41,9 +41,11 @@
- s.add_runtime_dependency("kramdown", "~> 2.3")
- s.add_runtime_dependency("kramdown-parser-gfm", "~> 1.0")
- s.add_runtime_dependency("liquid", "~> 4.0")
-+ s.add_runtime_dependency("listen", "~> 3.4")
- s.add_runtime_dependency("mercenary", "~> 0.4.0")
- s.add_runtime_dependency("pathutil", "~> 0.9")
- s.add_runtime_dependency("rouge", "~> 3.0")
- s.add_runtime_dependency("safe_yaml", "~> 1.0")
- s.add_runtime_dependency("terminal-table", "~> 2.0")
-+
- end
diff --git a/www-apps/jekyll/jekyll-4.2.0-r1.ebuild b/www-apps/jekyll/jekyll-4.2.0-r1.ebuild
new file mode 100644
index 000000000000..40520250a3c6
--- /dev/null
+++ b/www-apps/jekyll/jekyll-4.2.0-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="README.markdown History.markdown"
+RUBY_FAKEGEM_EXTRAINSTALL="features"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+DESCRIPTION="A simple, blog aware, static site generator"
+HOMEPAGE="https://jekyllrb.com https://github.com/jekyll/jekyll"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/addressable-2.4
+ >=dev-ruby/colorator-1.0
+ >=dev-ruby/em-websocket-0.5
+ dev-ruby/i18n:1
+ >=dev-ruby/kramdown-2.1:2
+ dev-ruby/kramdown-parser-gfm:1
+ dev-ruby/liquid:4
+ >=dev-ruby/mercenary-0.4.0
+ >=dev-ruby/pathutil-0.9
+ =dev-ruby/rouge-3*
+ >=dev-ruby/safe_yaml-1.0
+ >=dev-ruby/terminal-table-1.8:0
+ >=www-apps/jekyll-sass-converter-2.0
+ >=www-apps/jekyll-watch-2.2.1-r1
+"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/classifier-reborn-2.1.0
+ dev-ruby/httpclient
+ dev-ruby/kramdown-syntax-coderay
+ dev-ruby/launchy
+ dev-ruby/nokogiri
+ >=dev-ruby/rdiscount-2.0
+ >=dev-ruby/redcarpet-3.2.3
+ dev-ruby/rspec-mocks
+ >=dev-ruby/shoulda-3
+ dev-ruby/test-unit:2
+ www-apps/jekyll-coffeescript
+ )
+"
+
+all_ruby_prepare() {
+ eapply "${FILESDIR}"/jekyll-3.6.0-test-helper.patch
+
+ # Drop tests requiring bundler
+ sed -i -e '/bundle_message/d' test/test_new_command.rb || die
+ rm test/test_plugin_manager.rb || die
+
+ # Replace git command in gemspec
+ sed -e 's/git ls-files/find -not -type d -print/' \
+ -e 's:_relative ": "./:' \
+ -i $RUBY_FAKEGEM_GEMSPEC || die
+
+ # FIXMEs:
+ # fails to find fixtures because this requires bundler
+ rm test/test_theme.rb || die
+ rm test/test_theme_assets_reader.rb || die
+ sed -i -e '/^ should.*theme/,/^ end$/d' \
+ -e '/^ should.*theme/,/^ end$/d' test/test_site.rb || die
+ sed -i -e '/context "with a theme"/,/^ end/ s:^:#:' test/test_layout_reader.rb || die
+ sed -i -e '/normalize paths of rendered items/askip "test-theme"' test/test_liquid_renderer.rb || die
+ # partially requires 'toml'
+ rm test/test_configuration.rb || die
+ # pygments tests fail because of line numbering
+ sed -i -e '/^ context.*pygments/,/^ end$/d' test/test_tags.rb || die
+ #sed -i -e '/^ context.*pygments/,/^ end$/d' test/test_redcarpet.rb || die
+
+ # Tries to use bundler and install packages.
+ rm -f test/test_new_command.rb || die
+}
+
+src_test() {
+ local -x JEKYLL_NO_BUNDLER_REQUIRE=true
+
+ ruby-ng_src_test
+}