summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-06-07 21:54:22 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-06-07 21:56:15 -0500
commitc738fb4e40476a36153783605fca94cedd79e0f3 (patch)
tree885a8579da4bac4e25bcc4452647c7cc94490d5d /www-apps
parentapp-admin/rasdaemon: 0.6.7 bump (diff)
downloadgentoo-c738fb4e40476a36153783605fca94cedd79e0f3.tar.gz
gentoo-c738fb4e40476a36153783605fca94cedd79e0f3.tar.bz2
gentoo-c738fb4e40476a36153783605fca94cedd79e0f3.zip
www-apps/icingaweb2-module-director: 1.8.0 bump
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2-module-director/Manifest1
-rw-r--r--www-apps/icingaweb2-module-director/icingaweb2-module-director-1.8.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/www-apps/icingaweb2-module-director/Manifest b/www-apps/icingaweb2-module-director/Manifest
index f1b0b64a25cc..5a2dbdfbad0f 100644
--- a/www-apps/icingaweb2-module-director/Manifest
+++ b/www-apps/icingaweb2-module-director/Manifest
@@ -1 +1,2 @@
DIST icingaweb2-module-director-1.6.2.tar.gz 2772722 BLAKE2B 3d51f68469cd4ddf45f6bc62f76ad1f4c8d7d7bec36cc33022f1e0761334707bb345c87bc9f0e1276010e4a643867f1e1a6ea7c53a6fa28dd33e810089b7840b SHA512 693a2aca10e25f99fcf9ada4babb031d682b577b82098185259991214ac7d7662c494b58cf52284569dbca90c8eafa522177b6c64dd817912dafd20b4d7109cb
+DIST icingaweb2-module-director-1.8.0.tar.gz 3042572 BLAKE2B e29ac535c8975f79abfa086ce54e2b78e3f1a992858ec83e902c5e8e72a447f7436a1a9876c1b7237a14d08c54dec12069e9c57231b23c4fd203be3f6f2635b8 SHA512 e33cc49c8255aa3693f73693d874ca5e00a9d95fe3d737c457473d8c5b37f36faf44bbc7f608ba03be79d5a6fd032e5ffd8fbc824eda1831422f837040b0c400
diff --git a/www-apps/icingaweb2-module-director/icingaweb2-module-director-1.8.0.ebuild b/www-apps/icingaweb2-module-director/icingaweb2-module-director-1.8.0.ebuild
new file mode 100644
index 000000000000..890743ae7e0e
--- /dev/null
+++ b/www-apps/icingaweb2-module-director/icingaweb2-module-director-1.8.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Icinga Web 2 plugin for configuration"
+HOMEPAGE="https://dev.icinga.org/projects/icingaweb2-module-director/"
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-director.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ MY_PN="icingaweb2-module-director"
+ SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=net-analyzer/icinga2-2.4.3
+ >=www-apps/icingaweb2-2.2.0
+ || (
+ dev-lang/php:5.6[curl]
+ dev-lang/php:7.1[curl]
+ dev-lang/php:7.2[curl]
+ dev-lang/php:7.3[curl]
+ )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/director/"
+ doins -r "${S}"/*
+}